[PATCH] gnu: Add mrbayes.

  • Open
  • quality assurance status badge
Details
2 participants
  • M?d?lin Ionel Patra?cu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
M?d?lin Ionel Patra?cu
Severity
normal
M
M
M?d?lin Ionel Patra?cu wrote on 11 Aug 2022 10:30
(address . guix-patches@gnu.org)
20220811083010.25264-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (mrbayes): New variable.
---
gnu/packages/bioinformatics.scm | 67 +++++++++++++++++++++++++++++++++
1 file changed, 67 insertions(+)

Toggle diff (82 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3a40cc2281..ae362de1e7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11155,6 +11155,73 @@ (define-public mantis
(supported-systems '("x86_64-linux"))
(license license:bsd-3))))
+(define-public mrbayes
+ (package
+ (name "mrbayes")
+ (version "3.2.7a")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/NBISweden/MrBayes/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1c4qg4wd6lhj1if5g6462pk15bhh7v84ys92sp47yih7lrkk2jd6"))))
+ (properties `((upstream-name . "MrBayes")))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list automake
+ autoconf))
+ (home-page "https://github.com/NBISweden/MrBayes/")
+ (synopsis "Bayesian inference of phylogeny")
+ (description
+ "@code{MrBayes} is a program for Bayesian inference and model choice across
+a wide range of phylogenetic and evolutionary models. @code{MrBayes} uses @dfn{
+MCMC} (Markov chain Monte Carlo) methods to estimate the posterior distribution
+of model parameters. Program features include:
+@itemize
+@item
+analysis of nucleotide, amino acid, restriction site, and morphological data;
+@item
+mixing of data types, such as molecular and morphological characters, in a single
+analysis;
+@item
+easy linking and unlinking of parameters across data partitions;
+@item
+multiple evolutionary models, including 4x4, doublet, and codon models for
+nucleotide data and many of the standard rate matrices for amino acid data;
+@item
+estimation of positively selected sites in a fully hierarchical Bayesian framework;
+@item
+full integration of the @code{BEST} algorithms for the multi-species coalescent;
+@item
+estimation of time calibrated (clock) trees using a variety of (strict and)
+relaxed-clock models;
+@item
+support for complex combinations of positive, negative, and backbone constraints
+on topologies;
+@item
+model jumping across the @code{GTR} model space and across fixed rate matrices
+for amino acid data;
+@item
+monitoring of convergence during the analysis, and access to a wide range of
+convergence diagnostics tools after the analysis has finished;
+@item
+rich summaries of posterior samples of branch and node parameters printed to
+majority rule consensus trees in FigTree format;
+@item
+implementation of the stepping-stone method for accurate estimation of model
+likelihoods for Bayesian model choice using Bayes factors;
+@item
+ability to spread jobs over a cluster of computers using @code{MPI} (for
+Macintosh and UNIX environments only);
+@item
+support for the @code{BEAGLE} library, resulting in dramatic speedups for codon
+and amino acid models on compatible hardware (NVIDIA graphics cards);
+@end itemize")
+ (license license:gpl3)))
+
(define-public sjcount
;; There is no tag for version 3.2, nor is there a release archive.
(let ((commit "292d3917cadb3f6834c81e509c30e61cd7ead6e5")

base-commit: 6ce3e51aa876681967177812dc295c86a50d7446
--
2.37.1
R
R
Ricardo Wurmus wrote on 18 Aug 2022 22:42
(name . M?d?lin Ionel Patra?cu)(address . madalinionel.patrascu@mdc-berlin.de)
871qtd46tj.fsf@elephly.net
Hi M?d?lin,

Toggle quote (2 lines)
> * gnu/packages/bioinformatics.scm (mrbayes): New variable.

Thanks for the patch.

Unfortunately, there are a few problems.

- you added autoconf and automake, but neither of these is used as the
git checkout includes a pre-built “configure” script and “Makefile.in”

- we cannot use the “configure” script as is, because the build system
uses AX_EXT, which unconditionally adds -msse* compiler flags when the
CPU on the build node supports these features. This means that we
cannot build a generic binary. The build system ignores
“--disable-sse”, “--disable-avx”, and “--disable-fma” because of
AX_EXT.

- we cannot rebuild the “configure” script because the bootstrap phase
fails with an error. Adding pkg-config to the native inputs does not
seem to fix this either, so more investigation is needed.

- consider adding openmpi and use --enable-mpi.

- consider shortening the description. Especially the parts that
mention proprietary software or trademarks (UNIX and Macintosh, as
well as NVIDIA) should be removed.

Could you please revise this and send an updated patch?

--
Ricardo
Attachment: wip.diff
R
R
Ricardo Wurmus wrote on 4 Nov 2022 12:46
(address . control@debbugs.gnu.org)
87o7tn54dl.fsf@elephly.net
tags 55725 moreinfo
tags 57135 moreinfo
thanks

--
Ricardo
?