home: services: Broken openssh service.

  • Done
  • quality assurance status badge
Details
3 participants
  • Oleg Pykhalov
  • Joshua Branson
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Oleg Pykhalov
Severity
normal
O
O
Oleg Pykhalov wrote on 10 Aug 2022 13:39
(name . bug-guix)(address . bug-guix@gnu.org)
87k07gqqdq.fsf@gmail.com
home ssh service is broken on:
Toggle snippet (8 lines)
$ guix describe
Generation 33 Aug 10 2022 10:50:55 (current)
guix b72459a
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: b72459a861d7029d69e9e3ffe3dd411b452e26de

home.scm:
Toggle snippet (14 lines)
(use-modules (gnu services)
(gnu home services ssh))

(home-environment
(services
(list
(service home-openssh-service-type
(home-openssh-configuration
(hosts
(list
(openssh-host (name "git.sv.gnu.org")
(user "wigust")))))))))

Toggle snippet (4 lines)
$ guix home build home.scm
/home/oleg/home.scm:11:15: error: invalid value unset for field 'address-family'

Oleg.
-----BEGIN PGP SIGNATURE-----

iQJIBAEBCgAyFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAmLzmPEUHGdvLndpZ3Vz
dEBnbWFpbC5jb20ACgkQFn+OpQAa+pzzYw//SpXMbJOXBwnI7NRZMuS+HBoo+8qw
ph58WUaCYIn536f42ZOlJTC7sFhOdtSOIDAEyoRsxFQTg6fZCnMxtXG+ImFHMDk9
j49L3nwihLXKetYBoHsfUU+M1A9b/380kiOBTEBizOzng3Jkvev8cj2YY5U/2BI3
0vekucq3yFtAK5s6q6jdN0q+0ckcqCOgUM8TusiENpb0CtafspEhy04uBgyPKkcp
F/hHRKHfAnN1AP8QbBb808wWP94kbEXRXczZtvgq2aD6nfiBtSIWyMlPmw63uWmH
mzvY8VIOxgyDfTaIUq/bjk/AqcCJ03Cpog970XWfx4/VywpgIv9MK0WnpH5AB1E4
oe1whSQGPND99WGpVjPuy8G4g+IZcr1gE9jWde93Iq8lM4SHv6JBTxgTXerzz/bc
PLA5f5zHOoMm3poenyk4tYN1m+OkKPFrihN3DZ++tQZpO1l1Ph/foSA7txZzgJXc
fYjv6aX9bksyJbwcqlCgigYqxzBx614vbUUBh/LMIuhNDeZgiVoaI/yZjcqcQnAr
F0wDH0KaDQxNX6f53k+eihHXsvfN29LFfyuBFUxdBUASe4nH9YBCcBoQu0vhU21o
dDZRcPyd5SZfGShZUNOoS9W1izi2FEhQuyKvRxiIo8ZL5sDw8oBmJeOrtErtiE/H
hFJJer+pc9MOH/Q=
=2Msf
-----END PGP SIGNATURE-----

M
M
Maxim Cournoyer wrote on 10 Aug 2022 15:13
(name . Oleg Pykhalov)(address . go.wigust@gmail.com)(address . 57110-done@debbugs.gnu.org)
87sfm4kzqx.fsf@gmail.com
Hi,

Oleg Pykhalov <go.wigust@gmail.com> writes:

Toggle quote (28 lines)
> home ssh service is broken on:
>
> $ guix describe
> Generation 33 Aug 10 2022 10:50:55 (current)
> guix b72459a
> repository URL: https://git.savannah.gnu.org/git/guix.git
> branch: master
> commit: b72459a861d7029d69e9e3ffe3dd411b452e26de
>
>
> home.scm:
>
> (use-modules (gnu services)
> (gnu home services ssh))
>
> (home-environment
> (services
> (list
> (service home-openssh-service-type
> (home-openssh-configuration
> (hosts
> (list
> (openssh-host (name "git.sv.gnu.org")
> (user "wigust")))))))))
>
> $ guix home build home.scm
> /home/oleg/home.scm:11:15: error: invalid value unset for field 'address-family'

Fixed with d9a0ccf13f. Sorry for the breakage!

Maxim
Closed
J
J
Joshua Branson wrote on 14 Aug 2022 00:58
(address . 57110@debbugs.gnu.org)
87edxjn42n.fsf@dismail.de
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (21 lines)
> Hi,
>
> Oleg Pykhalov <go.wigust@gmail.com> writes:
>
>> home ssh service is broken on:
>>
>> $ guix describe
>> Generation 33 Aug 10 2022 10:50:55 (current)
>> guix b72459a
>> repository URL: https://git.savannah.gnu.org/git/guix.git
>> branch: master
>> commit: b72459a861d7029d69e9e3ffe3dd411b452e26de
>>
>>
>
> Fixed with d9a0ccf13f. Sorry for the breakage!
>
>
> Maxim


Wow a fix provided in one day! Maxim how!? I am having a hard time
just cleaning my room! :)
M
M
Maxim Cournoyer wrote on 14 Aug 2022 03:18
(name . Joshua Branson)(address . jbranso@dismail.de)
87edxjd3n2.fsf@gmail.com
Hi Joshua,

Joshua Branson <jbranso@dismail.de> writes:

Toggle quote (26 lines)
> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> Hi,
>>
>> Oleg Pykhalov <go.wigust@gmail.com> writes:
>>
>>> home ssh service is broken on:
>>>
>>> $ guix describe
>>> Generation 33 Aug 10 2022 10:50:55 (current)
>>> guix b72459a
>>> repository URL: https://git.savannah.gnu.org/git/guix.git
>>> branch: master
>>> commit: b72459a861d7029d69e9e3ffe3dd411b452e26de
>>>
>>>
>>
>> Fixed with d9a0ccf13f. Sorry for the breakage!
>>
>>
>> Maxim
>
>
> Wow a fix provided in one day! Maxim how!? I am having a hard time
> just cleaning my room! :)

The root problem is more easily understood when you're the one having
caused it, ah!

Maxim
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57110@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57110
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch