arm-none-eabi-toolchain atomic support is broken

  • Open
  • quality assurance status badge
Details
2 participants
  • Jean Pierre De Jesus DIAZ
  • Csepp
Owner
unassigned
Submitted by
Jean Pierre De Jesus DIAZ
Severity
normal
J
J
Jean Pierre De Jesus DIAZ wrote on 10 Aug 2022 13:14
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
FxrTtbkN-kgBnsg2G8jk10dUAf5LGSIhQQKxosEukaNtGlCbHPCXA3HyNf6hzdYYe-qIRF6DlER0-Ma2XjMmzN8GDcwYPNP-5LylnDLavcY=@jeandudey.tech
The atomic supports for this toolchain is broken:

A minimal test case:

guix shell arm-none-eabi-toolchain -- \
bash -c "echo '#include <stdatomic.h>' \
| arm-none-eabi-gcc -x c -o /dev/null -c -"

Something similar found online:


However no solution.

This happens with all versions of the arm-none-eabi-toolchain
packages.

Jean-Pierre De Jesus DIAZ
J
J
Jean Pierre De Jesus DIAZ wrote on 16 Aug 2022 16:14
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
W3bwtjXOE9kR8_Y5FAONpXogV-HS5-FwbXBLauTFI0N5PN6CVuez0dh2ToQBJGSb02mCOLJ0CPotmEtWG-1LbWZON4no9bk6H1yqT4yeh10=@jeandudey.tech
The following works though. No newlib or anything:

guix shell --expression='((@ (gnu packages cross-base) cross-gcc) "arm-none-eabi")' -- \
bash -c "echo '#include <stdatomic.h>' \
| arm-none-eabi-gcc -x c -o /dev/null -c -"


Jean-Pierre De Jesus DIAZ


------- Original Message -------
On Wednesday, August 10th, 2022 at 1:14 PM, Jean Pierre De Jesus DIAZ <me@jeandudey.tech> wrote:


Toggle quote (20 lines)
> The atomic supports for this toolchain is broken:
>
> A minimal test case:
>
> guix shell arm-none-eabi-toolchain -- \
> bash -c "echo '#include <stdatomic.h>' \
>
> | arm-none-eabi-gcc -x c -o /dev/null -c -"
>
> Something similar found online:
>
> https://sourceware.org/legacy-ml/newlib/2017/msg00150.html
>
> However no solution.
>
> This happens with all versions of the arm-none-eabi-toolchain
> packages.
>
> —
> Jean-Pierre De Jesus DIAZ
C
Re: bug#57109: arm-none-eabi-toolchain atomic support is broken
(name . Jean Pierre De Jesus DIAZ)(address . me@jeandudey.tech)
878rnlbpbe.fsf@riseup.net
Jean Pierre De Jesus DIAZ via Bug reports for GNU Guix <bug-guix@gnu.org> writes:

Toggle quote (36 lines)
> The following works though. No newlib or anything:
>
> guix shell --expression='((@ (gnu packages cross-base) cross-gcc) "arm-none-eabi")' -- \
> bash -c "echo '#include <stdatomic.h>' \
> | arm-none-eabi-gcc -x c -o /dev/null -c -"
>
>
> —
> Jean-Pierre De Jesus DIAZ
>
>
> ------- Original Message -------
> On Wednesday, August 10th, 2022 at 1:14 PM, Jean Pierre De Jesus DIAZ <me@jeandudey.tech> wrote:
>
>
>> The atomic supports for this toolchain is broken:
>>
>> A minimal test case:
>>
>> guix shell arm-none-eabi-toolchain -- \
>> bash -c "echo '#include <stdatomic.h>' \
>>
>> | arm-none-eabi-gcc -x c -o /dev/null -c -"
>>
>> Something similar found online:
>>
>> https://sourceware.org/legacy-ml/newlib/2017/msg00150.html
>>
>> However no solution.
>>
>> This happens with all versions of the arm-none-eabi-toolchain
>> packages.
>>
>> —
>> Jean-Pierre De Jesus DIAZ

Might be a good idea to add a (regression) test for this in advance.
Wish I could help, but my expermientation with cross compilation with
Guix were largely fruitless.
?