'guix style --whole-file' hangs indefinitely if parenthesis is unmatched

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Mohammed AMAR-BENSABER
Owner
unassigned
Submitted by
Mohammed AMAR-BENSABER
Severity
normal
M
M
Mohammed AMAR-BENSABER wrote on 9 Aug 2022 23:25
(address . bug-guix@gnu.org)
6041017.lOV4Wx5bFT@siga
Hi,

guix style --whole-file package.scm hangs indefinitely if parenthesis is
unmatched. Relevant commit a15542d26df42dabdb5e2f76d150ae200230c3b0.

Here is an example package definition with missing a parenthesis.

(define-public vim-asyncrun
(package
(name "vim-asyncrun")
(version "2.8.6")
(source (origin
(method git-fetch)
(uri (git-reference
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32
"11zcw0sll6qg6ha0rr6n1cw5v73azvf7ycwn9lgiwa5cj7rrqjf4"))))
(build-system copy-build-system)
(arguments
'(#:install-plan
'(("plugin" "share/vim/vimfiles/")
("doc/" "share/vim/vimfiles/doc" #:include ("asyncrun.txt")))))
(synopsis "Run Async Shell Commands in Vim")
(description "This plugin takes the advantage of new APIs in Vim 8 (and
NeoVim) to enable you to run shell commands in background and read output in
the
quickfix window in realtime.")
(license license:expat))

--
Mohammed 'Renken' AMAR-BENSABER
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEUzNLCdIGb886Sie/HyuxWbZF5XUFAmLy0MQACgkQHyuxWbZF
5XUwxBAAx3nee5TcklLRKhQsw+zaQ6ZDB3pdUY6Ic5cLKUALy3YIMxksYF7dTnEn
SU9D1uI0QbHnCsdmvJRzMwdSefQZc/pfGbOTvKTX1t67DoMtIvZ4Oc90FY4SfVJ0
4VVWuzIpHrPDSVFEeQ6tQz6zpk9L42vIcXA0SCUwL81RVQibpqDWk9KKl21xxHg/
iMabIh//lIQsyJrr9d+OqyymJ3MZgaCIwX+SqhaNlfmmB7ygb8ahEln/qZxcpeqX
YLBFcGoD0NUWYidtkfpYiSmFM2ImrxMiBjVG1hQbQxqqiJd5/oALo0uqOLh2Og07
2LFcPRMpRAxOKWE89jT+VMfTHXlQk6Z3jpITYBrJjroXrUUO2dTub9PUXwEs97Aw
ehF3j+G7D4yfK528ZtJ5JhdWrCUvANwAQ5SsU6Oq4ruPy/6UxQUSiX8XY6OZdelK
uLiBZwlHyYrL2pimO6NoDp2bR77xOYuH5u27oTxHebaLxS6OfM6EMUVAtQT8cX0q
6Lxj6NZx9qzRhHQ9DORPK1/FHAd17azK6yMb4pqzUAViHd5aQRZkD/nurd4S4azd
UTxovj8Vs6kIaDfIstpf/12x/ittYb89HI9xxLMrJumKFHeZTxhM6p6PJiz+6Db/
xBTuZK0lgzU4PO1vAfh3vwmQ48u/wR583t2t2Wc0S66DlKWTHwE=
=wFNC
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 10 Aug 2022 16:56
(name . Mohammed AMAR-BENSABER)(address . renken@shione.net)(address . 57093-done@debbugs.gnu.org)
87fsi4ywo6.fsf@gnu.org
Hi Mohammed,

Mohammed AMAR-BENSABER <renken@shione.net> skribis:

Toggle quote (3 lines)
> guix style --whole-file package.scm hangs indefinitely if parenthesis is
> unmatched. Relevant commit a15542d26df42dabdb5e2f76d150ae200230c3b0.

Oops, fixed in ebda12e1d2c64480bb7d5977e580d8b2eabeb503:

Toggle snippet (5 lines)
$ ./pre-inst-env guix style -f /tmp/t.scm
/tmp/t.scm:25:0: error: unexpected end of file
hint: Did you forget a closing parenthesis?

Thanks for your report!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57093@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57093
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch