Hello,
Baptiste Strazzulla <bstrazzull@hotmail.fr> writes:
Toggle quote (2 lines)
> Subject: [PATCH 1/2] gnu: Add emacs-blight
Applied with the following changes. Thank you.
Toggle quote (3 lines)
> +(define-public emacs-blight
> + (let ((commit "6bf9c6192d")
Toggle quote (5 lines)
> + (revision "0"))
> + (package
> + (name "emacs-blight")
> + (version (git-version "1.0.0" revision commit))
AFAICT, there is no mention of a version number whatsoever across the
code base. I set the base version to 0 instead.
Toggle quote (10 lines)
> + (description
> + "@code{blight} allows you to control display brightness from Emacs. It
> +features object-oriented code using EIEIO, a base class implementing a
> +reasonable API which focuses on the extremely basic \"set the back light to
> +this percentage\" functionality instead of advanced tightly-coupled frippery,
> +it includes a concrete implementation that uses SysFS to control brightness.
> +Other systems (D-Bus, macOS, Windows, xbacklight, XELB using XRandR) are
> +easily supportable, giving the same experience across environments. It has a
> +500% snappier name than any other backlight tool for Emacs.")
I trimmed down the description a bit.
Toggle quote (3 lines)
> +(define-public emacs-lemon
> + (let ((commit "37a6e6d6ef")
Toggle quote (3 lines)
> + (native-inputs
> + (list emacs-emms emacs-blight))
I re-ordered inputs alphabetically.
Toggle quote (7 lines)
> + (description
> + "@code{lemon} is a tiny system monitor which displays system information
> +in the echo area when Emacs is has been idle for a few seconds. This is a
> +fork of zk_phi’s Symon, which has been largely rewritten. It fixes a number of
> +bugs and shortcomings and emphasizes customizability and code reuse, but also
> +drops support for non-Linux platforms. It works nicely with EXWM.")
I removed the penultimate sentence, which is not useful in our case.
Regards,
--
Nicolas Goaziou