[PATCH] gnu: terminals: Deprecate wterm.

  • Done
  • quality assurance status badge
Details
3 participants
  • ???
  • Joshua Branson
  • (
Owner
unassigned
Submitted by
(
Severity
normal
(
(address . guix-patches@gnu.org)(name . ()(address . paren@disroot.org)
20220806091331.4321-1-paren@disroot.org
* gnu/packages/terminals.scm (wterm): Deprecate in favour of `foot`.

`wterm` no longer works with modern Wayland, and has been unmaintained
since early 2021. See issue #52029.
---
gnu/packages/terminals.scm | 56 ++------------------------------------
1 file changed, 2 insertions(+), 54 deletions(-)

Toggle diff (76 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 7e5016f08f..3603f4710e 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2022 Felipe Balbi <balbi@kernel.org>
+;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1301,60 +1302,7 @@ (define-public eternalterminal
(license license:asl2.0)))
(define-public wterm
- (package
- (name "wterm")
- (version "0.7")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/majestrate/wterm")
- (commit "0ae42717c08a85a6509214e881422c7fbe7ecc45")))
- (sha256
- (base32
- "0g4lzmc1w6na81i6hny32xds4xfig4xzswzfijyi6p93a1226dv0"))
- (file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (native-inputs
- (list pkg-config))
- (inputs
- `(("fontconfig" ,fontconfig)
- ("freetype" ,freetype)
- ("libdrm" ,libdrm)
- ("libxkbcommon" ,libxkbcommon)
- ("ncurses" ,ncurses)
- ("pixman" ,pixman)
- ("wayland" ,wayland)))
- (arguments
- '(#:tests? #f
-
- ;; Without -j1 it fails to find file libwld.a.
- #:parallel-build? #f
-
- #:make-flags (list "CC=gcc"
- (string-append "PREFIX=" %output)
- (string-append "TERMINFO="
- (assoc-ref %outputs "out")
- "/share/terminfo"))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-after 'unpack 'terminfo-fix
- (lambda _
- (substitute* "Makefile"
- (("\ttic .*") "\tmkdir -p $(SHARE_PREFIX)/share/terminfo
-\ttic -o $(SHARE_PREFIX)/share/terminfo -s wterm.info\n"))
- #t)))))
- (native-search-paths
- (list (search-path-specification
- (variable "TERMINFO_DIRS")
- (files '("share/terminfo")))))
- (home-page "https://github.com/majestrate/wterm")
- (synopsis "Terminal emulator for Wayland")
- (description "wterm is a native Wayland terminal emulator based on
-an st fork using wld. st is a simple terminal emulator for X originally
-made by suckless.")
- (license license:x11)))
+ (deprecated-package "wterm" foot))
(define-public tio
(package
--
2.37.1
J
J
Joshua Branson wrote on 10 Aug 2022 18:10
(name . ()(address . paren@disroot.org)(address . 57014@debbugs.gnu.org)
87bkssoz9d.fsf@dismail.de
Can we please commit this to guix proper? This patch is in reponse to
the closed bug reports:

56965

and

52029

Thanks,

Joshua
?
(name . ()(address . paren@disroot.org)(address . 57014-done@debbugs.gnu.org)
87h72d9dzs.fsf@envs.net
"(" <paren@disroot.org> writes:

Toggle quote (5 lines)
> * gnu/packages/terminals.scm (wterm): Deprecate in favour of `foot`.
>
> `wterm` no longer works with modern Wayland, and has been unmaintained
> since early 2021. See issue #52029.

Applied, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 57014@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 57014
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch