Add phyml package tools.

  • Done
  • quality assurance status badge
Details
4 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • M?d?lin Ionel Patra?cu
  • Ricardo Wurmus
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal
M
M
MadalinIonel.Patrascu@mdc-berlin.de wrote on 5 Aug 2022 11:14
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
398fc66441a34468a7c66370abb8f923@mdc-berlin.de

Attachment: file
M
M
MadalinIonel.Patrascu@mdc-berlin.de wrote on 5 Aug 2022 11:29
Re: [ext] bug#56999: Acknowledgement (Add phyml package tools.)
(name . 56999@debbugs.gnu.org)(address . 56999@debbugs.gnu.org)(name . Ricardo.Wurmus@mdc-berlin.de)(address . Ricardo.Wurmus@mdc-berlin.de)
d03f5f3979974bffa133260aa135df40@mdc-berlin.de
Dear reviewer,

This package requires to do the .configure --argument and make for building of each tool.

I already tried to specific make targets, but didn't help.

Also the PhyTime has issues with the building, more you can check here:


All the best,

M?d?lin!

________________________________
From: GNU bug Tracking System <help-debbugs@gnu.org>
Sent: Friday, August 5, 2022 11:16
To: Patrascu, Madalin Ionel
Subject: [ext] bug#56999: Acknowledgement (Add phyml package tools.)

Thank you for filing a new bug report with debbugs.gnu.org.

This is an automatically generated reply to let you know your message
has been received.

Your message is being forwarded to the package maintainers and other
interested parties for their attention; they will reply in due course.

Your message has been sent to the package maintainer(s):
guix-patches@gnu.org

If you wish to submit further information on this problem, please
send it to 56999@debbugs.gnu.org.

Please do not send mail to help-debbugs@gnu.org unless you wish
to report a problem with the Bug-tracking system.

--
GNU Bug Tracking System
Contact help-debbugs@gnu.org with problems
Attachment: file
M
M
M?d?lin Ionel Patra?cu wrote on 5 Aug 2022 11:33
[PATCH 1/4] gnu: Add phyml.
(address . 56999@debbugs.gnu.org)
20220805093306.21767-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (phyml): New variable.
---
gnu/packages/bioinformatics.scm | 37 +++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 00238531db..fa91f48569 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9068,6 +9068,43 @@ (define-public phylip
programs for inferring phylogenies (evolutionary trees).")
(license license:bsd-2)))
+(define-public phyml
+ (package
+ (name "phyml")
+ (version "3.3.20220408")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stephaneguindon/phyml")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03hdqmnsgnzkcrp9r9ajdfkj33jgq4b86kra8ssjlrph65y344sa"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list automake
+ autoconf))
+ (home-page "https://github.com/stephaneguindon/phyml")
+ (synopsis "Programs for working on SAM/BAM files")
+ (description
+ "@code{PhyML} is a software package that uses modern statistical approaches
+to analyse alignments of nucleotide or amino acid sequences in a phylogenetic
+framework. The main tool in this package builds phylogenies under the maximum
+likelihood criterion. It implements a large number of substitution models coupled
+with efficient options to search the space of phylogenetic tree topologies. @code{
+PhyTime} is another tool in the @code{PhyML} package that focuses on divergence
+date estimation in a Bayesian setting. The main strengths of @code{PhyTime} lie
+in its ability to accommodate for uncertrainty in the placement of fossil
+calibration and the use of realistic models of rate variation along the tree.
+Finally, code{PhyREX} fits the spatial-Lambda-Fleming-Viot model to geo-referenced
+genetic data. This model is similar to the structured coalescent but assumes that
+individuals are distributed along a spatial continuum rather than discrete demes.
+@code{PhyREX} can be used to estimate population densities and rates of dispersal.
+Its output can be processed by treeannotator (from the @code{BEAST} package) as
+well as @code{SPREAD}.")
+ (license license:gpl3)))
+
(define-public imp
(package
(name "imp")

base-commit: 47a38d09696b309f6174b585465e621352444ddb
--
2.37.1
M
M
M?d?lin Ionel Patra?cu wrote on 5 Aug 2022 11:33
[PATCH 2/4] gnu: Add phyml-mpi.
(address . 56999@debbugs.gnu.org)
20220805093306.21767-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (phyml-mpi): New variable.
---
gnu/packages/bioinformatics.scm | 11 +++++++++++
1 file changed, 11 insertions(+)

Toggle diff (24 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index fa91f48569..f448341031 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9105,6 +9105,17 @@ (define-public phyml
well as @code{SPREAD}.")
(license license:gpl3)))
+(define-public phyml-mpi
+ (package (inherit phyml)
+ (name "phyml-mpi")
+ (arguments
+ `(#:configure-flags
+ (list "--enable-phyml-mpi")))
+ (native-inputs
+ (list autoconf
+ automake
+ openmpi))))
+
(define-public imp
(package
(name "imp")
--
2.37.1
M
M
M?d?lin Ionel Patra?cu wrote on 5 Aug 2022 11:33
[PATCH 3/4] gnu: Add phyml-phyrex.
(address . 56999@debbugs.gnu.org)
20220805093306.21767-3-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (phyml-phyrex): New variable.
---
gnu/packages/bioinformatics.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (20 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f448341031..1cb2b49eea 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9116,6 +9116,13 @@ (define-public phyml-mpi
automake
openmpi))))
+(define-public phyml-phyrex
+ (package (inherit phyml)
+ (name "phyml-phyrex")
+ (arguments
+ `(#:configure-flags
+ (list "--enable-phyrex")))))
+
(define-public imp
(package
(name "imp")
--
2.37.1
M
M
M?d?lin Ionel Patra?cu wrote on 5 Aug 2022 11:33
[PATCH 4/4] nu: Add phyml-rf.
(address . 56999@debbugs.gnu.org)
20220805093306.21767-4-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (phyml-rf): New variable.
---
gnu/packages/bioinformatics.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (20 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1cb2b49eea..5421a987b7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9123,6 +9123,13 @@ (define-public phyml-phyrex
`(#:configure-flags
(list "--enable-phyrex")))))
+(define-public phyml-rf
+ (package (inherit phyml)
+ (name "phyml-rf")
+ (arguments
+ `(#:configure-flags
+ (list "--enable-rf")))))
+
(define-public imp
(package
(name "imp")
--
2.37.1
R
R
Ricardo Wurmus wrote on 8 Aug 2022 10:09
Re: [bug#56999] [PATCH 1/4] gnu: Add phyml.
(name . M?d?lin Ionel Patra?cu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 56999@debbugs.gnu.org)
875yj32m0z.fsf@elephly.net
M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/bioinformatics.scm (phyml): New variable.

Thanks for the patch.

Toggle quote (16 lines)
> + "@code{PhyML} is a software package that uses modern statistical approaches
> +to analyse alignments of nucleotide or amino acid sequences in a phylogenetic
> +framework. The main tool in this package builds phylogenies under the maximum
> +likelihood criterion. It implements a large number of substitution models coupled
> +with efficient options to search the space of phylogenetic tree topologies. @code{
> +PhyTime} is another tool in the @code{PhyML} package that focuses on divergence
> +date estimation in a Bayesian setting. The main strengths of @code{PhyTime} lie
> +in its ability to accommodate for uncertrainty in the placement of fossil
> +calibration and the use of realistic models of rate variation along the tree.
> +Finally, code{PhyREX} fits the spatial-Lambda-Fleming-Viot model to geo-referenced
> +genetic data. This model is similar to the structured coalescent but assumes that
> +individuals are distributed along a spatial continuum rather than discrete demes.
> +@code{PhyREX} can be used to estimate population densities and rates of dispersal.
> +Its output can be processed by treeannotator (from the @code{BEAST} package) as
> +well as @code{SPREAD}.")

The description mentions PhyTime and PhyREX, neither of which are
included in this package. I’ll try to integrate this package with
the definitions of phyml-mpi, phyml-phyrex, and phyml-rf that you’ve
sent here.

--
Ricardo
R
R
Ricardo Wurmus wrote on 8 Aug 2022 12:35
Re: [ext] bug#56999: Acknowledgement (Add phyml package tools.)
(name . Patrascu, Madalin Ionel)(address . MadalinIonel.Patrascu@mdc-berlin.de)(name . 56999-done@debbugs.gnu.org)(address . 56999@debbugs.gnu.org)
871qtr2f3n.fsf@mdc-berlin.de
I modified the package definition like this:

- build all tools in the same package by using separate build phases
- remove any mention of PhyTime from the description
- add texlive-* packages to build and install the PDF manual
- remove the pre-built PDF manual from the sources
- remove -march=native
- set only x86_64 as supported

made it impossible to remove -march=native completely, so I hope this is
sufficient.

--
Ricardo
R
R
Ricardo Wurmus wrote on 31 Oct 2022 21:47
Add phyml package tools
(address . 56999-done@debbugs.gnu.org)
87o7trbtyj.fsf@mdc-berlin.de
Closing.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56999@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56999
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch