[PATCH] gnu: ugrep: Use gexps and add zstd to inputs.

  • Done
  • quality assurance status badge
Details
3 participants
  • kiasoc5
  • Liliana Marie Prikler
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
kiasoc5
Severity
normal
K
K
kiasoc5 wrote on 5 Aug 2022 06:32
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20220805043256.286451-1-kiasoc5@disroot.org
* gnu/packages/search.scm (ugrep)[snippets]: Remove trailing #t.
[arguments]: Use gexps.
[inputs]: Add zstd.
---
gnu/packages/search.scm | 28 +++++++++++++++-------------
1 file changed, 15 insertions(+), 13 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index db5579a708..620c8dbe1f 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -32,6 +32,7 @@ (define-module (gnu packages search)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
@@ -687,8 +688,7 @@ (define-public ugrep
(delete-file-recursively "bin") ; pre-built executables
(for-each delete-file (find-files "tests" "^archive\\..*"))
(for-each delete-file (find-files "tests" "^.*\\.pdf$"))
- (for-each delete-file (find-files "tests" "^.*\\.class$"))
- #t))))
+ (for-each delete-file (find-files "tests" "^.*\\.class$"))))))
(build-system gnu-build-system)
(inputs
(list bzip2
@@ -696,18 +696,20 @@ (define-public ugrep
lz4
lzip ;; lzma
pcre2
- zlib))
+ zlib
+ zstd))
(arguments
- `(#:tests? #f ; no way to rebuild the binary input files
- #:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; Unpatch shebangs in tests.
- (substitute* '("tests/Hello.bat"
- "tests/Hello.sh")
- (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
+ (list
+ #:tests? #f ; no way to rebuild the binary input files
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda _
+ ;; Unpatch shebangs in tests.
+ (substitute* '("tests/Hello.bat"
+ "tests/Hello.sh")
+ (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
(home-page "https://github.com/Genivia/ugrep/")
(synopsis "Faster grep with an interactive query UI")
(description "Ugrep is a ultra fast searcher of file systems, text
--
2.37.1
K
K
kiasoc5 wrote on 5 Aug 2022 07:14
Re: [PATCH] gnu: ugrep: Use gexps and add zstd lib to inputs.
20220805051456.11725518@aria
On Fri, Aug 05 2022, 01:10:00 AM -0400
kiasoc5 <kiasoc5@disroot.org> wrote:

Toggle quote (3 lines)
> Last email had old version of patch, please use this one. Sorry paren
> for using cc instead of reply-to.

Also forgot to check my git-send email arguments. Sending to the
correct issue.

Toggle quote (76 lines)
> * gnu/packages/search.scm (ugrep)[snippets]: Use gexps. Remove
> trailing #t. [snippets]: Use gexps.
> [arguments]: Likewise.
> [inputs]: Add zstd lib.
> ---
> gnu/packages/search.scm | 33 +++++++++++++++++----------------
> 1 file changed, 17 insertions(+), 16 deletions(-)
>
> diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
> index db5579a708..65a642c259 100644
> --- a/gnu/packages/search.scm
> +++ b/gnu/packages/search.scm
> @@ -32,6 +32,7 @@ (define-module (gnu packages search)
> #:use-module (guix packages)
> #:use-module (guix download)
> #:use-module (guix git-download)
> + #:use-module (guix gexp)
> #:use-module (guix utils)
> #:use-module (guix build-system gnu)
> #:use-module (guix build-system perl)
> @@ -681,14 +682,12 @@ (define-public ugrep
> (sha256
> (base32
> "03b3lahc3zzsznaqnrk47f1cnd5jwakvwrkz0r4m2crk09cpfv57")) (file-name
> (git-file-name name version))
> - (modules '((guix build utils)))
> - (snippet
> - '(begin
> + (snippet #~(begin
> + (use-modules (guix build utils))
> (delete-file-recursively "bin") ; pre-built
> executables (for-each delete-file (find-files "tests"
> "^archive\\..*")) (for-each delete-file (find-files "tests"
> "^.*\\.pdf$"))
> - (for-each delete-file (find-files "tests"
> "^.*\\.class$"))
> - #t))))
> + (for-each delete-file (find-files "tests"
> "^.*\\.class$")))))) (build-system gnu-build-system)
> (inputs
> (list bzip2
> @@ -696,18 +695,20 @@ (define-public ugrep
> lz4
> lzip ;; lzma
> pcre2
> - zlib))
> + zlib
> + `(,zstd "lib"))
> (arguments
> - `(#:tests? #f ; no way to rebuild the binary
> input files
> - #:test-target "test"
> - #:phases
> - (modify-phases %standard-phases
> - (add-before 'check 'check-setup
> - (lambda _
> - ;; Unpatch shebangs in tests.
> - (substitute* '("tests/Hello.bat"
> - "tests/Hello.sh")
> - (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
> + (list
> + #:tests? #f ; no way to rebuild the binary
> input files
> + #:test-target "test"
> + #:phases
> + #~(modify-phases %standard-phases
> + (add-before 'check 'check-setup
> + (lambda _
> + ;; Unpatch shebangs in tests.
> + (substitute* '("tests/Hello.bat"
> + "tests/Hello.sh")
> + (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
> (home-page "https://github.com/Genivia/ugrep/")
> (synopsis "Faster grep with an interactive query UI")
> (description "Ugrep is a ultra fast searcher of file systems,
> text
L
L
Liliana Marie Prikler wrote on 5 Aug 2022 09:35
8f611a9aa9447906a46bb59a6371ee8059362e0d.camel@ist.tugraz.at
Am Freitag, dem 05.08.2022 um 05:14 +0000 schrieb kiasoc5:

Toggle quote (1 lines)
> Use gexps and add zstd lib to inputs.
Useful hint: If your patch title contains "and", it probably should be
a series of two or more patches. ??

Cheers
K
K
kiasoc5 wrote on 6 Aug 2022 07:37
[PATCH 1/2] gnu: ugrep: Add zstd lib to inputs.
(address . 56995@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20220806053750.184243-1-kiasoc5@disroot.org
* gnu/packages/search.scm (ugrep)[inputs]: Add zstd lib.
---
gnu/packages/search.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index db5579a708..175a31cd5d 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -696,7 +696,8 @@ (define-public ugrep
lz4
lzip ;; lzma
pcre2
- zlib))
+ zlib
+ `(,zstd "lib"))
(arguments
`(#:tests? #f ; no way to rebuild the binary input files
#:test-target "test"
--
2.37.1
K
K
kiasoc5 wrote on 6 Aug 2022 07:37
[PATCH 2/2] gnu: ugrep: Use gexps.
(address . 56995@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20220806053750.184243-2-kiasoc5@disroot.org
* gnu/packages/search.scm (ugrep)[source]: Convert snippet to gexp.
[arguments]: Use gexps.
---
gnu/packages/search.scm | 36 ++++++++++++++++++------------------
1 file changed, 18 insertions(+), 18 deletions(-)

Toggle diff (65 lines)
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 175a31cd5d..34dc6d5faf 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -32,6 +32,7 @@ (define-module (gnu packages search)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
@@ -681,14 +682,12 @@ (define-public ugrep
(sha256
(base32 "03b3lahc3zzsznaqnrk47f1cnd5jwakvwrkz0r4m2crk09cpfv57"))
(file-name (git-file-name name version))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (delete-file-recursively "bin") ; pre-built executables
- (for-each delete-file (find-files "tests" "^archive\\..*"))
- (for-each delete-file (find-files "tests" "^.*\\.pdf$"))
- (for-each delete-file (find-files "tests" "^.*\\.class$"))
- #t))))
+ (snippet #~(begin
+ (use-modules (guix build utils))
+ (delete-file-recursively "bin") ; pre-built executables
+ (for-each delete-file (find-files "tests" "^archive\\..*"))
+ (for-each delete-file (find-files "tests" "^.*\\.pdf$"))
+ (for-each delete-file (find-files "tests" "^.*\\.class$"))))))
(build-system gnu-build-system)
(inputs
(list bzip2
@@ -698,18 +697,19 @@ (define-public ugrep
pcre2
zlib
`(,zstd "lib"))
- (arguments
- `(#:tests? #f ; no way to rebuild the binary input files
+ (arguments
+ (list
+ #:tests? #f ; no way to rebuild the binary input files
#:test-target "test"
#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; Unpatch shebangs in tests.
- (substitute* '("tests/Hello.bat"
- "tests/Hello.sh")
- (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
- (home-page "https://github.com/Genivia/ugrep/")
+ #~(modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda _
+ ;; Unpatch shebangs in tests.
+ (substitute* '("tests/Hello.bat"
+ "tests/Hello.sh")
+ (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
+ (home-page "https://github.com/Genivia/ugrep/")
(synopsis "Faster grep with an interactive query UI")
(description "Ugrep is a ultra fast searcher of file systems, text
and binary files, source code, archives, compressed files, documents, and
--
2.37.1
L
L
Liliana Marie Prikler wrote on 6 Aug 2022 16:41
a7d22d6736d0cbe982aba8bdca0e1282dcbc2d90.camel@gmail.com
Am Samstag, dem 06.08.2022 um 01:37 -0400 schrieb kiasoc5:
Toggle quote (2 lines)
> * gnu/packages/search.scm (ugrep)[source]: Convert snippet to gexp.
> [arguments]: Use gexps.
Pushed with a fix on the first patch and slightly modified ChangeLog.

Cheers
Closed
?