[PATCH] gnu: openh264: Update to 2.3.0.

  • Done
  • quality assurance status badge
Details
3 participants
  • 宋文武
  • kiasoc5
  • (
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 3 years ago
(address . guix-patches@gnu.org)
20220804203726.44fb38aa@aria

From 91f966c74da0e9a27dd68d443ed2a255b1c48826 Mon Sep 17 00:00:00 2001
From: kiasoc5 <kiasoc5@disroot.org>
Date: Tue, 2 Aug 2022 23:07:57 -0400
Subject: [PATCH] gnu: openh264: Update to 2.3.0.

* gnu/packages/video.scm (openh264): Update to 2.3.0.
---
gnu/packages/video.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 04049fd9c8..1a99a206ca 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3940,7 +3940,7 @@ (define-public intel-vaapi-driver
(define-public openh264
(package
(name "openh264")
- (version "2.1.1")
+ (version "2.3.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3949,7 +3949,7 @@ (define-public openh264
(file-name (git-file-name name version))
(sha256
(base32
- "0ffav46pz3sbj92nipd62z03fibyqgclfq9w8lgr80s6za6zdk5s"))))
+ "1yr6nsjpnazq4z6dvjfyanljwgwnyjh3ddxa0sq6hl9qc59yq91r"))))
(build-system gnu-build-system)
(native-inputs
(list nasm python))

base-commit: a956c7df87536717e4e04af11ae6d73dcb7a2ce7
--
2.37.1
( wrote 3 years ago
CLXJJYTM4QKL.Z1FB4X69Q847@guix-aspire
And here :)

-- (
kiasoc5 wrote 3 years ago
[PATCH V2] gnu: openh264: Update to 2.3.0 and use gexps.
(address . 56984@debbugs.gnu.org)
20220805044452.323170-1-kiasoc5@disroot.org
* gnu/packages/video.scm (openh264): Update to 2.3.0.
[arguments]: Use gexps.
---
gnu/packages/video.scm | 19 +++++++++++--------
1 file changed, 11 insertions(+), 8 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 04049fd9c8..b9e2c54eb7 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3940,7 +3940,7 @@ (define-public intel-vaapi-driver
(define-public openh264
(package
(name "openh264")
- (version "2.1.1")
+ (version "2.3.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3949,17 +3949,20 @@ (define-public openh264
(file-name (git-file-name name version))
(sha256
(base32
- "0ffav46pz3sbj92nipd62z03fibyqgclfq9w8lgr80s6za6zdk5s"))))
+ "1yr6nsjpnazq4z6dvjfyanljwgwnyjh3ddxa0sq6hl9qc59yq91r"))))
(build-system gnu-build-system)
(native-inputs
(list nasm python))
(arguments
- '(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
- "CC=gcc")
- #:test-target "test"
- #:phases (modify-phases %standard-phases
- ;; no configure script
- (delete 'configure))))
+ (list
+ #:make-flags
+ #~(list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "CC=gcc")
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; no configure script
+ (delete 'configure))))
(home-page "https://www.openh264.org/")
(synopsis "H264 decoder library")
(description
--
2.37.1
kiasoc5 wrote 3 years ago
[PATCH V3] gnu: ugrep: Use gexps and add zstd lib to inputs.
(address . 56984@debbugs.gnu.org)
20220805050408.342881-1-kiasoc5@disroot.org
* gnu/packages/search.scm (ugrep)[snippets]: Remove trailing #t.
[snippets]: Use gexps.
[arguments]: Likewise.
[inputs]: Add zstd lib.
---
gnu/packages/search.scm | 28 +++++++++++++++-------------
1 file changed, 15 insertions(+), 13 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index db5579a708..620c8dbe1f 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -32,6 +32,7 @@ (define-module (gnu packages search)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
@@ -687,8 +688,7 @@ (define-public ugrep
(delete-file-recursively "bin") ; pre-built executables
(for-each delete-file (find-files "tests" "^archive\\..*"))
(for-each delete-file (find-files "tests" "^.*\\.pdf$"))
- (for-each delete-file (find-files "tests" "^.*\\.class$"))
- #t))))
+ (for-each delete-file (find-files "tests" "^.*\\.class$"))))))
(build-system gnu-build-system)
(inputs
(list bzip2
@@ -696,18 +696,20 @@ (define-public ugrep
lz4
lzip ;; lzma
pcre2
- zlib))
+ zlib
+ zstd))
(arguments
- `(#:tests? #f ; no way to rebuild the binary input files
- #:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; Unpatch shebangs in tests.
- (substitute* '("tests/Hello.bat"
- "tests/Hello.sh")
- (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
+ (list
+ #:tests? #f ; no way to rebuild the binary input files
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda _
+ ;; Unpatch shebangs in tests.
+ (substitute* '("tests/Hello.bat"
+ "tests/Hello.sh")
+ (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
(home-page "https://github.com/Genivia/ugrep/")
(synopsis "Faster grep with an interactive query UI")
(description "Ugrep is a ultra fast searcher of file systems, text
--
2.37.1
kiasoc5 wrote 3 years ago
[PATCH] gnu: ugrep: Use gexps and add zstd lib to inputs.
(address . 56984@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20220805050959.344944-1-kiasoc5@disroot.org
Last email had old version of patch, please use this one. Sorry paren
for using cc instead of reply-to.

* gnu/packages/search.scm (ugrep)[snippets]: Use gexps. Remove trailing #t.
[snippets]: Use gexps.
[arguments]: Likewise.
[inputs]: Add zstd lib.
---
gnu/packages/search.scm | 33 +++++++++++++++++----------------
1 file changed, 17 insertions(+), 16 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index db5579a708..65a642c259 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -32,6 +32,7 @@ (define-module (gnu packages search)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
@@ -681,14 +682,12 @@ (define-public ugrep
(sha256
(base32 "03b3lahc3zzsznaqnrk47f1cnd5jwakvwrkz0r4m2crk09cpfv57"))
(file-name (git-file-name name version))
- (modules '((guix build utils)))
- (snippet
- '(begin
+ (snippet #~(begin
+ (use-modules (guix build utils))
(delete-file-recursively "bin") ; pre-built executables
(for-each delete-file (find-files "tests" "^archive\\..*"))
(for-each delete-file (find-files "tests" "^.*\\.pdf$"))
- (for-each delete-file (find-files "tests" "^.*\\.class$"))
- #t))))
+ (for-each delete-file (find-files "tests" "^.*\\.class$"))))))
(build-system gnu-build-system)
(inputs
(list bzip2
@@ -696,18 +695,20 @@ (define-public ugrep
lz4
lzip ;; lzma
pcre2
- zlib))
+ zlib
+ `(,zstd "lib"))
(arguments
- `(#:tests? #f ; no way to rebuild the binary input files
- #:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; Unpatch shebangs in tests.
- (substitute* '("tests/Hello.bat"
- "tests/Hello.sh")
- (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
+ (list
+ #:tests? #f ; no way to rebuild the binary input files
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda _
+ ;; Unpatch shebangs in tests.
+ (substitute* '("tests/Hello.bat"
+ "tests/Hello.sh")
+ (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
(home-page "https://github.com/Genivia/ugrep/")
(synopsis "Faster grep with an interactive query UI")
(description "Ugrep is a ultra fast searcher of file systems, text
--
2.37.1
宋文武 wrote 3 years ago
Re: bug#56984: [PATCH] gnu: openh264: Update to 2.3.0.
(name . kiasoc5)(address . kiasoc5@disroot.org)
87y1vwijs0.fsf_-_@envs.net
kiasoc5 <kiasoc5@disroot.org> writes:

Toggle quote (6 lines)
> * gnu/packages/video.scm (openh264): Update to 2.3.0.
> [arguments]: Use gexps.
> ---
> gnu/packages/video.scm | 19 +++++++++++--------
> 1 file changed, 11 insertions(+), 8 deletions(-)

I changed '(assoc-ref %outputs "out")' to '#$output'.

Pushed now, thank you for the patch and ( for the review!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56984@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56984
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help