[PATCH] gnu: Add emacs-buffer-env.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal
M
M
Morgan.J.Smith wrote on 4 Aug 2022 02:37
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163D2642001B57A37FD5E56C59F9@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-buffer-env): New variable.
---
gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7a060783f8..a9c1869474 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29431,6 +29431,26 @@ (define-public emacs-boxquote
example code.")
(license license:gpl3+)))
+(define-public emacs-buffer-env
+ (package
+ (name "emacs-buffer-env")
+ (version "0.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/buffer-env-"
+ version ".tar"))
+ (sha256
+ (base32
+ "0y8ik87dqldhn6q631zp2ln9z5byqgm9icrvr4xrdx6g8mr9c56z"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-compat))
+ (home-page "https://github.com/astoff/buffer-env")
+ (synopsis "Create buffer-local process environments")
+ (description "Create buffer-local environments using scripts similar to
+direnv. This allows Emacs to call the correct version of external programs
+such as linters, compilers, and language servers on a per-project basis.")
+ (license license:gpl3+)))
+
(define-public emacs-buffer-move
(package
(name "emacs-buffer-move")
--
2.37.1
N
N
Nicolas Goaziou wrote on 25 Aug 2022 13:48
(address . Morgan.J.Smith@outlook.com)(address . 56964-done@debbugs.gnu.org)
87bks8sfwd.fsf@nicolasgoaziou.fr
Hello,

Morgan.J.Smith@outlook.com writes:

Toggle quote (4 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/emacs-xyz.scm (emacs-buffer-env): New variable.

Applied with the following change. Thank you.

Toggle quote (5 lines)
> + (description "Create buffer-local environments using scripts similar to
> +direnv. This allows Emacs to call the correct version of external programs
> +such as linters, compilers, and language servers on a per-project basis.")
> + (license license:gpl3+)))

I sligthly changed the description so it would start with a complete sentence.

Regards,
--
Nicolas Goaziou
Closed
?