Morgan.J.Smith wrote 3 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
From: Morgan Smith <Morgan.J.Smith@outlook.com>
* gnu/packages/emacs-xyz.scm (emacs-buffer-env): New variable.
---
gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)
Toggle diff (33 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7a060783f8..a9c1869474 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29431,6 +29431,26 @@ (define-public emacs-boxquote
example code.")
(license license:gpl3+)))
+(define-public emacs-buffer-env
+ (package
+ (name "emacs-buffer-env")
+ (version "0.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/buffer-env-"
+ version ".tar"))
+ (sha256
+ (base32
+ "0y8ik87dqldhn6q631zp2ln9z5byqgm9icrvr4xrdx6g8mr9c56z"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-compat))
+ (home-page "https://github.com/astoff/buffer-env")
+ (synopsis "Create buffer-local process environments")
+ (description "Create buffer-local environments using scripts similar to
+direnv. This allows Emacs to call the correct version of external programs
+such as linters, compilers, and language servers on a per-project basis.")
+ (license license:gpl3+)))
+
(define-public emacs-buffer-move
(package
(name "emacs-buffer-move")
--
2.37.1