[PATCH] gnu: packages: Add jrnlc.

  • Open
  • quality assurance status badge
Details
One participant
  • (
Owner
unassigned
Submitted by
(
Severity
normal
(
(address . guix-patches@gnu.org)(name . ()(address . paren@disroot.org)
20220803131731.8771-1-paren@disroot.org
* gnu/packages/admin.scm (jrnlc): New variable.
---
gnu/packages/admin.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 146423d068..2d84787aef 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -5447,3 +5447,44 @@ (define-public fail2ban
up services to use only two factor, or public/private authentication
mechanisms if you really want to protect services.")
(license license:gpl2+)))
+
+(define-public jrnlc
+ (package
+ (name "jrnlc")
+ (version "2022.a")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/thexhr/jrnlc")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10j4iyac41ndr9yic7vdkajf4kvvwzbd5jxpjypzybcygj9jq8h6"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags
+ #~(list (string-append "PREFIX=" #$output)
+ (string-append "CC=" #$(cc-for-target)))
+ #:tests? #f ; no check target
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-install-invocations
+ (lambda _
+ (substitute* "Makefile"
+ (("-o root") ""))))
+ (delete 'configure)
+ (add-before 'install 'create-output-dirs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (mkdir-p (string-append out "/bin"))
+ (mkdir-p (string-append out "/man"))))))))
+ (inputs (list json-c libsodium))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/thexhr/jrnlc")
+ (synopsis "Opinionated command-line journal")
+ (description "@code{jrnlc} is a opinionated command line application
+for note-taking. You can take notes by entering them on the command line
+or piping them from a file. It supports full encryption of the journal,
+so that your notes remain secret.")
+ (license license:isc)))
--
2.37.1
(
[PATCH v2] gnu: Add jrnlc.
(address . 56951@debbugs.gnu.org)(name . ()(address . paren@disroot.org)
20220913175201.15957-1-paren@disroot.org
* gnu/packages/c.scm (jrnlc): New variable.
---
gnu/packages/c.scm | 49 ++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 49 insertions(+)

Toggle diff (66 lines)
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 10275970b1..4d1ee7714b 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -50,6 +50,7 @@ (define-module (gnu packages c)
#:use-module (gnu packages bootstrap)
#:use-module (gnu packages bison)
#:use-module (gnu packages check)
+ #:use-module (gnu packages crypto)
#:use-module (gnu packages flex)
#:use-module (gnu packages gcc)
#:use-module (gnu packages perl)
@@ -1258,3 +1259,51 @@ (define-public utest-h
(description
"This package provides a header-only unit testing library for C/C++.")
(license license:unlicense))))
+
+(define-public jrnlc
+ (package
+ (name "jrnlc")
+ (version "2022.a")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/thexhr/jrnlc")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10j4iyac41ndr9yic7vdkajf4kvvwzbd5jxpjypzybcygj9jq8h6"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ;no test target
+ #:make-flags
+ #~(list (string-append "PREFIX=" #$output)
+ (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-install
+ (lambda _
+ (substitute* "Makefile"
+ (("-o root") ""))))
+ (add-after 'patch-install 'fix-cross-compile
+ (lambda _
+ (substitute* "Makefile"
+ (("pkg-config")
+ #$(pkg-config-for-target)))))
+ (delete 'configure) ;no configure script
+ (add-before 'install 'create-output-dirs
+ (lambda _
+ (mkdir-p #$output)
+ (with-directory-excursion #$output
+ (mkdir-p "bin")
+ (mkdir-p "man")))))))
+ (inputs (list json-c libsodium))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/thexhr/jrnlc")
+ (synopsis "Command-line journal for note-taking")
+ (description
+ "This package provides a command-line utility for taking notes
+in a journal. You can take notes by entering them on the command
+line or writing them to standard input. It supports full encryption
+of the journal, so that your notes remain secret.")
+ (license license:isc)))
--
2.37.3
(
CMVGRPEZ0X9A.34DG8VMG64WD6@guix-aspire
This patch uses the latest standard package style, uses c.scm instead
of admin.scm, and fixes cross-compilation.

-- (
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 56951@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56951
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch