[PATCH] gnu: packages: Add gopls.

  • Done
  • quality assurance status badge
Details
One participant
  • (
Owner
unassigned
Submitted by
(
Severity
normal
(
(address . guix-patches@gnu.org)(name . ()(address . paren@disroot.org)
20220803114355.13792-1-paren@disroot.org
* gnu/packages/golang.scm (gopls): New variable.
---
gnu/packages/golang.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1ce55875d8..4756bcb249 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2021 Lu Hui <luhux76@gmail.com>
;;; Copyright © 2022 Pier-Hugues Pellerin <phpellerin@gmail.com>
;;; Copyright © 2022 muradm <mail@muradm.net>
+;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9891,3 +9892,22 @@ (define-public go-github-com-sourcegraph-jsonrpc2
(description
"Package jsonrpc2 provides a Go implementation of JSON-RPC 2.0.")
(license license:expat)))
+
+(define-public gopls
+ (package
+ (inherit go-golang-org-x-tools)
+ (name "gopls")
+ (arguments
+ (list #:unpack-path "golang.org/x/tools"
+ #:import-path "golang.org/x/tools/gopls"
+ #:install-source? #f))
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs
+ go-golang-org-x-tools)
+ (prepend go-golang-org-x-sync)))
+ (synopsis "Go language server implementation")
+ (description
+ "This package provides the @acronym{LSP, Language Server Protocol}
+server implementation for the Go programming language. It provides
+on-the-fly code linting, formatting, completion, and introspection for
+Go code in text editors supporting LSP.")))
--
2.37.1
(
[PATCH v2] gnu: packages: Add gopls.
(address . 56908@debbugs.gnu.org)(name . ()(address . paren@disroot.org)
20220804173545.2274-1-paren@disroot.org
* gnu/packages/golang.scm (gopls): New variable.
---
gnu/packages/golang.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1ce55875d8..68fd8630a2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2021 Lu Hui <luhux76@gmail.com>
;;; Copyright © 2022 Pier-Hugues Pellerin <phpellerin@gmail.com>
;;; Copyright © 2022 muradm <mail@muradm.net>
+;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9891,3 +9892,19 @@ (define-public go-github-com-sourcegraph-jsonrpc2
(description
"Package jsonrpc2 provides a Go implementation of JSON-RPC 2.0.")
(license license:expat)))
+
+(define-public gopls
+ (package
+ (inherit go-golang-org-x-tools)
+ (name "gopls")
+ (arguments
+ (list #:unpack-path "golang.org/x/tools"
+ #:import-path "golang.org/x/tools/gopls"
+ #:install-source? #f))
+ (inputs (list go-golang-org-x-sync))
+ (synopsis "Go language server implementation")
+ (description
+ "This package provides the @acronym{LSP, Language Server Protocol}
+server implementation for the Go programming language. It provides
+on-the-fly code linting, formatting, completion, and introspection for
+Go code in text editors supporting LSP.")))
--
2.37.1
(
CLXFDW8TLMEU.XTW4HM7TL8V3@guix-aspire
This improved patch doesn't use propagated-inputs or modify-inputs (since
x-tools doesn't have any inputs anyway).

-- (
(
[PATCH v3] gnu: Add gopls.
(address . 56908@debbugs.gnu.org)(name . ()(address . paren@disroot.org)
20220814124126.14868-1-paren@disroot.org
* gnu/packages/golang.scm (gopls): New variable.
---
gnu/packages/golang.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1ce55875d8..1ade3b81b2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2560,6 +2560,22 @@ (define-public go-golang-org-x-tools
(home-page "https://go.googlesource.com/tools/")
(license license:bsd-3))))
+(define-public gopls
+ (package
+ (inherit go-golang-org-x-tools)
+ (name "gopls")
+ (arguments
+ (list #:unpack-path "golang.org/x/tools"
+ #:import-path "golang.org/x/tools/gopls"
+ #:install-source? #f))
+ (inputs (list go-golang-org-x-sync))
+ (synopsis "Go language server implementation")
+ (description
+ "This package provides the @acronym{LSP, Language Server Protocol}
+server implementation for the Go programming language. It provides
+on-the-fly code linting, formatting, completion, and introspection for
+Go code in text editors supporting LSP.")))
+
(define-public go-golang-org-x-crypto
(let ((commit "2aa609cf4a9d7d1126360de73b55b6002f9e052a")
(revision "5"))
--
2.37.1
(
CM5SVC7EHQ6E.2614L7PD31OOV@guix-aspire
Uh, please ignore this patch. I think it may be missing lots of
dependencies. I'll send a v4 with the missing deps when I have
time.

-- (
(
(address . control@debbugs.gnu.org)
CN64KY8AH670.1T5PNRP7QDZBX@guix-aspire
close 54357
close 56908
thanks

-- (
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56908@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56908
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch