(address . guix-patches@gnu.org)(name . ()(address . paren@disroot.org)
* gnu/packages/golang.scm (gopls): New variable.
---
gnu/packages/golang.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1ce55875d8..4756bcb249 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2021 Lu Hui <luhux76@gmail.com>
;;; Copyright © 2022 Pier-Hugues Pellerin <phpellerin@gmail.com>
;;; Copyright © 2022 muradm <mail@muradm.net>
+;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9891,3 +9892,22 @@ (define-public go-github-com-sourcegraph-jsonrpc2
(description
"Package jsonrpc2 provides a Go implementation of JSON-RPC 2.0.")
(license license:expat)))
+
+(define-public gopls
+ (package
+ (inherit go-golang-org-x-tools)
+ (name "gopls")
+ (arguments
+ (list #:unpack-path "golang.org/x/tools"
+ #:import-path "golang.org/x/tools/gopls"
+ #:install-source? #f))
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs
+ go-golang-org-x-tools)
+ (prepend go-golang-org-x-sync)))
+ (synopsis "Go language server implementation")
+ (description
+ "This package provides the @acronym{LSP, Language Server Protocol}
+server implementation for the Go programming language. It provides
+on-the-fly code linting, formatting, completion, and introspection for
+Go code in text editors supporting LSP.")))
--
2.37.1