[PATCH] gnu: qt5ct: Fix build

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • 宋文武
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 3 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163B409BDD90A99B6B2F4CCC59C9@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/qt.scm (qt5ct)
[build-system]: Change to qt-build-system
[phases]: Replace
[inputs]: Remove qtbase-5
[modules]: Removed
[impoorted-modules]: Removed
---
gnu/packages/qt.scm | 39 ++++++++++++---------------------------
1 file changed, 12 insertions(+), 27 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index f74f84f2ac..86f5d11714 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -159,37 +159,22 @@ (define-public qt5ct
(string-append "mirror://sourceforge/qt5ct/qt5ct-" version ".tar.bz2"))
(sha256
(base32 "14742vs32m98nbfb5mad0i8ciff5f45gfcb5v03p4hh2dvhhqgfn"))))
- (build-system gnu-build-system)
+ (build-system qt-build-system)
(arguments
- `(#:tests? #f ; No target
- #:imported-modules
- (,@%qt-build-system-modules)
- #:modules
- ((guix build gnu-build-system)
- ((guix build qt-build-system)
- #:prefix qt:)
- (guix build utils))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "qt5ct.pro"
- (("\\$\\$\\[QT_INSTALL_BINS\\]/lrelease")
- (search-input-file inputs "/bin/lrelease")))))
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out")))
- (invoke "qmake"
- (string-append "PREFIX=" out)
- (string-append "BINDIR=" out "/bin")
- (string-append "DATADIR=" out "/share")
- (string-append "PLUGINDIR=" out "/lib/qt5/plugins")))))
- (add-after 'install 'qt-wrap
- (assoc-ref qt:%standard-phases 'qt-wrap)))))
+ (list
+ #:tests? #f ; No target
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* '("src/qt5ct-qtplugin/CMakeLists.txt"
+ "src/qt5ct-style/CMakeLists.txt")
+ (("\\$\\{PLUGINDIR\\}")
+ (string-append #$output "/lib/qt5/plugins"))))))))
(native-inputs
(list qttools-5))
(inputs
- (list qtbase-5 qtsvg-5))
+ (list qtsvg-5))
(synopsis "Qt5 Configuration Tool")
(description "Qt5CT is a program that allows users to configure Qt5
settings (such as icons, themes, and fonts) in desktop environments or
--
2.37.1
宋文武 wrote 3 years ago
(address . Morgan.J.Smith@outlook.com)(address . 56901-done@debbugs.gnu.org)
87h72uqarn.fsf@envs.net
Morgan.J.Smith@outlook.com writes:

Toggle quote (5 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/qt.scm (qt5ct)
> [build-system]: Change to qt-build-system

Applied with some simplify for commit message, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56901@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56901
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help