[PATCH] Fix nsis.

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal

Debbugs page

Vivien Kraus wrote 3 years ago
(name . guix-patches)(address . guix-patches@gnu.org)
45c22c0a9d36937360172ba25edd97280436edf6.camel@planete-kraus.eu
Dear guix,

nsis is broken from the switch to GCC 10. See here:

The fix here is to simply update the package to a newer version. Doing
this, we can drop the SOURCE_DATE_EPOCH patch, but we must keep the
environment hack for the build system. I just updated it to the new
syntax.

What do you think?

Best regards,

Vivien
From 3c775f2796115b2081b18cf64c0bce52da500dba Mon Sep 17 00:00:00 2001
From: Vivien Kraus <vivien@planete-kraus.eu>
Date: Tue, 2 Aug 2022 17:23:05 +0200
Subject: [PATCH] gnu: nsis: Update to 3.08.

* gnu/packages/patches/nsis-source-date-epoch.patch: Drop this patch.
* gnu/packages/patches/nsis-env-passthru.patch: Adjust the patch.
* gnu/packages/installers.scm (make-nsis): Update to 3.08.
---
gnu/local.mk | 1 -
gnu/packages/installers.scm | 7 +++---
gnu/packages/patches/nsis-env-passthru.patch | 17 +++++++-------
.../patches/nsis-source-date-epoch.patch | 23 -------------------
4 files changed, 11 insertions(+), 37 deletions(-)
delete mode 100644 gnu/packages/patches/nsis-source-date-epoch.patch

Toggle diff (94 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 10c3192ade..2e02af8b71 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1550,7 +1550,6 @@ dist_patch_DATA = \
%D%/packages/patches/nginx-socket-cloexec.patch \
%D%/packages/patches/nnpack-system-libraries.patch \
%D%/packages/patches/nsis-env-passthru.patch \
- %D%/packages/patches/nsis-source-date-epoch.patch \
%D%/packages/patches/nss-getcwd-nonnull.patch \
%D%/packages/patches/nss-increase-test-timeout.patch \
%D%/packages/patches/nss-3.56-pkgconfig.patch \
diff --git a/gnu/packages/installers.scm b/gnu/packages/installers.scm
index 01ad03e6af..abbc45a1dd 100644
--- a/gnu/packages/installers.scm
+++ b/gnu/packages/installers.scm
@@ -34,16 +34,15 @@ (define (make-nsis machine target-arch nsis-target-type)
(xgcc (cross-gcc triplet #:libc xlibc)))
(package
(name (string-append "nsis-" machine))
- (version "3.05")
+ (version "3.08")
(source (origin
(method url-fetch)
(uri (string-append "http://prdownloads.sourceforge.net/nsis/nsis-"
version "-src.tar.bz2"))
(sha256
(base32
- "1sbwx5vzpddharkb7nj4q5z3i5fbg4lan63ng738cw4hmc4v7qdn"))
- (patches (search-patches "nsis-env-passthru.patch"
- "nsis-source-date-epoch.patch"))))
+ "11qy1n1qdcqwal9hn8cmzm7gxjdyx7by6w14rfz2l646afnp0lm8"))
+ (patches (search-patches "nsis-env-passthru.patch"))))
(build-system scons-build-system)
(native-inputs `(("xgcc" ,xgcc)
("xbinutils" ,xbinutils)
diff --git a/gnu/packages/patches/nsis-env-passthru.patch b/gnu/packages/patches/nsis-env-passthru.patch
index 36b4092230..22b186f55a 100644
--- a/gnu/packages/patches/nsis-env-passthru.patch
+++ b/gnu/packages/patches/nsis-env-passthru.patch
@@ -1,12 +1,11 @@
---- nsis-3.04-src/SConstruct 2019-05-30 14:53:30.276775332 -0400
-+++ nsis-3.04-src/SConstruct 2019-05-30 14:54:17.901232914 -0400
-@@ -77,6 +77,9 @@
- if not toolset and not path:
- defenv = Environment(TARGET_ARCH = arch)
+--- nsis-3.08-src/SConstruct 2021-01-15 17:31:10.000000000 +0100
++++ nsis-3.08-src/SConstruct-passthru 2022-08-02 17:11:12.414702282 +0200
+@@ -71,7 +71,7 @@
-+import os;
-+defenv['ENV'] = os.environ
-+
- Export('defenv')
+ defenv = {
+ 'TARGET_ARCH': ARGUMENTS.get('TARGET_ARCH', 'x86'),
+- 'ENV': {}
++ 'ENV': os.environ.copy()
+ }
######################################################################
diff --git a/gnu/packages/patches/nsis-source-date-epoch.patch b/gnu/packages/patches/nsis-source-date-epoch.patch
deleted file mode 100644
index 744c2a8011..0000000000
--- a/gnu/packages/patches/nsis-source-date-epoch.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Honour SOURCE_DATE_EPOCH for VERSION default
-
-Merged upstream as cd3f1024a37a332f1d4fa96a817ca80dfa2a478c, but not yet in a
-release. GitHub PR: https://github.com/kichik/nsis/pull/13
-
-Python snippet from: https://reproducible-builds.org/docs/source-date-epoch/#python
-
-
-diff --git a/SConstruct b/SConstruct
-index e8252c9..41786f2 100755
---- a/SConstruct
-+++ b/SConstruct
-@@ -95,8 +95,8 @@ default_doctype = 'html'
- if defenv.WhereIs('hhc', os.environ['PATH']):
- default_doctype = 'chm'
-
--from time import strftime, gmtime
--cvs_version = strftime('%d-%b-%Y.cvs', gmtime())
-+import time
-+cvs_version = time.strftime('%d-%b-%Y.cvs', time.gmtime(int(os.environ.get('SOURCE_DATE_EPOCH', time.time()))))
-
- opts = Variables()
-

base-commit: d5ba31c19accdf14bca23ebc0c3baf1c5b08fb5f
--
2.37.1
Vivien Kraus wrote 3 years ago
Fix the target detection fix.
(address . 56892@debbugs.gnu.org)
e431501ce3071bea3436f3273270047f761dc620.camel@planete-kraus.eu
Dear guix,

The NSIS target detection is still screwed up, but now with unicode!

This V2 fixes the fix.

Best regards,

Vivien
宋文武 wrote 3 years ago
Re: bug#56892: [PATCH] Fix nsis.
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)(address . 56892-done@debbugs.gnu.org)
87bkt1rgj4.fsf_-_@envs.net
Vivien Kraus <vivien@planete-kraus.eu> writes:

Toggle quote (6 lines)
> Dear guix,
>
> The NSIS target detection is still screwed up, but now with unicode!
>
> This V2 fixes the fix.

Pushed, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56892@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56892
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help