qutebrowser: wrap-qt-process-path phase wrong type to string-append

  • Done
  • quality assurance status badge
Details
4 participants
  • Jack Hill
  • Lars-Dominik Braun
  • Maxim Cournoyer
  • (
Owner
unassigned
Submitted by
Jack Hill
Severity
normal
J
J
J
Jack Hill wrote on 1 Aug 2022 07:13
(no subject)
(address . control@debbugs.gnu.org)
eeb200f3-f7d5-ee32-ddd3-d348f3e63ab4@jackhill.us
retitle 56864 qutebrowser: wrap-qt-process-path phase wrong type to string-append

thanks
M
M
Maxim Cournoyer wrote on 1 Aug 2022 15:08
Re: bug#56864: qutebrowser
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 56864@debbugs.gnu.org)
877d3s3yc8.fsf@gmail.com
Hello Jack,

Jack Hill <jackhill@jackhill.us> writes:

Toggle quote (6 lines)
> X-Debbugs-CC: maxim.cournoyer@gmail.com
>
> With Guix 3a656ea836f87f30f1b34852cb4efc911363d2b4, qutebrowser's
> wrap-qt-process-path phase fails. Maybe related to the recent Qt work
> in <https://issues.guix.gnu.org/56771>? Build log attatched.

Uh, this was unexpected. I believe it's because label-less inputs are
auto-generated via the package *name* rather than their variable name...
Since qtwebengine-5 (the variable) still has the name "qtwebengine", the
following code:

Toggle snippet (4 lines)
(qt-process-path (string-append (assoc-ref inputs "qtwebengine-5")
"/lib/qt5/libexec/QtWebEngineProcess"))

Doesn't actually find "qtwebengine-5" and it fails attempting to append
#f to "/lib/qt5/libexec/QtWebEngineProcess. The solution that comes to
mind would be using:

(file-input-search inputs "lib/qt5/libexec/QtWebEngineProcess").

Thanks,

Maxim
M
M
Maxim Cournoyer wrote on 1 Aug 2022 15:35
Re: bug#56864: qutebrowser: wrap-qt-process-path phase wrong type to string-append
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 56864-done@debbugs.gnu.org)
8735eg3x3a.fsf_-_@gmail.com
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (24 lines)
> Hello Jack,
>
> Jack Hill <jackhill@jackhill.us> writes:
>
>> X-Debbugs-CC: maxim.cournoyer@gmail.com
>>
>> With Guix 3a656ea836f87f30f1b34852cb4efc911363d2b4, qutebrowser's
>> wrap-qt-process-path phase fails. Maybe related to the recent Qt work
>> in <https://issues.guix.gnu.org/56771>? Build log attatched.
>
> Uh, this was unexpected. I believe it's because label-less inputs are
> auto-generated via the package *name* rather than their variable name...
> Since qtwebengine-5 (the variable) still has the name "qtwebengine", the
> following code:
>
> (qt-process-path (string-append (assoc-ref inputs "qtwebengine-5")
> "/lib/qt5/libexec/QtWebEngineProcess"))
>
> Doesn't actually find "qtwebengine-5" and it fails attempting to append
> #f to "/lib/qt5/libexec/QtWebEngineProcess. The solution that comes to
> mind would be using:
>
> (file-input-search inputs "lib/qt5/libexec/QtWebEngineProcess").

Yep, that did it.

Fixed in aea756ea3312ba7e8229804492ba12001c8de568.

Closing.

Thanks for the report!

Maxim
Closed
L
L
Lars-Dominik Braun wrote on 1 Aug 2022 16:10
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
Yufe51kTwj1eZrBu@noor.fritz.box
Hi Maxim,

Toggle quote (4 lines)
> Yep, that did it.
>
> Fixed in aea756ea3312ba7e8229804492ba12001c8de568.

this does not fix the build of lyx and twinkle for me, which both fail at 'qt-wrap:

---snip---
starting phase `qt-wrap'
error: in phase 'qt-wrap': uncaught exception:
wrong-type-arg "substring" "Wrong type argument in position ~A (expecting ~A): ~S" (1 "string" #f) (#f)
phase `qt-wrap' failed after 0.0 seconds
Backtrace:
9 (primitive-load "/gnu/store/gm47sv2ndfg906vkdr68nbv7zsi…")
In guix/build/gnu-build-system.scm:
906:2 8 (gnu-build #:source _ #:outputs _ #:inputs _ #:phases . #)
In ice-9/boot-9.scm:
1752:10 7 (with-exception-handler _ _ #:unwind? _ # _)
In srfi/srfi-1.scm:
634:9 6 (for-each #<procedure 7ffff0b45020 at guix/build/gnu-b…> …)
In ice-9/boot-9.scm:
1752:10 5 (with-exception-handler _ _ #:unwind? _ # _)
In guix/build/gnu-build-system.scm:
927:23 4 (_)
In guix/build/qt-utils.scm:
148:22 3 (wrap-all-qt-programs #:inputs _ #:outputs _ #:qtbase _ …)
In unknown file:
2 (string-drop #f 44)
In ice-9/boot-9.scm:
1685:16 1 (raise-exception _ #:continuable? _)
1685:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
In procedure substring: Wrong type argument in position 1 (expecting string): #f
---snap---

Maybe a different incarnation of the same issue?

Lars
(
CLUR82NLIUMN.C6PPO28ZW6BJ@guix-aspire
On Mon Aug 1, 2022 at 3:10 PM BST, Lars-Dominik Braun wrote:
Toggle quote (1 lines)
> Maybe a different incarnation of the same issue?
The fix is on the package side, so other affected packages won't have
been fixed by that commit.

-- (
(
CLURQVDPRLVA.3HVXYCV8JDKO6@guix-aspire
This issue affects the following packages as well as qute:

twinkle, lyx, nheko, quaternion, kcrash, likely many KDE packages
(possibly kdenlive, kdevelop, and others), kguiaddons, psi, sonnet.

(Not a complete list, of course.)

-- (
M
M
Maxim Cournoyer wrote on 1 Aug 2022 17:43
(name . ()(address . paren@disroot.org)
87tu6w2cma.fsf@gmail.com
Hi,

"(" <paren@disroot.org> writes:

Toggle quote (5 lines)
> This issue affects the following packages as well as qute:
>
> twinkle, lyx, nheko, quaternion, kcrash, likely many KDE packages
> (possibly kdenlive, kdevelop, and others), kguiaddons, psi, sonnet.

Proposed fix at:
objects I'll push it soon.

Thanks,

Maxim
M
M
Maxim Cournoyer wrote on 2 Aug 2022 06:59
control message for bug #56864
(address . control@debbugs.gnu.org)
8735ef2qcq.fsf@gmail.com
close 56864
quit
?