gnu: Add r-phyclust and r-infercnv. (New variables)

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 3 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
3f5cff2631864372b7a0b1233e11ce86@mdc-berlin.de

Attachment: file
Mădălin Ionel Patrașcu wrote 3 years ago
[PATCH 2/2] gnu: Add r-infercnv.
(address . 56819@debbugs.gnu.org)
20220728213859.21641-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-infercnv): New variable.
---
gnu/packages/bioconductor.scm | 60 +++++++++++++++++++++++++++++++++++
1 file changed, 60 insertions(+)

Toggle diff (80 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 31484799b2..e9bfbed9b5 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -49,6 +49,7 @@ (define-module (gnu packages bioconductor)
#:use-module (gnu packages image)
#:use-module (gnu packages maths)
#:use-module (gnu packages netpbm)
+ #:use-module (gnu packages python)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages statistics)
@@ -2647,6 +2648,65 @@ (define-public r-ideoviz
arbitrary genomic intervals along chromosomal ideogram.")
(license license:gpl2)))
+(define-public r-infercnv
+ (package
+ (name "r-infercnv")
+ (version "1.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "infercnv" version))
+ (sha256
+ (base32
+ "01f021fdxm058733rky46dlvqg7dmf5mn5x9lnq0fspp5665w3bl"))))
+ (properties `((upstream-name . "infercnv")))
+ (build-system r-build-system)
+ (inputs (list python))
+ (propagated-inputs
+ (list r-ape
+ r-argparse
+ r-biocgenerics
+ r-catools
+ r-coda
+ r-coin
+ r-digest
+ r-doparallel
+ r-dplyr
+ r-edger
+ r-fastcluster
+ r-fitdistrplus
+ r-foreach
+ r-futile-logger
+ r-future
+ r-ggplot2
+ r-gplots
+ r-gridextra
+ r-hiddenmarkov
+ r-leiden
+ r-matrix
+ r-paralleldist
+ r-phyclust
+ r-rann
+ r-rcolorbrewer
+ r-reshape
+ r-rjags
+ r-singlecellexperiment
+ r-summarizedexperiment
+ r-tidyr))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/broadinstitute/inferCNV/wiki")
+ (synopsis "Infer copy number variation from single-cell RNA-Seq data")
+ (description
+ "@code{InferCNV} is used to explore tumor single cell RNA-Seq data to identify
+evidence for somatic large-scale chromosomal copy number alterations, such as gains
+or deletions of entire chromosomes or large segments of chromosomes. This is done
+by exploring expression intensity of genes across positions of a tumor genome in
+comparison to a set of reference \"normal\" cells. A heatmap is generated
+illustrating the relative expression intensities across each chromosome, and it
+often becomes readily apparent as to which regions of the tumor genome are
+over-abundant or less-abundant as compared to that of normal cells.")
+ (license license:bsd-3)))
+
(define-public r-iranges
(package
(name "r-iranges")
--
2.37.1
Mădălin Ionel Patrașcu wrote 3 years ago
[PATCH 1/2] gnu: Add r-phyclust.
(address . 56819@debbugs.gnu.org)
20220728213859.21641-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-phyclust): New variable.
---
gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 731facb4e5..e63cb28e19 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11699,6 +11699,31 @@ (define-public r-nleqslv
singular or ill-conditioned Jacobian.")
(license license:gpl2+)))
+(define-public r-phyclust
+ (package
+ (name "r-phyclust")
+ (version "0.1-30")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "phyclust" version))
+ (sha256
+ (base32
+ "0fy9q95vmlm9idpax7alhpfwn30gflnc9md72g91jypyxkx5nr7p"))))
+ (properties `((upstream-name . "phyclust")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ape))
+ (home-page "https://snoweye.github.io/phyclust/")
+ (synopsis "Studying phyloclustering and exploring DNA sequence data")
+ (description
+ "@dfn{Phylogenetic clustering} (phyloclustering) is an evolutionary continuous
+time Markov Chain model-based approach to identify population structure from
+molecular data without assuming linkage equilibrium. The package @code{phyclust}
+provides a convenient implementation of phyloclustering for DNA and SNP data,
+capable of clustering individuals into subpopulations and identifying molecular
+sequences representative of those subpopulations. It is designed in @code{C} for
+performance and interfaced with @code{R} for visualization.")
+ (license license:gpl2+)))
+
(define-public r-physicalactivity
(package
(name "r-physicalactivity")

base-commit: bdb2e262fcbea76de807cd829c2d2270661546a5
--
2.37.1
Ricardo Wurmus wrote 3 years ago
Re: [bug#56819] [PATCH 2/2] gnu: Add r-infercnv.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 56819@debbugs.gnu.org)
87k07sniyl.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (1 lines)
> * gnu/packages/bioconductor.scm (r-infercnv): New variable.
[…]
Toggle quote (2 lines)
> + r-phyclust

This variable is not defined anywhere, or maybe I just can’t find it.

--
Ricardo
Ricardo Wurmus wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 56819-done@debbugs.gnu.org)
87pmhjm4sy.fsf@elephly.net
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (8 lines)
> Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:
>
>> * gnu/packages/bioconductor.scm (r-infercnv): New variable.
> […]
>> + r-phyclust
>
> This variable is not defined anywhere, or maybe I just can’t find it.

The problem was that I only received the second email; the first one
wasn’t cc’d to me. I then saw that the first patch is right there on
issues.guix.gnu.org, so I applied them both.

Sorry for the confusion!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56819@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56819
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help