[PATCH] gnu: Add r-muscat.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220728101800.10580-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-muscat): New variable.
---
gnu/packages/bioconductor.scm | 50 +++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 31484799b2..c79787cea2 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4629,6 +4629,56 @@ (define-public r-motifrg
throughput genetic sequencing data sets using regression methods.")
(license license:artistic2.0)))
+(define-public r-muscat
+ (package
+ (name "r-muscat")
+ (version "1.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "muscat" version))
+ (sha256
+ (base32
+ "1j3zkhqgza92vdykb1yia1jjwsdqra6q9c0jk6p5p2x0778xqgfd"))))
+ (properties `((upstream-name . "muscat")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocparallel
+ r-blme
+ r-complexheatmap
+ r-data-table
+ r-deseq2
+ r-dplyr
+ r-edger
+ r-ggplot2
+ r-glmmtmb
+ r-limma
+ r-lme4
+ r-lmertest
+ r-matrix
+ r-matrixstats
+ r-progress
+ r-purrr
+ r-s4vectors
+ r-scales
+ r-scater
+ r-sctransform
+ r-scuttle
+ r-singlecellexperiment
+ r-summarizedexperiment
+ r-variancepartition
+ r-viridis))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/HelenaLC/muscat")
+ (synopsis "Multi-sample multi-group scRNA-seq data analysis tools")
+ (description
+ "This package @code{muscat} provides various methods and visualization tools
+for @dfn{DS}(differential splicing) analysis in multi-sample, multi-group,
+multi-(cell-)subpopulation scRNA-seq data, including cell-level mixed models and
+methods based on aggregated \"pseudobulk\" data, as well as a flexible simulation
+platform that mimics both single and multi-sample scRNA-seq data.")
+ (license license:gpl3)))
+
(define-public r-mutationalpatterns
(package
(name "r-mutationalpatterns")

base-commit: dbcd7876566840f31b763e28bb74394f0914b397
--
2.37.1
Ricardo Wurmus wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 56812-done@debbugs.gnu.org)
87bkt4nf0q.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/bioconductor.scm (r-muscat): New variable.

Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56812@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56812
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help