[PATCH] gnu: Add r-millefy.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220727081742.27956-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-millefy): New variable.
---
gnu/packages/bioinformatics.scm | 37 ++++++++++++++++++++++++++++++++-
1 file changed, 36 insertions(+), 1 deletion(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 325c159df1..cf736dfbaa 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2017, 2021, 2022 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
-;;; Copyright © 2018, 2019, 2020, 2021 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2018, 2019, 2020, 2021, 2022 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2019, 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
@@ -7523,6 +7523,41 @@ (define-public r-scde
;; See https://github.com/hms-dbmi/scde/issues/38
(license license:gpl2)))
+(define-public r-millefy
+ (package
+ (name "r-millefy")
+ (version "0.1.9-beta")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yuifu/millefy")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0z2y0x99f761pxvg6n37cmnyrnj699jhjk43pvk05sa86iykgizl"))))
+ (properties `((upstream-name . "millefy")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-data-table
+ r-destiny
+ r-dplyr
+ r-genomicranges
+ r-iranges
+ r-magrittr
+ r-rsamtools
+ r-rtracklayer
+ r-tidyr))
+ (home-page "https://github.com/yuifu/millefy")
+ (synopsis "Make millefy plot with single-cell RNA-seq data")
+ (description "@code{Millefy} is a tool for visualizing read coverage of
+@dfn{scRNA-seq}(single-cell RNA sequencing) datasets in genomic contexts. By
+dynamically and automatically reorder single cells based on locus-specific
+pseudo time, @code{Millefy} highlights cell-to-cell heterogeneity in read coverage
+of scRNA-seq data.")
+ (license license:expat)))
+
(define-public r-misha
(package
(name "r-misha")

base-commit: dbcd7876566840f31b763e28bb74394f0914b397
--
2.37.1
Ricardo Wurmus wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 56790-done@debbugs.gnu.org)
87sfmgnlk9.fsf@elephly.net
Toggle quote (2 lines)
> * gnu/packages/bioinformatics.scm (r-millefy): New variable.

Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56790@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56790
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help