Marcel van der Boom wrote 3 years ago
(address . guix-patches@gnu.org)(name . Marcel van der Boom)(address . marcel@van-der-boom.nl)
ppc64 and arm do not raise exception and thus output and exit code for test is different.
* gnu/packages/patches/exiv2-ppc64.patch: Modify test for ppc64
* gnu/packages/image.scm (exiv2): add `patches` field for source if target is ppc64
See:
upstream.
---
gnu/packages/image.scm | 5 ++++-
gnu/packages/patches/exiv2-ppc64.patch | 11 +++++++++++
2 files changed, 15 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/exiv2-ppc64.patch
Toggle diff (37 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index d52d57b3b1..dc4bf76790 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1342,7 +1342,10 @@ (define-public exiv2
(uri (string-append "https://www.exiv2.org/builds/exiv2-" version
"-Source.tar.gz"))
(sha256
- (base32 "1qm6bvj28l42km009nc60gffn1qhngc0m2wjlhf90si3mcc8d99m"))))
+ (base32 "1qm6bvj28l42km009nc60gffn1qhngc0m2wjlhf90si3mcc8d99m"))
+ (patches
+ (if (target-ppc64le?)
+ (list (search-patch "exiv2-ppc64.patch"))))))
(build-system cmake-build-system)
(arguments
'(#:test-target "tests"
diff --git a/gnu/packages/patches/exiv2-ppc64.patch b/gnu/packages/patches/exiv2-ppc64.patch
new file mode 100644
index 0000000000..a74a7ac1b7
--- /dev/null
+++ b/gnu/packages/patches/exiv2-ppc64.patch
@@ -0,0 +1,11 @@
+--- /tests/bugfixes/github/test_CVE_2018_12265.py
++++ /tests/bugfixes/github/test_CVE_2018_12265.py
+@@ -18,7 +18,6 @@
+ Warning: Directory Image, entry 0x0201: Strip 0 is outside of the data area; ignored.
+ Warning: Directory Image, entry 0x0201: Strip 7 is outside of the data area; ignored.
+ Error: Offset of directory Thumbnail, entry 0x0201 is out of bounds: Offset = 0x00000000; truncating the entry
+-$uncaught_exception $addition_overflow_message
+ """
+ ]
+- retval = [1]
++ retval = [0]
base-commit: 212ca81895b2baa819ea11a308ad21880b84a546
--
2.37.1