[PATCH 0/2]: gnu: Add libsep (astronopy)

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 3 years ago
(address . guix-patches@gnu.org)
CAO+9K5p_htCJPeotXwptsQ4cBv98UQ_x_4Zsj6XJUD9GanqDLQ@mail.gmail.com
Hi Guix team!
This patch series introduce C library from SEP project as a main
package libsep and inherit python-sep out of it.
Toggle quote (1 lines)
> ./pre-inst-env guix build python-sep libsep
/gnu/store/31zbssd2kxn3bafqfg1283vqi7f9adj5-libsep-1.2.1
/gnu/store/d7ww46gygffzdmq48aqi3r787dnsyhlr-python-sep-1.2.1
Sharlatan Hellseher (2):
gnu: Add libsep
gnu: python-sep: Update to 1.2.1
gnu/packages/astronomy.scm | 69 ++++++++++++++++++++++++++++----------
1 file changed, 51 insertions(+), 18 deletions(-)
base-commit: 7aab4eddd04e4b26986903680b28dce2de0f4db0
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Sharlatan Hellseher wrote 3 years ago
[PATCH 1/2]: gnu: Add libsep
(address . 56730@debbugs.gnu.org)
CAO+9K5pPRScNwO9WN2A4FYrRQ-w1GNmZ02145jaSK2u8RMJC4g@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 67b697c2e8fd8a2fa81914ead555290b0e2fb36b Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 23 Jul 2022 22:00:44 +0100
Subject: [PATCH 1/2] gnu: Add libsep

* gnu/packages/astronomy.scm: (libsep): New variable.
---
gnu/packages/astronomy.scm | 42 ++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 498252aaf4..e5f50001fe 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1131,6 +1131,48 @@ (define-public libnova
(license (list license:lgpl2.0+
license:gpl2+)))) ; examples/transforms.c & lntest/*.c
+(define-public libsep
+ (package
+ (name "libsep")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kbarbary/sep")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0sag96am6r1ffh9860yq40js874362v3132ahlm6sq7padczkicf"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (chdir "../source")
+ (invoke "make"
+ (string-append "CC=" #$(cc-for-target))
+ "test")))))))
+ (native-inputs
+ (list python-wrapper))
+ (home-page "https://github.com/kbarbary/sep")
+ (synopsis "Astronomical source extraction and photometry library")
+ (description
+ "SEP makes the core algorithms of
+@url{https://www.astromatic.net/software/sextractor/, sextractor} available as a
+library of stand-alone functions and classes. These operate directly on
+in-memory arrays (no FITS files or configuration files). The code is derived
+from the Source Extractor code base (written in C) and aims to produce results
+compatible with Source Extractor whenever possible. SEP consists of a C library
+with no dependencies outside the standard library, and a Python module that
+wraps the C library in a Pythonic API. The Python wrapper operates on NumPy
+arrays with NumPy as its only dependency.")
+ (license (list license:expat license:lgpl3+ license:bsd-3))))
+
(define-public libskry
(package
(name "libskry")
--
2.36.1
Sharlatan Hellseher wrote 3 years ago
[PATCH 2/2]: gnu: python-sep: Update to 1.2.1
(address . 56730@debbugs.gnu.org)
CAO+9K5q_-4E-Twb7KAVW-KA=Rj9Y3BL48SEw4AQnOZhmCx=GZA@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 12c617952c5b9294899da48a56bd936d2cfa5e86 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 23 Jul 2022 22:12:30 +0100
Subject: [PATCH 2/2] gnu: python-sep: Update to 1.2.1

* gnu/packages/astronomy.scm: (python-sep): Update to 1.2.1.
Inherit from libsep
---
gnu/packages/astronomy.scm | 27 +++++++++------------------
1 file changed, 9 insertions(+), 18 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index e5f50001fe..83d058d5c4 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1650,27 +1650,18 @@ (define-public python-pyerfa
(define-public python-sep
(package
+ (inherit libsep)
(name "python-sep")
- (version "1.1.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "sep" version))
- (sha256
- (base32 "0wxdqn92q1grv8k7xi7h88ac6wnznw4xh5bdlz1vz6za2dgsyj4m"))))
(build-system python-build-system)
+ (arguments
+ (strip-keyword-arguments
+ '(#:make-flags) (package-arguments libsep)))
(native-inputs
- (list python-cython python-pytest))
- (inputs
- (list python-numpy))
- (home-page "https://github.com/kbarbary/sep")
- (synopsis "Astronomical source extraction and photometry library")
- (description
- "SEP makes the core algorithms of Source Extractor available as a library
-of stand-alone functions and classes.")
- (license (list license:bsd-3
- license:expat
- license:lgpl3+))))
+ (modify-inputs (package-inputs libsep)
+ (prepend python-cython)))
+ (propagated-inputs
+ (modify-inputs (package-inputs libsep)
+ (prepend python-numpy)))))
(define-public python-asdf
(package
--
2.36.1
Ludovic Courtès wrote 3 years ago
Re: bug#56730: [PATCH 0/2]: gnu: Add libsep (astronopy)
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 56730-done@debbugs.gnu.org)
87r1201fbu.fsf@gnu.org
Hi,

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (3 lines)
> gnu: Add libsep
> gnu: python-sep: Update to 1.2.1

Applied both, thanks!

It would be nice to see if ‘python-sep’ can be made to depend on
‘libsep’ (currently I think it rebuilds the whole C library and embeds
it into the Python bindings).

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56730@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56730
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help