[PATCH] gnu: go-gitlab.com-shackra-goimapnotify: Update to 2.3.7.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Ludovic Courtès
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 3 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163288AB2F7739129064E8BC5909@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/mail.scm (go-gitlab.com-shackra-goimapnotify): Update to 2.3.7.
---

Tested working on my system and passes guix lint. Doesn't look like anything
depends on this package

gnu/packages/mail.scm | 52 +++++++++++++++++++++----------------------
1 file changed, 25 insertions(+), 27 deletions(-)

Toggle diff (66 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 556c5b4305..dfbaccd782 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -403,34 +403,32 @@ (define-public mailutils
(list license:gpl3+ license:lgpl3+))))
(define-public go-gitlab.com-shackra-goimapnotify
- (let ((commit "832bc7112db9b28e28d69e90b91ea6c005244c9b")
- (revision "0"))
- (package
- (name "go-gitlab.com-shackra-goimapnotify")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/shackra/goimapnotify")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1h27kshx4vwl5k6vc2szsq3d701fzs4gczjypz907f8hj0lrnjmy"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "gitlab.com/shackra/goimapnotify"))
- (propagated-inputs
- (list go-github-com-emersion-go-imap
- go-github-com-emersion-go-imap-idle
- go-github-com-emersion-go-sasl go-github-com-sirupsen-logrus
- go-golang-org-x-text))
- (synopsis "Execute scripts on IMAP mailbox changes")
- (description
- "Script to execute scripts on IMAP mailbox changes (new/deleted/updated
+ (package
+ (name "go-gitlab.com-shackra-goimapnotify")
+ (version "2.3.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/shackra/goimapnotify")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06jhxvhdvdv049qpvp8ahnhvswvbpakpw7aq2lw790f3x89px2ss"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "gitlab.com/shackra/goimapnotify"))
+ (propagated-inputs
+ (list go-github-com-emersion-go-imap
+ go-github-com-emersion-go-imap-idle
+ go-github-com-emersion-go-sasl go-github-com-sirupsen-logrus
+ go-golang-org-x-text))
+ (synopsis "Execute scripts on IMAP mailbox changes")
+ (description
+ "Script to execute scripts on IMAP mailbox changes (new/deleted/updated
messages) using IDLE. Implemented in Go.")
- (home-page "https://gitlab.com/shackra/goimapnotify")
- (license license:gpl3+))))
+ (home-page "https://gitlab.com/shackra/goimapnotify")
+ (license license:gpl3+)))
(define-public guile2.2-mailutils
(package
--
2.37.0
Ludovic Courtès wrote 3 years ago
(address . Morgan.J.Smith@outlook.com)(address . 56703-done@debbugs.gnu.org)
878ro1dqwv.fsf@gnu.org
Hi,

Morgan.J.Smith@outlook.com skribis:

Toggle quote (4 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/mail.scm (go-gitlab.com-shackra-goimapnotify): Update to 2.3.7.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56703@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56703
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help