[PATCH 0/2]: gnu: Add h5netcdf

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 3 years ago
(address . guix-patches@gnu.org)
CAO+9K5q3PxaAgFMLR-JH=CgxMr3bQZ46i8zKmFSZFuiO_gw_dw@mail.gmail.com
Hi Guix team!
This patch set adds Python package h5netcdf.
Version 1.0.1 requires netcdf4 to be updated to 1.6.0
All related packages built successfully after update
Toggle quote (1 lines)
> ./pre-inst-env guix build python-h5netcdf python-meshio python-netcdf4 --rounds=2
/gnu/store/38pwb87l6bggh2b0dvymxq53ld0vnz5h-python-netcdf4-1.6.0
/gnu/store/hb5ynj6nq4b0k6jabkdmfmyj9d7ia002-python-meshio-5.3.4
/gnu/store/ykb7a23a2mvmla1sqvkjlbq5165qyy7r-python-h5netcdf-1.0.1
Sharlatan Hellseher (2):
gnu: netcdf4: Update to 1.6.0
gnu: Add h5netcdf
gnu/packages/python-xyz.scm | 35 +++++++++++++++++++++++++++++++++--
1 file changed, 33 insertions(+), 2 deletions(-)
base-commit: cd3c4ad8fc113608eade2e5c29ba8486cde01157
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Sharlatan Hellseher wrote 3 years ago
[PATCH 1/2]: gnu: netcdf4: Update to 1.6.0
(address . 56700@debbugs.gnu.org)
CAO+9K5rtjp2ENkAB9ReVEsAPKANHhCjT3Susut6UCrMGpoXXXA@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 63b41517ef82a91f56ab99faa2ac9d1bf5112511 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Fri, 22 Jul 2022 12:34:36 +0100
Subject: [PATCH 1/2] gnu: netcdf4: Update to 1.6.0

* gnu/packages/python-xyz.scm: (python-netcdf4): Update to 1.6.0.
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 11f709f7b5..afb7798a5c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1646,14 +1646,14 @@ (define-public python-cftime
(define-public python-netcdf4
(package
(name "python-netcdf4")
- (version "1.5.3")
+ (version "1.6.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "netCDF4" version))
(sha256
(base32
- "1gn35mb2yc263pci720aik8ymz41lrvxlrn3z83vyjwghiashg1a"))))
+ "0qxs8r1qmsmg760wm5q0wqlcm7hdd3k7cghryw6wvqd3v5rs7vwm"))))
(build-system python-build-system)
(arguments
'(#:phases
--
2.36.1
Sharlatan Hellseher wrote 3 years ago
[PATCH 2/2]: gnu: Add h5netcdf
(address . 56700@debbugs.gnu.org)
CAO+9K5pEz7O15JyFgDj2FzSuhx3OAvH1a5mjj-Xxr8PWr4MTfg@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From bc8af5a649cfbd0c342e1281b59627e55a141e7e Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Fri, 22 Jul 2022 12:44:37 +0100
Subject: [PATCH 2/2] gnu: Add h5netcdf

* gnu/packages/python-xyz.scm: (python-h5netcdf): New variable.
---
gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index afb7798a5c..93935d3b03 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1481,6 +1481,37 @@ (define-public python-hdf4
@url{http://hdfeos.org/software/pyhdf.php,pyhdf}.")
(license license:expat)))
+(define-public python-h5netcdf
+ (package
+ (name "python-h5netcdf")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "h5netcdf" version))
+ (sha256
+ (base32 "1b2dcgf5rwy7pb7hr4prkc5vgcw9qc2was20dmnj90lbrpx08rvp"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "h5netcdf/tests")))))))
+ (native-inputs
+ (list python-netcdf4
+ python-pytest
+ python-setuptools-scm))
+ (propagated-inputs
+ (list python-h5py python-packaging))
+ (home-page "https://h5netcdf.org")
+ (synopsis "Python interface for the netCDF4 file-format based on h5py")
+ (description "This package provides Python interface for the netCDF4
+file-format that reads and writes local or remote HDF5 files directly via h5py
+or h5pyd, without relying on the Unidata netCDF library")
+ (license license:bsd-3)))
+
(define-public python-h5py
(package
(name "python-h5py")
--
2.36.1
Ludovic Courtès wrote 3 years ago
Re: bug#56700: [PATCH 0/2]: gnu: Add h5netcdf
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 56700-done@debbugs.gnu.org)
878ro4nx26.fsf@gnu.org
Hi,

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (3 lines)
> gnu: netcdf4: Update to 1.6.0
> gnu: Add h5netcdf

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56700@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56700
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help