SuperCollider's Help Browser doesn't display text (possible QtWebEngine issue?)

  • Open
  • quality assurance status badge
Details
One participant
  • Gabriel Wicki
Owner
unassigned
Submitted by
Gabriel Wicki
Severity
normal
G
G
Gabriel Wicki wrote on 21 Jul 2022 01:33
(address . bug-guix@gnu.org)
20220720233316.ddw53uqi3dhyvzfo@silvi
Hi!

I've noticed that when starting SuperCollider IDE (with the scide
command) the Help Browser (which is the panel on top on the right side
with vanilla/no configuration) doesn't show any text. IIRC
SuperCollider's documentation is HTML documents (you can also browse it
online [1]) displayed through some QtWeb-widget (I am no expert in Qt).

My first question: is this reproducible? Or do others also see no text
in the Help Browser?


I have tried adding qtwebengine as an input and passing a configure
flag, but this didn't change the issue:

Toggle diff (30 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index bab9d66a2d..975690b72f 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3183,6 +3183,7 @@ (define-public supercollider
"-DSC_QT=ON"
"-DCMAKE_BUILD_TYPE=Release"
"-DFORTIFY=ON"
+ "-DSC_USE_QTWEBENGINE:BOOL=ON"
;; "-DLIBSCSYNTH=ON" ; TODO: Re-enable?
"-DSC_EL=OFF") ;scel is packaged individually as emacs-scel
#:phases
@@ -3234,6 +3235,7 @@ (define-public supercollider
qtdeclarative
qtsvg
qtwebchannel
+ qtwebengine
qtwebsockets))
(propagated-inputs ;to get native-search-path
(list qtwebengine))


I'm more than happy to hunt that bug down but am grateful for any
pointers to where the issue could possibly originate.


gabriel


[1] https://doc.sccode.org
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 56676@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56676
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch