(address . bug-guix@gnu.org)
Hi!
I've noticed that when starting SuperCollider IDE (with the scide
command) the Help Browser (which is the panel on top on the right side
with vanilla/no configuration) doesn't show any text. IIRC
SuperCollider's documentation is HTML documents (you can also browse it
online [1]) displayed through some QtWeb-widget (I am no expert in Qt).
My first question: is this reproducible? Or do others also see no text
in the Help Browser?
I have tried adding qtwebengine as an input and passing a configure
flag, but this didn't change the issue:
Toggle diff (30 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index bab9d66a2d..975690b72f 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3183,6 +3183,7 @@ (define-public supercollider
"-DSC_QT=ON"
"-DCMAKE_BUILD_TYPE=Release"
"-DFORTIFY=ON"
+ "-DSC_USE_QTWEBENGINE:BOOL=ON"
;; "-DLIBSCSYNTH=ON" ; TODO: Re-enable?
"-DSC_EL=OFF") ;scel is packaged individually as emacs-scel
#:phases
@@ -3234,6 +3235,7 @@ (define-public supercollider
qtdeclarative
qtsvg
qtwebchannel
+ qtwebengine
qtwebsockets))
(propagated-inputs ;to get native-search-path
(list qtwebengine))
I'm more than happy to hunt that bug down but am grateful for any
pointers to where the issue could possibly originate.
gabriel
[1] https://doc.sccode.org