On 2022-07-26 12:23, Andrew Tropin wrote:
Toggle quote (60 lines)
> On 2022-07-21 19:25, Maxime Devos wrote:
>
>> On 21-07-2022 19:13, Andrew Tropin wrote:
>>
>>> The source code is here:
>>> https://git.sr.ht/~abcdw/rde/commit/c5b4097ab99309ace23e40d957e9fa1f938f97e9
>>
>> What's the 'guix-home-gc-roots' for? I would expect the reference
>> #$(file-append he "/activate") to be sufficient to keep things from
>> being gc'ed.
>
> It was needed while I was testing manual activation without shepherd
> service, not needed anymore, already removed it locally.
>
>>
>>> +
>>> <https://git.sr.ht/~abcdw/rde/commit/c5b4097ab99309ace23e40d957e9fa1f938f97e9#gnu/services/home.scm-1-23>
>>> (start #~(make-forkexec-constructor +
>>> <https://git.sr.ht/~abcdw/rde/commit/c5b4097ab99309ace23e40d957e9fa1f938f97e9#gnu/services/home.scm-1-24>
>>> '(#$(file-append he "/activate")) +
>>> <https://git.sr.ht/~abcdw/rde/commit/c5b4097ab99309ace23e40d957e9fa1f938f97e9#gnu/services/home.scm-1-25>
>>> #:user #$user +
>>> <https://git.sr.ht/~abcdw/rde/commit/c5b4097ab99309ace23e40d957e9fa1f938f97e9#gnu/services/home.scm-1-26>
>>> #:environment-variables +
>>> <https://git.sr.ht/~abcdw/rde/commit/c5b4097ab99309ace23e40d957e9fa1f938f97e9#gnu/services/home.scm-1-27>
>>> (list (string-append "HOME=" (passwd:dir (getpw #$user)))) +
>>> <https://git.sr.ht/~abcdw/rde/commit/c5b4097ab99309ace23e40d957e9fa1f938f97e9#gnu/services/home.scm-1-28>
>>> #:group (group:name (getgrgid (passwd:gid (getpw #$user))))))
>> I'm wondering if GUIX_LOCPATH is needed as well. Anyway, if not done
>> already internally by /activate, you could consider doing it in a
>> container to reduce potential irreproducibility, or insecurity on
>> multi-user systems (I'd assume the #:user + #:group to be sufficient for
>> security, especially if it appears sufficient for other system services,
>> but I'm not some expert on what things need to be set).
>>
> It's not set by /activate.
>
>>> +
>>> <https://git.sr.ht/~abcdw/rde/commit/c5b4097ab99309ace23e40d957e9fa1f938f97e9#gnu/services/home.scm-1-20>
>>> (provision (list (symbol-append 'guix-home- (string->symbol user)))) +
>>> <https://git.sr.ht/~abcdw/rde/commit/c5b4097ab99309ace23e40d957e9fa1f938f97e9#gnu/services/home.scm-1-21>
>>> (one-shot? #t) +
>>> <https://git.sr.ht/~abcdw/rde/commit/c5b4097ab99309ace23e40d957e9fa1f938f97e9#gnu/services/home.scm-1-22>
>>> (auto-start? #f)
>> Wouldn't it then be possible for the user to login via the login manager
>> before initialisation has completed, as gdm etc don't wait for
>> guix-home-... currently?
>
> You are right, the same as the first one, needed for more manual
> approach, changed to #t, thank you.
>
> Three patches for this service to work is on the way on guix-patches.
> In the meantime, will try to build livecd with the home environment
> inside.
>
> P.S. Probably this system service is far from final version of this
> feature, I still think about making home-environment a part of
> user-account. Will evaluate pros and cons, after I get livecd built
> successfully.
Sorry for the long status update, some life moments are happened.
Polished all the things on Guix Home side and I can confirm that the
service works correctly and it's possible to make home-environments a
part of operating-system record.
Current very simple implementation works relatively good. It accepts a
list of ("user" . home-env) pairs and creates a shepherd services, which
activate respective home environments.
This is how sway graphical environment activation is implemented in rde-live image.
I still find it not completely satisfying because activation happens
when one-shot shepherd service get started and not during system
activation, which leads to the problem mentioned by Maxim: you can login
into user's shell before home-environment activated. I would like to
just extend system activation with calls to home activation scripts, but
it's not that straightforward because we depend on user-homes (which is
a shepherd service).
That said the guix-home system service works fine and you can already
use it, but before merging it to Guix I would like to move home
activations into system activation, which requires some work on
user-homes. It doesn't seem to be a big task, but still require some
dedication and IDK when I get spare time for it. Let me know if this
feature blocks you in some way, otherwise I'll keep working on it in my
own pace.
--
Best regards,
Andrew Tropin