[PATCH 00/17] Add libomp per clang-toolchain.

  • Done
  • quality assurance status badge
Details
2 participants
  • Greg Hogan
  • Ludovic Courtès
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 20 Jul 2022 16:49
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
cover.1658327897.git.code@greghogan.com
This continues 03bc18dfcf3cea76be904b0dfbcdf3943ec2fe79 with the
addition of libomp packages for clang-toolchain versions 12 through 6
(the earliest version of clang-toolchain in GNU Guix).

$ ./pre-inst-env guix search clang-toolchain | recsel -p name,dependencies
name: clang-toolchain
dependencies: binutils@2.37 clang@14.0.6 glibc@2.33 ld-wrapper@0 libomp@14.0.6

name: clang-toolchain
dependencies: binutils@2.37 clang@13.0.1 glibc@2.33 ld-wrapper@0 libomp@13.0.1

name: clang-toolchain
dependencies: binutils@2.37 clang@12.0.1 glibc@2.33 ld-wrapper@0 libomp@12.0.1

name: clang-toolchain
dependencies: binutils@2.37 clang@11.0.0 glibc@2.33 ld-wrapper@0 libomp@11.0.0

name: clang-toolchain
dependencies: binutils@2.37 clang@10.0.1 glibc@2.33 ld-wrapper@0 libomp@10.0.1

name: clang-toolchain
dependencies: binutils@2.37 clang@9.0.1 glibc@2.33 ld-wrapper@0 libomp@9.0.1

name: clang-toolchain
dependencies: binutils@2.37 clang@8.0.1 glibc@2.33 ld-wrapper@0 libomp@8.0.1

name: clang-toolchain
dependencies: binutils@2.37 clang@7.1.0 glibc@2.33 ld-wrapper@0 libomp@7.1.0

name: clang-toolchain
dependencies: binutils@2.37 clang@6.0.1 glibc@2.33 ld-wrapper@0 libomp@6.0.1

Greg Hogan (17):
gnu: libomp-14: Reference llvm-14 version string.
gnu: libomp-13: Reference llvm-13 version string.
gnu: Add libomp-12.
gnu: clang-toolchain-12: Use libomp-12.
gnu: Add libomp-11.
gnu: clang-toolchain-11: Use libomp-11.
gnu: Add libomp-10.
gnu: clang-toolchain-10: Use libomp-10.
gnu: Add libomp-9.
gnu: clang-toolchain-9: Use libomp-9.
gnu: Add libomp-8.
gnu: clang-toolchain-8: Use libomp-8.
gnu: Add libomp-7.
gnu: clang-toolchain-7: Use libomp-7.
gnu: Add libomp-6.
gnu: clang-toolchain-6: Use libomp-6.
gnu: make-clang-toolchain: Require explicit libomp.

gnu/packages/llvm.scm | 145 ++++++++++++++++++++++++++++++++++++++----
1 file changed, 132 insertions(+), 13 deletions(-)

--
2.37.0
G
G
Greg Hogan wrote on 20 Jul 2022 17:08
[PATCH 02/17] gnu: libomp-13: Reference llvm-13 version string.
(address . 56666@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
9891c799ae245f0ede532a41fb8340472b0df6f0.1658327897.git.code@greghogan.com
* gnu/packages/llvm.scm (libomp-13): Reference llvm-13 version string.
---
gnu/packages/llvm.scm | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 175aa21208..faf4a42fd1 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -744,7 +744,7 @@ (define-public clang-13
(define-public libomp-13
(package
(inherit libomp-14)
- (version "13.0.1")
+ (version (package-version llvm-13))
(source (origin
(method url-fetch)
(uri (llvm-uri "openmp" version))
@@ -1205,6 +1205,7 @@ (define-public clang-3.5
#:patches '("clang-3.5-libc-search-path.patch")))
;; Default LLVM and Clang version.
+(define-public libomp libomp-13)
(define-public llvm llvm-13)
(define-public clang-runtime clang-runtime-13)
(define-public clang clang-13)
@@ -1582,8 +1583,6 @@ (define-public libclc
;; Apache license 2.0 with LLVM exception
(license license:asl2.0)))
-(define-public libomp libomp-13)
-
(define-public python-llvmlite
(package
(name "python-llvmlite")
--
2.37.0
G
G
Greg Hogan wrote on 20 Jul 2022 17:08
[PATCH 03/17] gnu: Add libomp-12.
(address . 56666@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
85a4bd2c8a72fc2c66959a12b9ae2207c7653685.1658327897.git.code@greghogan.com
* gnu/packages/llvm.scm (libomp-12): New variable.
---
gnu/packages/llvm.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index faf4a42fd1..5896c0f3e4 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -855,6 +855,27 @@ (define-public clang-12
(base32
"1r9a4fdz9ci58b5z2inwvm4z4cdp6scrivnaw05dggkxz7yrwrb5")))))
+(define-public libomp-12
+ (package
+ (inherit libomp-13)
+ (version (package-version llvm-12))
+ (source (origin
+ (method url-fetch)
+ (uri (llvm-uri "openmp" version))
+ (sha256
+ (base32
+ "14dh0r6h2xh747ffgnsl4z08h0ri04azi9vf79cbz7ma1r27kzk0"))
+ (file-name (string-append "libomp-" version ".tar.xz"))))
+ (arguments
+ '(#:configure-flags '("-DLIBOMP_USE_HWLOC=ON"
+ "-DOPENMP_TEST_C_COMPILER=clang"
+ "-DOPENMP_TEST_CXX_COMPILER=clang++")
+ #:test-target "check-libomp"))
+ (native-inputs
+ (modify-inputs (package-native-inputs libomp-13)
+ (replace "clang" clang-12)
+ (replace "llvm" llvm-12)))))
+
(define-public clang-toolchain-12
(make-clang-toolchain clang-12))
--
2.37.0
G
G
Greg Hogan wrote on 20 Jul 2022 17:08
[PATCH 04/17] gnu: clang-toolchain-12: Use libomp-12.
(address . 56666@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
3f3a3674d0d50407f9ee5af269c4ed512136e103.1658327898.git.code@greghogan.com
* gnu/packages/llvm.scm (clang-toolchain-12): Switch dependency from the
default libomp-13 to libomp-12.
---
gnu/packages/llvm.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 5896c0f3e4..7353f92e9d 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -877,7 +877,7 @@ (define-public libomp-12
(replace "llvm" llvm-12)))))
(define-public clang-toolchain-12
- (make-clang-toolchain clang-12))
+ (make-clang-toolchain clang-12 libomp-12))
(define-public llvm-11
(package
--
2.37.0
G
G
Greg Hogan wrote on 20 Jul 2022 17:09
[PATCH 10/17] gnu: clang-toolchain-9: Use libomp-9.
(address . 56666@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
284335a1befcc7371b4ea1a00e63bbb4b82a76a5.1658327898.git.code@greghogan.com
* gnu/packages/llvm.scm (clang-toolchain-9): Switch dependency from the
default libomp-13 to libomp-9.
---
gnu/packages/llvm.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 6b53b7e36d..93bd62bdd3 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1043,7 +1043,7 @@ (define-public libomp-9
(replace "llvm" llvm-9)))))
(define-public clang-toolchain-9
- (make-clang-toolchain clang-9))
+ (make-clang-toolchain clang-9 libomp-9))
(define-public llvm-8
(package
--
2.37.0
G
G
Greg Hogan wrote on 20 Jul 2022 17:08
[PATCH 05/17] gnu: Add libomp-11.
(address . 56666@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
be6b010129f89f0233c5fb01aa594d51ac08a24d.1658327898.git.code@greghogan.com
* gnu/packages/llvm.scm (libomp-11): New variable.
---
gnu/packages/llvm.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 7353f92e9d..07c86b6354 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -909,6 +909,22 @@ (define-public clang-11
(base32
"02bcwwn54661madhq4nxc069s7p7pj5gpqi8ww50w3anbpviilzy")))))
+(define-public libomp-11
+ (package
+ (inherit libomp-12)
+ (version (package-version llvm-11))
+ (source (origin
+ (method url-fetch)
+ (uri (llvm-uri "openmp" version))
+ (sha256
+ (base32
+ "0k389d0g9zlfyzh1kpb3i5jdawzpn0hrdxzbjinpvdv7rbw4sw1d"))
+ (file-name (string-append "libomp-" version ".tar.xz"))))
+ (native-inputs
+ (modify-inputs (package-native-inputs libomp-12)
+ (replace "clang" clang-11)
+ (replace "llvm" llvm-11)))))
+
(define-public clang-toolchain-11
(make-clang-toolchain clang-11))
--
2.37.0
G
G
Greg Hogan wrote on 20 Jul 2022 17:08
[PATCH 01/17] gnu: libomp-14: Reference llvm-14 version string.
(address . 56666@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
dd5bc4d0a11cc4f220376a1eaff0c903515bcffc.1658327897.git.code@greghogan.com
* gnu/packages/llvm.scm (libomp-14): Reference llvm-14 version string.
---
gnu/packages/llvm.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 5a2f411eb2..175aa21208 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -663,7 +663,7 @@ (define-public clang-14
(define-public libomp-14
(package
(name "libomp")
- (version "14.0.6")
+ (version (package-version llvm-14))
(source (origin
(method url-fetch)
(uri (llvm-uri "openmp" version))
--
2.37.0
G
G
Greg Hogan wrote on 20 Jul 2022 17:09
[PATCH 06/17] gnu: clang-toolchain-11: Use libomp-11.
(address . 56666@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
8c93b3c9b63210dedeb3c454c9c3e288e7b9148a.1658327898.git.code@greghogan.com
* gnu/packages/llvm.scm (clang-toolchain-11): Switch dependency from the
default libomp-13 to libomp-11.
---
gnu/packages/llvm.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 07c86b6354..07622a63cf 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -926,7 +926,7 @@ (define-public libomp-11
(replace "llvm" llvm-11)))))
(define-public clang-toolchain-11
- (make-clang-toolchain clang-11))
+ (make-clang-toolchain clang-11 libomp-11))
(define-public llvm-10
(package
--
2.37.0
G
G
Greg Hogan wrote on 20 Jul 2022 17:09
[PATCH 08/17] gnu: clang-toolchain-10: Use libomp-10.
(address . 56666@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
dd61956b28baec8c6eafc7da4aa78ae78701a91f.1658327898.git.code@greghogan.com
* gnu/packages/llvm.scm (clang-toolchain-10): Switch dependency from the
default libomp-13 to libomp-10.
---
gnu/packages/llvm.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index ed1664caf8..a0313afd3d 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -982,7 +982,7 @@ (define-public libomp-10
(replace "llvm" llvm-10)))))
(define-public clang-toolchain-10
- (make-clang-toolchain clang-10))
+ (make-clang-toolchain clang-10 libomp-10))
(define-public llvm-9
(package
--
2.37.0
G
G
Greg Hogan wrote on 20 Jul 2022 17:09
[PATCH 07/17] gnu: Add libomp-10.
(address . 56666@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
8763a21de694a4ad35c75e3fe2ade52c02288ed5.1658327898.git.code@greghogan.com
* gnu/packages/llvm.scm (libomp-10): New variable.
---
gnu/packages/llvm.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 07622a63cf..ed1664caf8 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -965,6 +965,22 @@ (define-public clang-10
(base32
"06n1yp638rh24xdxv9v2df0qajxbjz4w59b7dd4ky36drwmpi4yh")))))
+(define-public libomp-10
+ (package
+ (inherit libomp-11)
+ (version (package-version llvm-10))
+ (source (origin
+ (method url-fetch)
+ (uri (llvm-uri "openmp" version))
+ (sha256
+ (base32
+ "0i4bn84lkpm5w3qkpvwm5z6jdj8fynp7d3bcasa1xyq4is6757yi"))
+ (file-name (string-append "libomp-" version ".tar.xz"))))
+ (native-inputs
+ (modify-inputs (package-native-inputs libomp-11)
+ (replace "clang" clang-10)
+ (replace "llvm" llvm-10)))))
+
(define-public clang-toolchain-10
(make-clang-toolchain clang-10))
--
2.37.0
G
G
Greg Hogan wrote on 20 Jul 2022 17:09
[PATCH 09/17] gnu: Add libomp-9.
(address . 56666@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
fd2c2e8f26ffafffd65df0775e28d729d063a5cc.1658327898.git.code@greghogan.com
* gnu/packages/llvm.scm (libomp-9): New variable.
---
gnu/packages/llvm.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index a0313afd3d..6b53b7e36d 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1026,6 +1026,22 @@ (define-public clang-9
"0ls2h3iv4finqyflyhry21qhc9cm9ga7g1zq21020p065qmm2y2p"
#:patches '("clang-9.0-libc-search-path.patch")))
+(define-public libomp-9
+ (package
+ (inherit libomp-10)
+ (version (package-version llvm-9))
+ (source (origin
+ (method url-fetch)
+ (uri (llvm-uri "openmp" version))
+ (sha256
+ (base32
+ "1knafnpp0f7hylx8q20lkd6g1sf0flly572dayc5d5kghh7hd52w"))
+ (file-name (string-append "libomp-" version ".tar.xz"))))
+ (native-inputs
+ (modify-inputs (package-native-inputs libomp-10)
+ (replace "clang" clang-9)
+ (replace "llvm" llvm-9)))))
+
(define-public clang-toolchain-9
(make-clang-toolchain clang-9))
--
2.37.0
G
G
Greg Hogan wrote on 20 Jul 2022 17:09
[PATCH 16/17] gnu: clang-toolchain-6: Use libomp-6.
(address . 56666@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
81dd52f4124adfc7b175bc2866c034dbe7f21d04.1658327898.git.code@greghogan.com
* gnu/packages/llvm.scm (clang-toolchain-6): Switch dependency from the
default libomp-13 to libomp-6.
---
gnu/packages/llvm.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 8f5efcd5b8..76d2ff4f84 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1171,7 +1171,7 @@ (define-public libomp-6
(replace "llvm" llvm-6)))))
(define-public clang-toolchain-6
- (make-clang-toolchain clang-6))
+ (make-clang-toolchain clang-6 libomp-6))
(define-public llvm-3.9.1
(package (inherit llvm-6)
--
2.37.0
G
G
Greg Hogan wrote on 20 Jul 2022 17:09
[PATCH 11/17] gnu: Add libomp-8.
(address . 56666@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
7b8c83b04597f14593f044d4dc2f191ae30c1fdd.1658327898.git.code@greghogan.com
* gnu/packages/llvm.scm (libomp-8): New variable.
---
gnu/packages/llvm.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 93bd62bdd3..4b798a687b 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1069,6 +1069,23 @@ (define-public clang-8
"0ihnbdl058gvl2wdy45p5am55bq8ifx8m9mhcsgj9ax8yxlzvvvh"
#:patches '("clang-8.0-libc-search-path.patch")))
+(define-public libomp-8
+ (package
+ (inherit libomp-9)
+ (version (package-version llvm-8))
+ (source (origin
+ (method url-fetch)
+ (uri (llvm-uri "openmp" version))
+ (sha256
+ (base32
+ "0b3jlxhqbpyd1nqkpxjfggm5d9va5qpyf7d4i5y7n4a1mlydv19y"))
+ (file-name (string-append "libomp-" version ".tar.xz"))))
+ (native-inputs
+ (modify-inputs (package-native-inputs libomp-9)
+ (replace "clang" clang-8)
+ (replace "llvm" llvm-8)))
+ (license license:ncsa)))
+
(define-public clang-toolchain-8
(make-clang-toolchain clang-8))
--
2.37.0
G
G
Greg Hogan wrote on 20 Jul 2022 17:09
[PATCH 12/17] gnu: clang-toolchain-8: Use libomp-8.
(address . 56666@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
7332bfdf8c6b5c0d472c9951af7cddade66a5fda.1658327898.git.code@greghogan.com
* gnu/packages/llvm.scm (clang-toolchain-8): Switch dependency from the
default libomp-13 to libomp-8.
---
gnu/packages/llvm.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 4b798a687b..2b7e711d35 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1087,7 +1087,7 @@ (define-public libomp-8
(license license:ncsa)))
(define-public clang-toolchain-8
- (make-clang-toolchain clang-8))
+ (make-clang-toolchain clang-8 libomp-8))
(define-public llvm-7
(package
--
2.37.0
G
G
Greg Hogan wrote on 20 Jul 2022 17:09
[PATCH 13/17] gnu: Add libomp-7.
(address . 56666@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
8e567b4b6182a1a48530d0e1e8c79770b2caba9e.1658327898.git.code@greghogan.com
* gnu/packages/llvm.scm (libomp-7): New variable.
---
gnu/packages/llvm.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 2b7e711d35..f818894ab2 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1111,6 +1111,22 @@ (define-public clang-7
"0vc4i87qwxnw9lci4ayws9spakg0z6w5w670snj9f8g5m9rc8zg9"
#:patches '("clang-7.0-libc-search-path.patch")))
+(define-public libomp-7
+ (package
+ (inherit libomp-8)
+ (version (package-version llvm-7))
+ (source (origin
+ (method url-fetch)
+ (uri (llvm-uri "openmp" version))
+ (sha256
+ (base32
+ "1dg53wzsci2kra8lh1y0chh60h2l8h1by93br5spzvzlxshkmrqy"))
+ (file-name (string-append "libomp-" version ".tar.xz"))))
+ (native-inputs
+ (modify-inputs (package-native-inputs libomp-8)
+ (replace "clang" clang-7)
+ (replace "llvm" llvm-7)))))
+
(define-public clang-toolchain-7
(make-clang-toolchain clang-7))
--
2.37.0
G
G
Greg Hogan wrote on 20 Jul 2022 17:09
[PATCH 14/17] gnu: clang-toolchain-7: Use libomp-7.
(address . 56666@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
806c2df600e8ecc3acfb0decfe568a88c47eb507.1658327898.git.code@greghogan.com
* gnu/packages/llvm.scm (clang-toolchain-7): Switch dependency from the
default libomp-13 to libomp-7.
---
gnu/packages/llvm.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index f818894ab2..56656fb683 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1128,7 +1128,7 @@ (define-public libomp-7
(replace "llvm" llvm-7)))))
(define-public clang-toolchain-7
- (make-clang-toolchain clang-7))
+ (make-clang-toolchain clang-7 libomp-7))
(define-public llvm-6
(package
--
2.37.0
G
G
Greg Hogan wrote on 20 Jul 2022 17:09
[PATCH 15/17] gnu: Add libomp-6.
(address . 56666@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
b3b6a6ac00d150217d1fc24cfa825d990759807f.1658327898.git.code@greghogan.com
* gnu/packages/llvm.scm (libomp-6): New variable.
---
gnu/packages/llvm.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 56656fb683..8f5efcd5b8 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1152,6 +1152,24 @@ (define-public clang-6
"0rxn4rh7rrnsqbdgp4gzc8ishbkryhpl1kd3mpnxzpxxhla3y93w"
#:patches '("clang-6.0-libc-search-path.patch")))
+(define-public libomp-6
+ (package
+ (inherit libomp-7)
+ (version (package-version llvm-6))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://releases.llvm.org/"
+ version "/openmp-" version
+ ".src.tar.xz"))
+ (sha256
+ (base32
+ "0nhwfba9c351r16zgyjyfwdayr98nairky3c2f0b2lc360mwmbv6"))
+ (file-name (string-append "libomp-" version ".tar.xz"))))
+ (native-inputs
+ (modify-inputs (package-native-inputs libomp-7)
+ (replace "clang" clang-6)
+ (replace "llvm" llvm-6)))))
+
(define-public clang-toolchain-6
(make-clang-toolchain clang-6))
--
2.37.0
G
G
Greg Hogan wrote on 20 Jul 2022 17:09
[PATCH 17/17] gnu: make-clang-toolchain: Require explicit libomp.
(address . 56666@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
eaf0b368c45940585460961ef07769725ba0a8f6.1658327898.git.code@greghogan.com
* gnu/packages/llvm.scm (make-clang-toolchain): Remove default libomp
parameter since each clang-toolchain has a matching libomp package.
(clang-toolchain-13): Explicitly refer to libomp-13.
---
gnu/packages/llvm.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 76d2ff4f84..4606cccc2a 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -485,7 +485,7 @@ (define (clang-properties version)
"znver3")
'())))))
-(define* (make-clang-toolchain clang #:optional (libomp libomp-13))
+(define (make-clang-toolchain clang libomp)
(package
(name (string-append (package-name clang) "-toolchain"))
(version (package-version clang))
@@ -767,7 +767,7 @@ (define-public libomp-13
(replace "llvm" llvm-13)))))
(define-public clang-toolchain-13
- (make-clang-toolchain clang-13))
+ (make-clang-toolchain clang-13 libomp-13))
(define-public llvm-12
(package
--
2.37.0
L
L
Ludovic Courtès wrote on 4 Aug 2022 11:39
Re: bug#56666: [PATCH 00/17] Add libomp per clang-toolchain.
(name . Greg Hogan)(address . code@greghogan.com)(address . 56666-done@debbugs.gnu.org)
87les4ny9o.fsf@gnu.org
Hi Greg,

Greg Hogan <code@greghogan.com> skribis:

Toggle quote (18 lines)
> gnu: libomp-14: Reference llvm-14 version string.
> gnu: libomp-13: Reference llvm-13 version string.
> gnu: Add libomp-12.
> gnu: clang-toolchain-12: Use libomp-12.
> gnu: Add libomp-11.
> gnu: clang-toolchain-11: Use libomp-11.
> gnu: Add libomp-10.
> gnu: clang-toolchain-10: Use libomp-10.
> gnu: Add libomp-9.
> gnu: clang-toolchain-9: Use libomp-9.
> gnu: Add libomp-8.
> gnu: clang-toolchain-8: Use libomp-8.
> gnu: Add libomp-7.
> gnu: clang-toolchain-7: Use libomp-7.
> gnu: Add libomp-6.
> gnu: clang-toolchain-6: Use libomp-6.
> gnu: make-clang-toolchain: Require explicit libomp.

Nice work! Applied, thanks.

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56666@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56666
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch