[PATCH] gnu: ranger: Add dependency file

  • Open
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Ludovic Courtès
  • Nguy?n Gia Phong
Owner
unassigned
Submitted by
Nguy?n Gia Phong
Severity
normal
N
N
Nguy?n Gia Phong wrote on 20 Jul 2022 10:01
(address . guix-patches@gnu.org)(name . Nguy?n Gia Phong)(address . mcsinyx@disroot.org)
20220720080143.18005-1-mcsinyx@disroot.org
While file is an optional dependency, without it
file type determination and opening does not work out of the box.
---
gnu/packages/disk.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 47b15e588f79..58bd3db3812c 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
;;; Copyright © 2014, 2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Nguy?n Gia Phong <mcsinyx@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -800,7 +801,7 @@ (define-public ranger
"0lfjrpv3z4h0knd3v94fijrw2zjba51mrp3mjqx2c98wr428l26f"))))
(build-system python-build-system)
(inputs
- (list w3m))
+ (list file w3m))
(native-inputs
(list which
;; For tests.
@@ -815,11 +816,13 @@ (define-public ranger
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(ranger (string-append out "/bin/ranger"))
+ (file (assoc-ref inputs "file"))
(w3m (assoc-ref inputs "w3m"))
(w3mimgdisplay (string-append w3m
"/libexec/w3m/w3mimgdisplay")))
(wrap-program ranger
- `("W3MIMGDISPLAY_PATH" ":" prefix (,w3mimgdisplay)))
+ `("W3MIMGDISPLAY_PATH" ":" prefix (,w3mimgdisplay))
+ `("PATH" ":" prefix ,(list (string-append file "/bin"))))
#t)))
(replace 'check
;; The default check phase simply prints 'Ran 0 tests in 0.000s'.
--
2.37.0
L
L
Liliana Marie Prikler wrote on 21 Jul 2022 08:50
223585fd44f0b8e94d85aacd6885d01432b5e3e0.camel@ist.tugraz.at
Am Mittwoch, dem 20.07.2022 um 17:01 +0900 schrieb Nguy?n Gia Phong:
Toggle quote (2 lines)
> While file is an optional dependency, without it
> file type determination and opening does not work out of the box.
Rather than patching PATH, you should use substitute* to hardcode the
reference. Also, do write a ChangeLog style commit message.

Cheers
L
L
Liliana Marie Prikler wrote on 26 Jul 2022 09:48
3b9ad15ef70095a116c2657017808d0783a9c44e.camel@ist.tugraz.at
Am Dienstag, dem 26.07.2022 um 16:43 +0900 schrieb Nguy?n Gia Phong:
Toggle quote (7 lines)
> On Thu Jul 21, 2022 at 8:50 AM +0200, Liliana Marie Prikler wrote:
> > Rather than patching PATH, you should use substitute*
> > to hardcode the reference.
>
> Coming from Nix, I don't get why is it preferred.
> Shouldn't users be able to override runtime dependencies at runtime,
> e.g. via a custom wrapper script?
In Guix we prefer not to rely on the environment because that breaks
the case of pure shells. We have transformations, which are more
powerful than wrapper scripts.
N
N
Nguy?n Gia Phong wrote on 26 Jul 2022 09:43
CLPF3SUOY06B.2ONLNWJ9RSI7V@nix
On Thu Jul 21, 2022 at 8:50 AM +0200, Liliana Marie Prikler wrote:
Toggle quote (3 lines)
> Rather than patching PATH, you should use substitute*
> to hardcode the reference.

Coming from Nix, I don't get why is it preferred.
Shouldn't users be able to override runtime dependencies at runtime,
e.g. via a custom wrapper script?

If that is the case, I suppose the correct wrapper would be

(wrap-program ...
'("PATH" suffix ,(list (string-append file "/bin"))))

Toggle quote (2 lines)
> Also, do write a ChangeLog style commit message.

Thanks, I probably missed this reading the contrib guide.
L
L
Ludovic Courtès wrote on 4 Aug 2022 23:58
control message for bug #56657
(address . control@debbugs.gnu.org)
87r11vk6w0.fsf@gnu.org
tags 56657 + moreinfo
quit
?