(address . bug-guix@gnu.org)
Hello Guix!
On the 'core-updates' branch, running 'guix build -d' fails on some
cross-derivations (notably anything that depends on NSPR, but there may
be others).
Somehow both TARGET and SYSTEM ends up #false. Any ideas to what is
going on?
Toggle snippet (40 lines)
$ ./pre-inst-env guix build --target=aarch64-linux-gnu nspr -d
Backtrace:
In guix/monads.scm:
471:9 19 (_ _)
In guix/packages.scm:
1553:7 18 (_ _)
In guix/store.scm:
1996:13 17 (_ #<store-connection 256.99 7f5816372e60>)
In guix/packages.scm:
1878:37 16 (_)
1798:39 15 (bag->derivation #<<bag> name: "ld-wrapper-aarch64-linux-gnu-0" system: #f target: #f build-inputs: () host-inputs: (("binutils" #<package binutils-cross-aarch64-linux-gnu@2.38 gnu/packages/cross-base.scm:69 7f58054e12c0>) ("guile" #<package guile@3.0.8 guix/build-system/gnu.scm:145 7f5804e65420>) ("bash" #<package bash@5.1.16 gnu/packages/bash.scm:131 7f5804bae210>) ("wrapper" "…> …)
1291:4 14 (bag-transitive-inputs _)
1074:23 13 (transitive-inputs _)
1415:36 12 (propagated-inputs _)
In srfi/srfi-1.scm:
586:29 11 (map1 (("libunistring" #<package libunistring@1.0 gnu/packages/bootstrap.scm:297 7f58054e1000>) ("bdw-gc" #<package libgc@8.0.6 gnu/packages/bootstrap.scm:297 7f58054e5f20>)))
586:17 10 (map1 (("bdw-gc" #<package libgc@8.0.6 gnu/packages/bootstrap.scm:297 7f58054e5f20>)))
In guix/packages.scm:
1370:20 9 (rewrite ("bdw-gc" #<package libgc@8.0.6 gnu/packages/bootstrap.scm:297 7f58054e5f20>))
In guix/memoization.scm:
101:0 8 (_ #<hash-table 7f5804e64be0 2/31> #<package libgc@8.0.6 gnu/packages/bootstrap.scm:297 7f58054e5f20> _)
In guix/packages.scm:
1384:13 7 (_)
In guix/build-system/gnu.scm:
157:33 6 (cut? _)
In gnu/packages/bdw-gc.scm:
61:15 5 (arguments #<package libgc@8.0.6 gnu/packages/bootstrap.scm:297 7f58054e5f20>)
In guix/utils.scm:
672:7 4 (target-hurd? _)
In unknown file:
3 (string-suffix? "-gnu" #f #<undefined> #<undefined> #<undefined> #<undefined>)
In ice-9/boot-9.scm:
1685:16 2 (raise-exception _ #:continuable? _)
1685:16 1 (raise-exception _ #:continuable? _)
1685:16 0 (raise-exception _ #:continuable? _)
ice-9/boot-9.scm:1685:16: In procedure raise-exception:
In procedure string-suffix?: Wrong type argument in position 2 (expecting string): #f