(address . guix-patches@gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
* guix/scripts/install.scm (show-help, %options): Add "--manifest".
* tests/guix-package-aliases.sh" Test "guix install -m".
---
guix/scripts/install.scm | 8 ++++++--
tests/guix-package-aliases.sh | 16 +++++++++++++---
2 files changed, 19 insertions(+), 5 deletions(-)
Hi!
I think it’s convenient and quite natural to be able to type:
guix install -m manifest.scm
Hence this patch. Objections? :-)
Thanks,
Ludo’.
Toggle diff (73 lines)
diff --git a/guix/scripts/install.scm b/guix/scripts/install.scm
index 63e625f266..0d24d7c956 100644
--- a/guix/scripts/install.scm
+++ b/guix/scripts/install.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019, 2020, 2022 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,6 +33,9 @@ (define (show-help)
This is an alias for 'guix package -i'.\n"))
(display (G_ "
-p, --profile=PROFILE use PROFILE instead of the user's default profile"))
+ (display (G_ "
+ -m, --manifest=FILE create a new profile generation with the manifest
+ from FILE"))
;; '--bootstrap' not shown here.
(display (G_ "
-v, --verbosity=LEVEL use the given verbosity LEVEL"))
@@ -61,7 +64,8 @@ (define %options
;; Preserve some of the 'guix package' options.
(append (filter (lambda (option)
(any (cut member <> (option-names option))
- '("profile" "dry-run" "verbosity" "bootstrap")))
+ '("profile" "dry-run" "verbosity" "bootstrap"
+ "manifest")))
%package-options)
%transformation-options
diff --git a/tests/guix-package-aliases.sh b/tests/guix-package-aliases.sh
index 311838b768..99cb9176cd 100644
--- a/tests/guix-package-aliases.sh
+++ b/tests/guix-package-aliases.sh
@@ -1,5 +1,5 @@
# GNU Guix --- Functional package management for GNU
-# Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+# Copyright © 2019, 2020, 2022 Ludovic Courtès <ludo@gnu.org>
#
# This file is part of GNU Guix.
#
@@ -28,9 +28,10 @@ readlink_base ()
}
profile="t-profile-$$"
-rm -f "$profile"
+manifest="t-manifest-$$"
+rm -f "$profile" "$manifest"
-trap 'rm -f "$profile" "$profile-"[0-9]*' EXIT
+trap 'rm -f "$profile" "$profile-"[0-9]* "$manifest"' EXIT
guix install --bootstrap guile-bootstrap -p "$profile"
test -x "$profile/bin/guile"
@@ -55,6 +56,15 @@ guix remove --bootstrap guile-bootstrap -p "$profile"
! test -x "$profile/bin/guile"
test `guix package -p "$profile" -I | wc -l` -eq 0
+# Installing from a manifest.
+cat > "$manifest" <<EOF
+(specifications->manifest '("guile-bootstrap"))
+EOF
+guix install -p "$profile" -m "$manifest" --bootstrap
+test -x "$profile/bin/guile"
+guix remove --bootstrap guile-bootstrap -p "$profile"
+! test -x "$profile/bin/guile"
+
! guix remove -p "$profile" this-is-not-installed --bootstrap
! guix remove -i guile-bootstrap -p "$profile" --bootstrap
--
2.36.1