[PATCH] gnu: Add texlive-mdframed.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Fabio Natali
Owner
unassigned
Submitted by
Fabio Natali
Severity
normal

Debbugs page

Fabio Natali wrote 3 years ago
(address . guix-patches@gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
df3cb4cb72bba8e9f08b27a5e5603ab3003ec0fb.1657962688.git.me@fabionatali.com
---
gnu/packages/tex.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 47e015da71..2af21907c6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11034,3 +11034,19 @@ (define-public texlive-babel-finnish
Finnish in @code{babel}. It provides all the necessary macros, definitions and
settings to typeset Finnish documents.")
(license license:lppl1.3c+))))
+
+(define-public texlive-mdframed
+ (package
+ (inherit
+ (simple-texlive-package
+ "texlive-mdframed"
+ (list "doc/latex/mdframed/" "source/latex/mdframed/" "tex/latex/mdframed/")
+ (base32 "1i5rm946wg43rjckxlfhx79zfx5cgd3bxk71206hd1dqkrgpdpa8")
+ #:trivial? #t))
+ (home-page "https://ctan.org/macros/latex/contrib/mdframed")
+ (synopsis "Framed environments that can split at page boundaries")
+ (description
+ "The package develops the facilities of framed in providing breakable framed and
+coloured boxes. The user may instruct the package to perform its operations
+using default LaTeX commands, PStricks or TikZ.")
+ (license license:lppl)))
--
2.36.1
Fabio Natali wrote 3 years ago
[PATCH] gnu: Add texlive-setspace.
(address . 56601@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
4064a772cded3b141c26af7c339f2a819eefea0f.1657968314.git.me@fabionatali.com
---
gnu/packages/tex.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2af21907c6..cb40f3b549 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11050,3 +11050,20 @@ (define-public texlive-mdframed
coloured boxes. The user may instruct the package to perform its operations
using default LaTeX commands, PStricks or TikZ.")
(license license:lppl)))
+
+(define-public texlive-setspace
+ (package
+ (inherit
+ (simple-texlive-package
+ "texlive-setspace"
+ (list "doc/latex/setspace/" "tex/latex/setspace/")
+ (base32 "00ik8qgkw3ivh3z827zjf7gbwkbsmdcmv22c6ap543mpgaqqjcfm")
+ #:trivial? #t))
+ (home-page "https://ctan.org/macros/latex/contrib/setspace")
+ (synopsis "Set space between lines")
+ (description
+ "This package provides support for setting the spacing between lines in a
+document. Package options include singlespacing, onehalfspacing, and
+doublespacing. Alternatively the spacing can be changed as required with the
+\\singlespacing, \\onehalfspacing, and \\doublespacing commands. Other size
+spacings also available.")))

base-commit: 4ce7f1fb24a111f3e92d5b889d1271bebf109d09
prerequisite-patch-id: 15fbd940ff2c4d720e5400d6413ffbfdf01ead36
--
2.36.1
Fabio Natali wrote 3 years ago
[PATCH] gnu: Add texlive-pgfgantt.
(address . 56601@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
2d22922c8edaccb5bbc8f414c6502d0f190d524e.1657981653.git.me@fabionatali.com
---
gnu/packages/tex.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cb40f3b549..2c6c961879 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11067,3 +11067,20 @@ (define-public texlive-setspace
doublespacing. Alternatively the spacing can be changed as required with the
\\singlespacing, \\onehalfspacing, and \\doublespacing commands. Other size
spacings also available.")))
+
+(define-public texlive-pgfgantt
+ (package
+ (inherit
+ (simple-texlive-package
+ "texlive-pgfgantt"
+ (list "doc/latex/pgfgantt/" "source/latex/pgfgantt/" "tex/latex/pgfgantt/")
+ (base32 "0bm034iizk4sd7p5x7vkj7v57dc0bf2lswpsb32s4qlg4s7h6jqz")
+ #:trivial? #t))
+ (propagated-inputs (list texlive-pgf))
+ (home-page "https://ctan.org/graphics/pgf/contrib/pgfgantt")
+ (synopsis "Draw Gantt charts with TikZ")
+ (description
+ "The package provides an environment for drawing Gantt charts that contain
+various elements (titles, bars, milestones, groups and links). Several keys
+customize the appearance of the chart elements.")
+ (license license:lppl1.3+)))

base-commit: 4ce7f1fb24a111f3e92d5b889d1271bebf109d09
prerequisite-patch-id: 15fbd940ff2c4d720e5400d6413ffbfdf01ead36
prerequisite-patch-id: 4b09fce4186da53607ac1503a21a16c410eb0287
--
2.36.1
Fabio Natali wrote 3 years ago
[PATCH] gnu: Add texlive-pdflscape.
(address . 56601@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
a5c14dabaae3e0602f03ff87418551126a199587.1657982144.git.me@fabionatali.com
---
gnu/packages/tex.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2c6c961879..6aa79c4d2c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11084,3 +11084,21 @@ (define-public texlive-pgfgantt
various elements (titles, bars, milestones, groups and links). Several keys
customize the appearance of the chart elements.")
(license license:lppl1.3+)))
+
+(define-public texlive-pdflscape
+ (package
+ (inherit
+ (simple-texlive-package
+ "texlive-pdflscape"
+ (list "doc/latex/pdflscape/"
+ "source/latex/pdflscape/"
+ "tex/latex/pdflscape/")
+ (base32 "05vvmwd8vlzs2x2rm6pfzlvrrihqf924d7krlrkvc6giiwyfsic4")
+ #:trivial? #t))
+ (home-page "https://ctan.org/macros/latex/contrib/pdflscape")
+ (synopsis "Make landscape pages display as landscape")
+ (description
+ "The package adds PDF support to the landscape environment of package lscape, by
+setting the PDF /Rotate page attribute. Pages with this attribute will be
+displayed in landscape orientation by conforming PDF viewers.")
+ (license license:lppl1.3+)))

base-commit: 4ce7f1fb24a111f3e92d5b889d1271bebf109d09
prerequisite-patch-id: 15fbd940ff2c4d720e5400d6413ffbfdf01ead36
prerequisite-patch-id: 4b09fce4186da53607ac1503a21a16c410eb0287
prerequisite-patch-id: 59d5d41ee572d700fb228981ac6c0acbf01953a1
--
2.36.1
Fabio Natali wrote 3 years ago
[PATCH] gnu: Add texlive-datetime2.
(address . 56601@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
02b20009a4ac69d0eaa4c2d17fe0b473a1d48fdf.1657982490.git.me@fabionatali.com
---
gnu/packages/tex.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6aa79c4d2c..c2824dbecd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11102,3 +11102,26 @@ (define-public texlive-pdflscape
setting the PDF /Rotate page attribute. Pages with this attribute will be
displayed in landscape orientation by conforming PDF viewers.")
(license license:lppl1.3+)))
+
+(define-public texlive-datetime2
+ (package
+ (inherit
+ (simple-texlive-package
+ "texlive-datetime2"
+ (list "doc/latex/datetime2/"
+ "source/latex/datetime2/"
+ "tex/latex/datetime2/")
+ (base32 "0yjkpfic1ni4j2g61rrjj5hjyd43shc9c0sg1aivbbsmqh30dn33")
+ #:trivial? #t))
+ (home-page "https://ctan.org/macros/latex/contrib/datetime2")
+ (synopsis "Formats for dates, times and time zones")
+ (description
+ "This package provides commands for formatting dates, times and time zones and
+redefines \\today to use the same formatting style. In addition to \\today, you
+can also use \\DTMcurrenttime (current time) or \\DTMnow (current date and time).
+Dates and times can be saved for later use. The accompanying datetime2-calc
+package can be used to convert date-times to UTC+00:00. Language and regional
+support is provided by independently maintained and installed modules. The
+datetime2-calc package uses the pgfcalendar package (part of the PGF/TikZ
+bundle). This package replaces datetime.sty which is now obsolete.")
+ (license license:lppl1.3+)))

base-commit: 4ce7f1fb24a111f3e92d5b889d1271bebf109d09
prerequisite-patch-id: 15fbd940ff2c4d720e5400d6413ffbfdf01ead36
prerequisite-patch-id: 4b09fce4186da53607ac1503a21a16c410eb0287
prerequisite-patch-id: 59d5d41ee572d700fb228981ac6c0acbf01953a1
prerequisite-patch-id: 1b253ce7adb8a1d30efc86a877c8a69e6c0ff3ac
--
2.36.1
Fabio Natali wrote 3 years ago
[PATCH] gnu: Add texlive-tracklang.
(address . 56601@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
35031d908d50b747bd5774d2ec44cef30548b610.1657982626.git.me@fabionatali.com
---
gnu/packages/tex.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c2824dbecd..8372ae6f51 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11125,3 +11125,24 @@ (define-public texlive-datetime2
datetime2-calc package uses the pgfcalendar package (part of the PGF/TikZ
bundle). This package replaces datetime.sty which is now obsolete.")
(license license:lppl1.3+)))
+
+(define-public texlive-tracklang
+ (package
+ (inherit
+ (simple-texlive-package
+ "texlive-tracklang"
+ (list "doc/generic/tracklang/"
+ "source/latex/tracklang/"
+ "tex/generic/tracklang/"
+ "tex/latex/tracklang/")
+ (base32 "1386sg25y6zb4ixvrbdv6n1gp54h18mjd984bnwwqda6jafxx4zr")
+ #:trivial? #t))
+ (home-page "https://ctan.org/macros/generic/tracklang")
+ (synopsis "Language and dialect tracker")
+ (description
+ "The tracklang package is provided for package developers who want a simple
+interface to find out which languages the user has requested through packages
+such as babel or polyglossia. This package does not provide any translations!
+Its purpose is simply to track which languages have been requested by the user.
+Generic TeX code is in tracklang.tex for non-LaTeX users.")
+ (license license:lppl1.3+)))

base-commit: 4ce7f1fb24a111f3e92d5b889d1271bebf109d09
prerequisite-patch-id: 15fbd940ff2c4d720e5400d6413ffbfdf01ead36
prerequisite-patch-id: 4b09fce4186da53607ac1503a21a16c410eb0287
prerequisite-patch-id: 59d5d41ee572d700fb228981ac6c0acbf01953a1
prerequisite-patch-id: 1b253ce7adb8a1d30efc86a877c8a69e6c0ff3ac
prerequisite-patch-id: 8b6ac3e9c66f5da5b825aad5b73fe59d305b583d
--
2.36.1
Fabio Natali wrote 3 years ago
[PATCH] gnu: Add texlive-ltablex.
(address . 56601@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
c649251ecfc318b4d0c03464be77160ae1ca5101.1657982690.git.me@fabionatali.com
---
gnu/packages/tex.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8372ae6f51..47823d48d1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11146,3 +11146,19 @@ (define-public texlive-tracklang
Its purpose is simply to track which languages have been requested by the user.
Generic TeX code is in tracklang.tex for non-LaTeX users.")
(license license:lppl1.3+)))
+
+(define-public texlive-ltablex
+ (package
+ (inherit
+ (simple-texlive-package
+ "texlive-ltablex"
+ (list "doc/latex/ltablex/" "tex/latex/ltablex/")
+ (base32 "14lmgj820j6zwj1xnd6ad38kzb9w132kp7sp55cv5bk9vhx3621w")
+ #:trivial? #t))
+ (home-page "https://ctan.org/macros/latex/contrib/ltablex")
+ (synopsis "Table package extensions")
+ (description
+ "Modifies the tabularx environment to combine the features of the tabularx
+package (auto-sized columns in a fixed width table) with those of the longtable
+package (multi-page tables).")
+ (license license:lppl)))

base-commit: 4ce7f1fb24a111f3e92d5b889d1271bebf109d09
prerequisite-patch-id: 15fbd940ff2c4d720e5400d6413ffbfdf01ead36
prerequisite-patch-id: 4b09fce4186da53607ac1503a21a16c410eb0287
prerequisite-patch-id: 59d5d41ee572d700fb228981ac6c0acbf01953a1
prerequisite-patch-id: 1b253ce7adb8a1d30efc86a877c8a69e6c0ff3ac
prerequisite-patch-id: 8b6ac3e9c66f5da5b825aad5b73fe59d305b583d
prerequisite-patch-id: a2fb5bfdb148bbf62a2d356a76b6d42dc15eefc2
--
2.36.1
Fabio Natali wrote 3 years ago
[PATCH] gnu: Add texlive-ragged2e.
(address . 56601@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
cfa1ff9decdf39e5544eb28e6d967f831462d955.1657982764.git.me@fabionatali.com
---
gnu/packages/tex.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 47823d48d1..ba5cd48c74 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11162,3 +11162,22 @@ (define-public texlive-ltablex
package (auto-sized columns in a fixed width table) with those of the longtable
package (multi-page tables).")
(license license:lppl)))
+
+(define-public texlive-ragged2e
+ (package
+ (inherit
+ (simple-texlive-package
+ "texlive-ragged2e"
+ (list "doc/latex/ragged2e/"
+ "source/latex/ragged2e/"
+ "tex/latex/ragged2e/")
+ (base32 "1cxj5jdgvr3xk1inrb3yzpm3l386jjawgpqiwsz53k6yshb6yfml")
+ #:trivial? #t))
+ (home-page "https://ctan.org/macros/latex/contrib/ragged2e")
+ (synopsis "Alternative versions of \"ragged\"-type commands")
+ (description
+ "The package defines new commands \\Centering, \\RaggedLeft, and \\RaggedRight and
+new environments Center, FlushLeft, and FlushRight, which set ragged text and
+are easily configurable to allow hyphenation (the corresponding commands in
+LaTeX, all of whose names are lower-case, prevent hyphenation altogether).")
+ (license license:lppl1.3c)))

base-commit: 4ce7f1fb24a111f3e92d5b889d1271bebf109d09
prerequisite-patch-id: 15fbd940ff2c4d720e5400d6413ffbfdf01ead36
prerequisite-patch-id: 4b09fce4186da53607ac1503a21a16c410eb0287
prerequisite-patch-id: 59d5d41ee572d700fb228981ac6c0acbf01953a1
prerequisite-patch-id: 1b253ce7adb8a1d30efc86a877c8a69e6c0ff3ac
prerequisite-patch-id: 8b6ac3e9c66f5da5b825aad5b73fe59d305b583d
prerequisite-patch-id: a2fb5bfdb148bbf62a2d356a76b6d42dc15eefc2
prerequisite-patch-id: ce78edf5bdc1b2bfc6d609ad616f8508390e93d0
--
2.36.1
Fabio Natali wrote 3 years ago
[PATCH] gnu: Add texlive-everysel.
(address . 56601@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
ef359a46be7db04bfceaa962794161152cf6a260.1657982859.git.me@fabionatali.com
---
gnu/packages/tex.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ba5cd48c74..23a72bef2a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11181,3 +11181,24 @@ (define-public texlive-ragged2e
are easily configurable to allow hyphenation (the corresponding commands in
LaTeX, all of whose names are lower-case, prevent hyphenation altogether).")
(license license:lppl1.3c)))
+
+(define-public texlive-everysel
+ (package
+ (inherit
+ (simple-texlive-package
+ "texlive-everysel"
+ (list "doc/latex/everysel/"
+ "source/latex/everysel/"
+ "tex/latex/everysel/")
+ (base32 "0skzm2qsk5vpjxgslclp4pvbbcrrnm1w3df8xfvfq252dyd7w8s5")
+ #:trivial? #t))
+ (home-page "https://ctan.org/macros/latex/contrib/everysel")
+ (synopsis "Provides hooks into \\selectfont")
+ (description
+ "The package provided hooks whose arguments are executed just after LaTeX has
+loaded a new font by means of \\selectfont. It has become obsolete with LaTeX
+versions 2021/01/05 or newer, since LaTeX now provides its own hooks to fulfill
+this task. For newer versions of LaTeX everysel only provides macros using
+LaTeX's hook management due to compatibility reasons. See lthooks-doc.pdf for
+instructions how to use lthooks instead of everysel.")
+ (license license:lppl1.3c)))

base-commit: 4ce7f1fb24a111f3e92d5b889d1271bebf109d09
prerequisite-patch-id: 15fbd940ff2c4d720e5400d6413ffbfdf01ead36
prerequisite-patch-id: 4b09fce4186da53607ac1503a21a16c410eb0287
prerequisite-patch-id: 59d5d41ee572d700fb228981ac6c0acbf01953a1
prerequisite-patch-id: 1b253ce7adb8a1d30efc86a877c8a69e6c0ff3ac
prerequisite-patch-id: 8b6ac3e9c66f5da5b825aad5b73fe59d305b583d
prerequisite-patch-id: a2fb5bfdb148bbf62a2d356a76b6d42dc15eefc2
prerequisite-patch-id: ce78edf5bdc1b2bfc6d609ad616f8508390e93d0
prerequisite-patch-id: a9ad8e5b6dad492a1027761e187a511da1b4303c
--
2.36.1
Fabio Natali wrote 3 years ago
[PATCH] gnu: Fixed home-page URLs and improved descriptions in various TeX packages.
(address . 56601@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
5874455c7e68d095d47464a14a717a17543a77fc.1659016912.git.me@fabionatali.com
---
gnu/packages/tex.scm | 111 ++++++++++++++++++++++++-------------------
1 file changed, 63 insertions(+), 48 deletions(-)

Toggle diff (211 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c833fe2c6c..dc898aacbe 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11088,15 +11088,19 @@ (define-public texlive-mdframed
(inherit
(simple-texlive-package
"texlive-mdframed"
- (list "doc/latex/mdframed/" "source/latex/mdframed/" "tex/latex/mdframed/")
+ (list
+ "doc/latex/mdframed/"
+ "source/latex/mdframed/"
+ "tex/latex/mdframed/")
(base32 "1i5rm946wg43rjckxlfhx79zfx5cgd3bxk71206hd1dqkrgpdpa8")
#:trivial? #t))
- (home-page "https://ctan.org/macros/latex/contrib/mdframed")
+ (home-page "https://ctan.org/pkg/mdframed")
(synopsis "Framed environments that can split at page boundaries")
(description
- "The package develops the facilities of framed in providing breakable framed and
-coloured boxes. The user may instruct the package to perform its operations
-using default LaTeX commands, PStricks or TikZ.")
+ "The @code{mdframed} package develops the facilities of @code{framed} in
+providing breakable framed and coloured boxes. The user may instruct the
+package to perform its operations using default LaTeX commands, PStricks or
+TikZ.")
(license license:lppl)))
(define-public texlive-setspace
@@ -11107,13 +11111,14 @@ (define-public texlive-setspace
(list "doc/latex/setspace/" "tex/latex/setspace/")
(base32 "00ik8qgkw3ivh3z827zjf7gbwkbsmdcmv22c6ap543mpgaqqjcfm")
#:trivial? #t))
- (home-page "https://ctan.org/macros/latex/contrib/setspace")
+ (home-page "https://ctan.org/pkg/setspace")
(synopsis "Set space between lines")
(description
- "This package provides support for setting the spacing between lines in a
-document. Package options include singlespacing, onehalfspacing, and
-doublespacing. Alternatively the spacing can be changed as required with the
-\\singlespacing, \\onehalfspacing, and \\doublespacing commands. Other size
+ "The @code{setspace} package provides support for setting the spacing between
+lines in a document. Package options include @code{singlespacing},
+@code{onehalfspacing}, and @code{doublespacing}. Alternatively the spacing
+can be changed as required with the @code{\\singlespacing},
+@code{\\onehalfspacing}, and @code{\\doublespacing} commands. Other size
spacings also available.")))
(define-public texlive-pgfgantt
@@ -11121,16 +11126,19 @@ (define-public texlive-pgfgantt
(inherit
(simple-texlive-package
"texlive-pgfgantt"
- (list "doc/latex/pgfgantt/" "source/latex/pgfgantt/" "tex/latex/pgfgantt/")
+ (list
+ "doc/latex/pgfgantt/"
+ "source/latex/pgfgantt/"
+ "tex/latex/pgfgantt/")
(base32 "0bm034iizk4sd7p5x7vkj7v57dc0bf2lswpsb32s4qlg4s7h6jqz")
#:trivial? #t))
(propagated-inputs (list texlive-pgf))
(home-page "https://ctan.org/graphics/pgf/contrib/pgfgantt")
(synopsis "Draw Gantt charts with TikZ")
(description
- "The package provides an environment for drawing Gantt charts that contain
-various elements (titles, bars, milestones, groups and links). Several keys
-customize the appearance of the chart elements.")
+ "The @code{pgfgantt} package provides an environment for drawing Gantt charts
+that contain various elements (titles, bars, milestones, groups and links).
+Several keys customize the appearance of the chart elements.")
(license license:lppl1.3+)))
(define-public texlive-pdflscape
@@ -11143,12 +11151,13 @@ (define-public texlive-pdflscape
"tex/latex/pdflscape/")
(base32 "05vvmwd8vlzs2x2rm6pfzlvrrihqf924d7krlrkvc6giiwyfsic4")
#:trivial? #t))
- (home-page "https://ctan.org/macros/latex/contrib/pdflscape")
+ (home-page "https://ctan.org/pkg/pdflscape")
(synopsis "Make landscape pages display as landscape")
(description
- "The package adds PDF support to the landscape environment of package lscape, by
-setting the PDF /Rotate page attribute. Pages with this attribute will be
-displayed in landscape orientation by conforming PDF viewers.")
+ "The @code{pdflscape} package adds PDF support to the @code{landscape}
+environment of package @code{lscape}, by setting the PDF @code{/Rotate} page
+attribute. Pages with this attribute will be displayed in landscape
+orientation by conforming PDF viewers.")
(license license:lppl1.3+)))
(define-public texlive-datetime2
@@ -11161,17 +11170,19 @@ (define-public texlive-datetime2
"tex/latex/datetime2/")
(base32 "0yjkpfic1ni4j2g61rrjj5hjyd43shc9c0sg1aivbbsmqh30dn33")
#:trivial? #t))
- (home-page "https://ctan.org/macros/latex/contrib/datetime2")
+ (home-page "https://ctan.org/pkg/datetime2")
(synopsis "Formats for dates, times and time zones")
(description
- "This package provides commands for formatting dates, times and time zones and
-redefines \\today to use the same formatting style. In addition to \\today, you
-can also use \\DTMcurrenttime (current time) or \\DTMnow (current date and time).
-Dates and times can be saved for later use. The accompanying datetime2-calc
-package can be used to convert date-times to UTC+00:00. Language and regional
-support is provided by independently maintained and installed modules. The
-datetime2-calc package uses the pgfcalendar package (part of the PGF/TikZ
-bundle). This package replaces datetime.sty which is now obsolete.")
+ "The @code{datetime2} package provides commands for formatting dates, times
+and time zones and redefines @code{\\today} to use the same formatting style.
+In addition to @code{\\today}, you can also use
+@code{\\DTMcurrenttime} (current time) or @code{\\DTMnow} (current date and
+time). Dates and times can be saved for later use. The accompanying
+@code{datetime2-calc} package can be used to convert date-times to UTC+00:00.
+Language and regional support is provided by independently maintained and
+installed modules. The @code{datetime2-calc} package uses the
+@code{pgfcalendar} package (part of the PGF/TikZ bundle). This package
+replaces @code{datetime.sty} which is now obsolete.")
(license license:lppl1.3+)))
(define-public texlive-tracklang
@@ -11188,11 +11199,12 @@ (define-public texlive-tracklang
(home-page "https://ctan.org/macros/generic/tracklang")
(synopsis "Language and dialect tracker")
(description
- "The tracklang package is provided for package developers who want a simple
-interface to find out which languages the user has requested through packages
-such as babel or polyglossia. This package does not provide any translations!
-Its purpose is simply to track which languages have been requested by the user.
-Generic TeX code is in tracklang.tex for non-LaTeX users.")
+ "The @code{tracklang} package is provided for package developers who want a
+simple interface to find out which languages the user has requested through
+packages such as @code{babel} or @code{polyglossia}. This package does not
+provide any translations! Its purpose is simply to track which languages have
+been requested by the user. Generic TeX code is in @code{tracklang.tex} for
+non-LaTeX users.")
(license license:lppl1.3+)))
(define-public texlive-ltablex
@@ -11203,12 +11215,13 @@ (define-public texlive-ltablex
(list "doc/latex/ltablex/" "tex/latex/ltablex/")
(base32 "14lmgj820j6zwj1xnd6ad38kzb9w132kp7sp55cv5bk9vhx3621w")
#:trivial? #t))
- (home-page "https://ctan.org/macros/latex/contrib/ltablex")
+ (home-page "https://ctan.org/pkg/ltablex")
(synopsis "Table package extensions")
(description
- "Modifies the tabularx environment to combine the features of the tabularx
-package (auto-sized columns in a fixed width table) with those of the longtable
-package (multi-page tables).")
+ "The @code{ltablex} package modifies the @code{tabularx} environment to
+combine the features of the @code{tabularx} package (auto-sized columns in a
+fixed-width table) with those of the @code{longtable} package (multi-page
+tables).")
(license license:lppl)))
(define-public texlive-ragged2e
@@ -11221,13 +11234,14 @@ (define-public texlive-ragged2e
"tex/latex/ragged2e/")
(base32 "1cxj5jdgvr3xk1inrb3yzpm3l386jjawgpqiwsz53k6yshb6yfml")
#:trivial? #t))
- (home-page "https://ctan.org/macros/latex/contrib/ragged2e")
+ (home-page "https://ctan.org/pkg/ragged2e")
(synopsis "Alternative versions of \"ragged\"-type commands")
(description
- "The package defines new commands \\Centering, \\RaggedLeft, and \\RaggedRight and
-new environments Center, FlushLeft, and FlushRight, which set ragged text and
-are easily configurable to allow hyphenation (the corresponding commands in
-LaTeX, all of whose names are lower-case, prevent hyphenation altogether).")
+ "The @code{ragged2e} package defines new commands @code{\\Centering}, @code{\\RaggedLeft},
+and @code{\\RaggedRight} and new environments @code{Center}, @code{FlushLeft},
+and @code{FlushRight}, which set ragged text and are easily configurable to
+allow hyphenation (the corresponding commands in LaTeX, all of whose names are
+lower-case, prevent hyphenation altogether).")
(license license:lppl1.3c)))
(define-public texlive-everysel
@@ -11240,13 +11254,14 @@ (define-public texlive-everysel
"tex/latex/everysel/")
(base32 "0skzm2qsk5vpjxgslclp4pvbbcrrnm1w3df8xfvfq252dyd7w8s5")
#:trivial? #t))
- (home-page "https://ctan.org/macros/latex/contrib/everysel")
+ (home-page "https://ctan.org/pkg/everysel")
(synopsis "Provides hooks into \\selectfont")
(description
- "The package provided hooks whose arguments are executed just after LaTeX has
-loaded a new font by means of \\selectfont. It has become obsolete with LaTeX
-versions 2021/01/05 or newer, since LaTeX now provides its own hooks to fulfill
-this task. For newer versions of LaTeX everysel only provides macros using
-LaTeX's hook management due to compatibility reasons. See lthooks-doc.pdf for
-instructions how to use lthooks instead of everysel.")
+ "The @code{everysel} package provided hooks whose arguments are executed just
+after LaTeX has loaded a new font by means of @code{\\selectfont}. It has
+become obsolete with LaTeX versions 2021/01/05 or newer, since LaTeX now
+provides its own hooks to fulfill this task. For newer versions of LaTeX
+@code{everysel} only provides macros using LaTeX's hook management due to
+compatibility reasons. See @code{lthooks-doc.pdf} for instructions how to use
+@code{lthooks} instead of @code{everysel}.")
(license license:lppl1.3c)))

base-commit: bdb2e262fcbea76de807cd829c2d2270661546a5
prerequisite-patch-id: 210183e53536829e6c6190c7ad485f4a95009965
prerequisite-patch-id: 4b09fce4186da53607ac1503a21a16c410eb0287
prerequisite-patch-id: 59d5d41ee572d700fb228981ac6c0acbf01953a1
prerequisite-patch-id: 1b253ce7adb8a1d30efc86a877c8a69e6c0ff3ac
prerequisite-patch-id: 8b6ac3e9c66f5da5b825aad5b73fe59d305b583d
prerequisite-patch-id: a2fb5bfdb148bbf62a2d356a76b6d42dc15eefc2
prerequisite-patch-id: ce78edf5bdc1b2bfc6d609ad616f8508390e93d0
prerequisite-patch-id: a9ad8e5b6dad492a1027761e187a511da1b4303c
prerequisite-patch-id: 390faeb22c95df692b527ba5770ed4249d90a316
--
2.36.1
Fabio Natali wrote 3 years ago
[PATCH] gnu: Improved TeX Live everysel package synopsis.
(address . 56601@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
6759a142f40ce2cd37bccd1315433c2876e49250.1659018946.git.me@fabionatali.com
---
gnu/packages/tex.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dc898aacbe..14f9c4acf1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11255,7 +11255,7 @@ (define-public texlive-everysel
(base32 "0skzm2qsk5vpjxgslclp4pvbbcrrnm1w3df8xfvfq252dyd7w8s5")
#:trivial? #t))
(home-page "https://ctan.org/pkg/everysel")
- (synopsis "Provides hooks into \\selectfont")
+ (synopsis "Provides hooks into @code{\\selectfont}")
(description
"The @code{everysel} package provided hooks whose arguments are executed just
after LaTeX has loaded a new font by means of @code{\\selectfont}. It has

base-commit: bdb2e262fcbea76de807cd829c2d2270661546a5
prerequisite-patch-id: 210183e53536829e6c6190c7ad485f4a95009965
prerequisite-patch-id: 4b09fce4186da53607ac1503a21a16c410eb0287
prerequisite-patch-id: 59d5d41ee572d700fb228981ac6c0acbf01953a1
prerequisite-patch-id: 1b253ce7adb8a1d30efc86a877c8a69e6c0ff3ac
prerequisite-patch-id: 8b6ac3e9c66f5da5b825aad5b73fe59d305b583d
prerequisite-patch-id: a2fb5bfdb148bbf62a2d356a76b6d42dc15eefc2
prerequisite-patch-id: ce78edf5bdc1b2bfc6d609ad616f8508390e93d0
prerequisite-patch-id: a9ad8e5b6dad492a1027761e187a511da1b4303c
prerequisite-patch-id: 390faeb22c95df692b527ba5770ed4249d90a316
prerequisite-patch-id: f13f36c79a8eba6d441d353dfa39987a0484ba87
--
2.36.1
Fabio Natali wrote 3 years ago
[PATCH] gnu: Add texlive-everyshi.
(address . 56601@debbugs.gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
9362a56cc224c4f1b26ef9fc7d9dcb8ca0dbe488.1659019870.git.me@fabionatali.com
---
gnu/packages/tex.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 14f9c4acf1..7183e0ac1c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11265,3 +11265,26 @@ (define-public texlive-everysel
compatibility reasons. See @code{lthooks-doc.pdf} for instructions how to use
@code{lthooks} instead of @code{everysel}.")
(license license:lppl1.3c)))
+
+(define-public texlive-everyshi
+ (package
+ (inherit
+ (simple-texlive-package
+ "texlive-everyshi"
+ (list "doc/latex/everyshi/"
+ "source/latex/everyshi/"
+ "tex/latex/everyshi/")
+ (base32 "11y6xazv1nk0m2hzsainjr8ijn5cff04xfccm6a65hzg7ipggraj")
+ #:trivial? #t))
+ (home-page "https://ctan.org/pkg/everyshi")
+ (synopsis "Take action at every @code{\\shipout}")
+ (description
+ "The @code{everyshi} package provides hooks into @code{\\sshipout} called
+@code{\\EveryShipout} and @code{\\AtNextShipout} analogous to
+@code{\\AtBeginDocument}. With the introduction of the LaTeX hook management
+this package became obsolete in 2020 and is only provided for backwards
+compatibility. For current versions of LaTeX it is only mapping the hooks to
+the original @code{everyshi} macros. In case you use an older LaTeX format,
+@code{everyshi} will automatically fall back to its old implementation by
+loading @code{everyshi-2001-05-15}.")
+ (license license:lppl1.3c)))

base-commit: bdb2e262fcbea76de807cd829c2d2270661546a5
prerequisite-patch-id: 210183e53536829e6c6190c7ad485f4a95009965
prerequisite-patch-id: 4b09fce4186da53607ac1503a21a16c410eb0287
prerequisite-patch-id: 59d5d41ee572d700fb228981ac6c0acbf01953a1
prerequisite-patch-id: 1b253ce7adb8a1d30efc86a877c8a69e6c0ff3ac
prerequisite-patch-id: 8b6ac3e9c66f5da5b825aad5b73fe59d305b583d
prerequisite-patch-id: a2fb5bfdb148bbf62a2d356a76b6d42dc15eefc2
prerequisite-patch-id: ce78edf5bdc1b2bfc6d609ad616f8508390e93d0
prerequisite-patch-id: a9ad8e5b6dad492a1027761e187a511da1b4303c
prerequisite-patch-id: 390faeb22c95df692b527ba5770ed4249d90a316
prerequisite-patch-id: f13f36c79a8eba6d441d353dfa39987a0484ba87
prerequisite-patch-id: 2905aa4832a1a9b3d951685d641f4e13eb6f24a4
--
2.36.1
Ludovic Courtès wrote 3 years ago
Re: bug#56601: [PATCH] gnu: Add texlive-mdframed.
(name . Fabio Natali)(address . me@fabionatali.com)(address . 56601-done@debbugs.gnu.org)
87tu6tsa1v.fsf_-_@gnu.org
Hi Fabio,

I reassembled the patches, added a commit log that follows our
conventions¹, and the whole series is now committed.

In the future, please send a new version when amending patches so that
reviewers get a clear view of what is being submitted.

Thanks,
Ludo’.

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56601@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56601
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help