[PATCH] gnu: Add android-file-transfer.

  • Done
  • quality assurance status badge
Details
2 participants
  • kiasoc5
  • Ludovic Courtès
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 3 years ago
(address . guix-patches@gnu.org)
20220715174140.4048a2af@aria
From 338e019331aa46f37b5e45c66aa1c09a4e27f008 Mon Sep 17 00:00:00 2001
From: kiasoc5 <kiasoc5@disroot.org>
Date: Fri, 15 Jul 2022 13:37:29 -0400
Subject: [PATCH] gnu: Add android-file-transfer.

* gnu/packages/android.scm (android-file-transfer): New variable.
---
gnu/packages/android.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 04dc4b6499..5897d71fa9 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -34,6 +34,7 @@ (define-module (gnu packages android)
#:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix build-system android-ndk)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
@@ -54,6 +55,8 @@ (define-module (gnu packages android)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages readline)
#:use-module (gnu packages selinux)
#:use-module (gnu packages serialization)
#:use-module (gnu packages sphinx)
@@ -1268,3 +1271,30 @@ (define-public enjarify
applications. Enjarify can translate the Dalvik bytecode back to equivalent
Java bytecode, which simplifies the analysis of Android applications.")
(license license:asl2.0)))
+
+(define-public android-file-transfer
+ (package
+ (name "android-file-transfer")
+ (version "4.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/whoozle/android-file-transfer-linux/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "125rq8ji83nw6chfw43i0h9c38hjqh1qjibb0gnf9wrigar9zc8b"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f)) ;there are no tests
+ (inputs (list qtbase-5 fuse libxkbcommon))
+ (native-inputs (list qttools openssl readline))
+ (home-page "https://whoozle.github.io/android-file-transfer-linux")
+ (synopsis "MTP client for Android devices")
+ (description
+ "This package provides a QT graphical interface for transfering
+files with Android devices using MTP. It also allows the Android device to be
+mounted via FUSE.")
+ (license license:lgpl2.1+)))

base-commit: 114b40ed675d0543058b5bdea86e561eff7c6b6e
--
2.37.1
kiasoc5 wrote 3 years ago
[PATCH V2] gnu: Add android-file-transfer.
(address . 56578@debbugs.gnu.org)
20220720153822.61d425c8@aria
Update to use fuse-3 instead of fuse.

From 45372cd82e79e116d8f80abbfec0e7e1f53200e1 Mon Sep 17 00:00:00 2001
From: kiasoc5 <kiasoc5@disroot.org>
Date: Fri, 15 Jul 2022 13:37:29 -0400
Subject: [PATCH V2] gnu: Add android-file-transfer.

* gnu/packages/android.scm (android-file-transfer): New variable.
---
gnu/packages/android.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 04dc4b6499..dafd9b52f3 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -34,6 +34,7 @@ (define-module (gnu packages android)
#:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix build-system android-ndk)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
@@ -54,6 +55,8 @@ (define-module (gnu packages android)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages readline)
#:use-module (gnu packages selinux)
#:use-module (gnu packages serialization)
#:use-module (gnu packages sphinx)
@@ -1268,3 +1271,30 @@ (define-public enjarify
applications. Enjarify can translate the Dalvik bytecode back to equivalent
Java bytecode, which simplifies the analysis of Android applications.")
(license license:asl2.0)))
+
+(define-public android-file-transfer
+ (package
+ (name "android-file-transfer")
+ (version "4.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/whoozle/android-file-transfer-linux/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "125rq8ji83nw6chfw43i0h9c38hjqh1qjibb0gnf9wrigar9zc8b"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f)) ;there are no tests
+ (inputs (list qtbase-5 fuse-3 libxkbcommon))
+ (native-inputs (list qttools openssl readline))
+ (home-page "https://whoozle.github.io/android-file-transfer-linux")
+ (synopsis "MTP client for Android devices")
+ (description
+ "This package provides a QT graphical interface for transfering
+files with Android devices using MTP. It also allows the Android device to be
+mounted via FUSE.")
+ (license license:lgpl2.1+)))

base-commit: be7b314f3fe22273e935accac22f313e44d3d970
--
2.37.1
Ludovic Courtès wrote 3 years ago
Re: bug#56578: [PATCH] gnu: Add android-file-transfer.
(name . kiasoc5)(address . kiasoc5@disroot.org)(address . 56578-done@debbugs.gnu.org)
87zggltz2n.fsf_-_@gnu.org
Hi,

kiasoc5 <kiasoc5@disroot.org> skribis:

Toggle quote (7 lines)
> From 45372cd82e79e116d8f80abbfec0e7e1f53200e1 Mon Sep 17 00:00:00 2001
> From: kiasoc5 <kiasoc5@disroot.org>
> Date: Fri, 15 Jul 2022 13:37:29 -0400
> Subject: [PATCH V2] gnu: Add android-file-transfer.
>
> * gnu/packages/android.scm (android-file-transfer): New variable.

Applied with the changes below, thanks!

Ludo’.
Toggle diff (20 lines)
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index dafd9b52f3..91aaba089f 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -1290,11 +1290,11 @@ (define-public android-file-transfer
(arguments
(list #:tests? #f)) ;there are no tests
(inputs (list qtbase-5 fuse-3 libxkbcommon))
- (native-inputs (list qttools openssl readline))
- (home-page "https://whoozle.github.io/android-file-transfer-linux")
+ (native-inputs (list qttools-5 openssl readline))
+ (home-page "https://whoozle.github.io/android-file-transfer-linux/")
(synopsis "MTP client for Android devices")
(description
- "This package provides a QT graphical interface for transfering
-files with Android devices using MTP. It also allows the Android device to be
+ "This package provides a Qt graphical interface for transferring files
+with Android devices using MTP. It also allows the Android device to be
mounted via FUSE.")
(license license:lgpl2.1+)))
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56578@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56578
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help