failed install on partition, backtrace attached

  • Open
  • quality assurance status badge
Details
3 participants
  • Josselin Poiret
  • Ludovic Courtès
  • Peter
Owner
unassigned
Submitted by
Peter
Severity
normal
P
(address . bug-guix@gnu.org)
CAHaGoVNUCRzFsJagMpxJzV4t_S0S=mkDmTBhv7J8OU9jXvGRZg@mail.gmail.com
Hi,

I did manual partitioning because I didn't want to wipe the other
partitions out.

Set / and /home partitions, formatted as EXT4.

Crashes as soon as it writes the changes, displays the backtrace and
restarts the installer.

Best,
Peter
Attachment: file
L
L
Ludovic Courtès wrote on 15 Jul 2022 12:58
(name . Peter)(address . sunspark@gmail.com)(address . 56572@debbugs.gnu.org)
87edym8wx9.fsf@gnu.org
Hi Peter,

Peter <sunspark@gmail.com> skribis:

Toggle quote (8 lines)
> I did manual partitioning because I didn't want to wipe the other
> partitions out.
>
> Set / and /home partitions, formatted as EXT4.
>
> Crashes as soon as it writes the changes, displays the backtrace and
> restarts the installer.

Ouch. Could you confirm it was with the 1.3.0 installer?

It would seem that the bug comes from ‘read-partition-uuid’ returning #f
in this function:

Toggle snippet (23 lines)
(define (user-partition->file-system user-partition)
"Convert the given USER-PARTITION record in a FILE-SYSTEM record from
(gnu system file-systems) module and return it."
(let* ((mount-point (user-partition-mount-point user-partition))
(fs-type (user-partition-fs-type user-partition))
(crypt-label (user-partition-crypt-label user-partition))
(mount-type (user-fs-type->mount-type fs-type))
(file-name (user-partition-file-name user-partition))
(upper-file-name (user-partition-upper-file-name user-partition))
;; Only compute uuid if partition is not encrypted.
(uuid (or crypt-label
(uuid->string (read-partition-uuid file-name) fs-type))))
`(file-system
(mount-point ,mount-point)
(device ,@(if crypt-label
`(,upper-file-name)
`((uuid ,uuid (quote ,fs-type)))))
(type ,mount-type)
,@(if crypt-label
'((dependencies mapped-devices))
'()))))

This can happen if a partition you chose to create actually contains
random data or a file system not supported by (gnu build file-systems);
this, in turn, can happen if you chose not to format partitions during
the installation process.

Could it be what happened in your case?

Ludo’.
S
S
sunspark wrote on 15 Jul 2022 16:15
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 56572@debbugs.gnu.org)
62d17727.1c69fb81.d2d46.80a4@mx.google.com
Hi, I confirm it was with the 1.3.0 installer. I have since downloaded the snapshot installer but I haven't tested it yet. However I would need to be careful testing because this time around I have created raw unformatted partitions in Windows disk manager because it annoys me how different Linux disk utilities round numbers differently. The guix installer views 64 GB as 68.7 GB and entering 68.7 there to create a matching 64 creates 63.98 GB instead. I suppose I would need to run it twice again with the 1.3 first. Once to see if just formatting a windows created raw partition fixes it and once with a filesystem that isn't ext4 then the snapshot. My partition table is standard. 100 meg efi, 128 meg Microsoft reserved partiton, two NTFS partitions, the two ext4s I was attempting to create in unallocated space and a linux swap partition already created. Incidentally, the reboot command in F1 doesn't work either. Just black screens. Need to hold the power button down.Best,PeterSent from my Galaxy
-------- Original message --------From: Ludovic Courtès <ludo@gnu.org> Date: 2022-07-15 06:58 (GMT-05:00) To: Peter <sunspark@gmail.com> Cc: 56572@debbugs.gnu.org Subject: Re: bug#56572: failed install on partition, backtrace attached Hi Peter,Peter <sunspark@gmail.com> skribis:> I did manual partitioning because I didn't want to wipe the other> partitions out.>> Set / and /home partitions, formatted as EXT4.>> Crashes as soon as it writes the changes, displays the backtrace and> restarts the installer.Ouch.  Could you confirm it was with the 1.3.0 installer?It would seem that the bug comes from ‘read-partition-uuid’ returning #fin this function:--8<---------------cut here---------------start------------->8---(define (user-partition->file-system user-partition)  "Convert the given USER-PARTITION record in a FILE-SYSTEM record from(gnu system file-systems) module and return it."  (let* ((mount-point (user-partition-mount-point user-partition))         (fs-type (user-partition-fs-type user-partition))         (crypt-label (user-partition-crypt-label user-partition))         (mount-type (user-fs-type->mount-type fs-type))         (file-name (user-partition-file-name user-partition))         (upper-file-name (user-partition-upper-file-name user-partition))         ;; Only compute uuid if partition is not encrypted.         (uuid (or crypt-label                   (uuid->string (read-partition-uuid file-name) fs-type))))    `(file-system       (mount-point ,mount-point)       (device ,@(if crypt-label                     `(,upper-file-name)                     `((uuid ,uuid (quote ,fs-type)))))       (type ,mount-type)       ,@(if crypt-label             '((dependencies mapped-devices))             '()))))--8<---------------cut here---------------end--------------->8---This can happen if a partition you chose to create actually containsrandom data or a file system not supported by (gnu build file-systems);this, in turn, can happen if you chose not to format partitions duringthe installation process.Could it be what happened in your case?Ludo’.
Attachment: file
P
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 56572@debbugs.gnu.org)
CAHaGoVOQ2jSF7XfTkrChVDOUDXUJbK_Cp2j0yezF1D-i=2CWog@mail.gmail.com
Follow-up: 1.3.0 installer couldn't be used again, will submit another bug
for the reason why separately.

Using the snapshot 520v5sznglla0z1g3mz6pfsml88b8gxx-image.iso did not have
the error 1.3.0 did trying to format/write to the partition and the install
was able to complete.

So it seems as if there is an issue with the partitioning software in the
1.3.0 image.


On Fri, Jul 15, 2022 at 10:18 AM sunspark <sunspark@gmail.com> wrote:

Toggle quote (90 lines)
> Hi,
>
> I confirm it was with the 1.3.0 installer.
>
> I have since downloaded the snapshot installer but I haven't tested it
> yet. However I would need to be careful testing because this time around I
> have created raw unformatted partitions in Windows disk manager because it
> annoys me how different Linux disk utilities round numbers differently. The
> guix installer views 64 GB as 68.7 GB and entering 68.7 there to create a
> matching 64 creates 63.98 GB instead.
>
> I suppose I would need to run it twice again with the 1.3 first. Once to
> see if just formatting a windows created raw partition fixes it and once
> with a filesystem that isn't ext4 then the snapshot.
>
> My partition table is standard. 100 meg efi, 128 meg Microsoft reserved
> partiton, two NTFS partitions, the two ext4s I was attempting to create in
> unallocated space and a linux swap partition already created.
>
> Incidentally, the reboot command in F1 doesn't work either. Just black
> screens. Need to hold the power button down.
>
> Best,
> Peter
>
>
>
>
>
> Sent from my Galaxy
>
>
> -------- Original message --------
> From: Ludovic Courtès <ludo@gnu.org>
> Date: 2022-07-15 06:58 (GMT-05:00)
> To: Peter <sunspark@gmail.com>
> Cc: 56572@debbugs.gnu.org
> Subject: Re: bug#56572: failed install on partition, backtrace attached
>
> Hi Peter,
>
> Peter <sunspark@gmail.com> skribis:
>
> > I did manual partitioning because I didn't want to wipe the other
> > partitions out.
> >
> > Set / and /home partitions, formatted as EXT4.
> >
> > Crashes as soon as it writes the changes, displays the backtrace and
> > restarts the installer.
>
> Ouch. Could you confirm it was with the 1.3.0 installer?
>
> It would seem that the bug comes from ‘read-partition-uuid’ returning #f
> in this function:
>
> --8<---------------cut here---------------start------------->8---
> (define (user-partition->file-system user-partition)
> "Convert the given USER-PARTITION record in a FILE-SYSTEM record from
> (gnu system file-systems) module and return it."
> (let* ((mount-point (user-partition-mount-point user-partition))
> (fs-type (user-partition-fs-type user-partition))
> (crypt-label (user-partition-crypt-label user-partition))
> (mount-type (user-fs-type->mount-type fs-type))
> (file-name (user-partition-file-name user-partition))
> (upper-file-name (user-partition-upper-file-name user-partition))
> ;; Only compute uuid if partition is not encrypted.
> (uuid (or crypt-label
> (uuid->string (read-partition-uuid file-name)
> fs-type))))
> `(file-system
> (mount-point ,mount-point)
> (device ,@(if crypt-label
> `(,upper-file-name)
> `((uuid ,uuid (quote ,fs-type)))))
> (type ,mount-type)
> ,@(if crypt-label
> '((dependencies mapped-devices))
> '()))))
> --8<---------------cut here---------------end--------------->8---
>
> This can happen if a partition you chose to create actually contains
> random data or a file system not supported by (gnu build file-systems);
> this, in turn, can happen if you chose not to format partitions during
> the installation process.
>
> Could it be what happened in your case?
>
> Ludo’.
>
Attachment: file
L
L
Ludovic Courtès wrote on 18 Jul 2022 11:10
(name . Peter)(address . sunspark@gmail.com)
87wnca3hx2.fsf@gnu.org
Hi,

Peter <sunspark@gmail.com> skribis:

Toggle quote (10 lines)
> Follow-up: 1.3.0 installer couldn't be used again, will submit another bug
> for the reason why separately.
>
> Using the snapshot 520v5sznglla0z1g3mz6pfsml88b8gxx-image.iso did not have
> the error 1.3.0 did trying to format/write to the partition and the install
> was able to complete.
>
> So it seems as if there is an issue with the partitioning software in the
> 1.3.0 image.

That suggests that this formatting bug was fixed in the meantime, which
is plausible because a lot of work has gone in the installer since
1.3.0.

Josselin, Mathieu, does that ring a bell?

Thanks,
Ludo’.
J
J
Josselin Poiret wrote on 21 Jul 2022 18:18
87y1wmxww4.fsf@jpoiret.xyz
Hello everyone,

Ludovic Courtès <ludo@gnu.org> writes:
Toggle quote (6 lines)
> That suggests that this formatting bug was fixed in the meantime, which
> is plausible because a lot of work has gone in the installer since
> 1.3.0.
>
> Josselin, Mathieu, does that ring a bell?

None for me, but it could come from improvements in (gnu build
file-systems) and friends too, not just the installer. I can't pinpoint
a specific commit that would do that, but there are some general reworks
that might have helped with this.

Best,
--
Josselin Poiret
?