generate-documentation can't handle package fields

  • Open
  • quality assurance status badge
Details
One participant
  • Andrew Tropin
Owner
unassigned
Submitted by
Andrew Tropin
Severity
normal

Debbugs page

Andrew Tropin wrote 3 years ago
(address . bug-guix@gnu.org)(name . Xinglu Chen)(address . public@yoctocell.xyz)(name . conses)(address . contact@conses.eu)
874jzirh5t.fsf@trop.in
Minimal reproducer:

Toggle snippet (14 lines)
(use-modules (gnu services configuration)
(gnu packages mail))

(define-configuration/no-serialization home-goimapnotify-configuration
(package
(package go-gitlab.com-shackra-goimapnotify)
"The @code{goimapnotify} package to use."))

(generate-documentation
`((home-goimapnotify-configuration
,home-goimapnotify-configuration-fields))
'home-goimapnotify-configuration)

Error:

Toggle snippet (12 lines)
(generate-documentation
`((home-goimapnotify-configuration
,home-goimapnotify-configuration-fields))
'home-goimapnotify-configuration)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
In procedure symbol->string: Wrong type argument in position 1 (expecting symbol): #f


[Debugging level: 18]

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmLREV4ACgkQIgjSCVjB
3rCh+A/9Gt/NdjH2zLDzcbXLGYfabCkmCX4joRyk6jLeqGK/ZKUP08hLTncO/FQS
8/P2cpC67pTcCYWfY6ZEkggKRuxQpXb7O0iA7/qD7HrHrsxnUqljyWTI5tWHkhMC
dVP9uYO7TYIP+NctuaZeR5kVHIPzayH9k+Q0hdSNWHmwurRqmOhaltJZ4G4ahjDC
6XTP2nTu9x3/xgqZCkbqvEVJK9PrzW5oZPMsy22Q8c7K0zkzJl6VZ4RVfs+OlOLN
SUbpZ7eieWSA91XQwMmSrA4/AU0+YIBqoutlMztC0t2E2w9FNzDCah+sJZ3iyPDL
dSodF5CfLPKzajq1CsktB6St8NSoQCrs6tAzunLw2U6XPqx7atwYwUQGBhl8Qh3m
3Zmq5ef+8kMhPSxsRvaXQ14E1kX0wvNkYcvSmJD1zHVpVCnPzTaE7GpM/eN8pvhM
zsZeXHuv0VGzj8cMBeXhAIo9HFLxS3dg8PNqA2c8bP4x+kMxBMoiKaJl4+jFbhAJ
GnOgMUqqkz5gsG3e+0tklaFICoFRJOl6EfZGEaFKZmYg0TUv5avH7vXHHXcz68IN
lXGRB3Lh48gWi/CkBuvWQU2C4VivjocTzI4Cz5/UXmY2KP5OPQPFY4xcdsIC4FEH
O8iL0OwGMWL21NesKAQkoGPgts5n0T1PJXGNcMKurdNLHnWzpqQ=
=MVK9
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 56570@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56570
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help