guix time-machine/shell throws "unsupported manifest format" error

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 14 Jul 2022 02:53
(name . bug-guix)(address . bug-guix@gnu.org)
87pmi8y0nx.fsf@gmail.com
Hi Guix,

I recently tried re-entering an older environment via:

$ guix describe
Generation 128 Jul 06 2022 14:50:39 (current)
guix 17892c5
branch: master
commit: 17892c5f9c5c5c93325884834a58cc2a4fafa51f
sfl-packages 6385881
branch: master
commit: 6385881124429016f750b0f562b70e07f592275e
$ guix time-machine -C channels.scm -- shell

with in the current directory the project manifest file:

Toggle snippet (60 lines)
(packages->manifest
(map specification->package
(list
;; General utilities.
"bash"
"coreutils"
"cpio"
"cqfd"
"findutils"
"gawk"
"git"
"grep"
"gzip"
"info-reader" ;to generate the info dir entry
"less" ;for a better git experience
"make"
"man-db" ;to generate the manpages database
"pandoc"
"pict"
"sed"
"openssh" ;for the SSH client used by git
"tar"
"tree"
"wget"

;; Python and libraries.
"python-matplotlib"
"python-paramiko"
"python-robotframework"
"python-robotframework-datadriver"
"python-robotframework-sshlibrary"
"python-robotframework-stacktrace"
"python-scp"
"python-selenium"
"python-tenacity"
"python-wrapper"

;; Drivers
"python-labjack"

;; Development tools.
"python-flake8"
"python-flake8-isort"
"python-ipython"
"python-ipython-documentation"
;; To use ipdb with Python's breakpoint():
;; 'export PYTHONBREAKPOINT=ipdb.sset_trace'
;; then set 'breakpoint()' in Python sources or
;; 'Evaluate breakpoint()' in RobotFramework sources.
"python-ipdb"
"python-isort"
"python-pdbpp" ;for the 'sticky' mode
"python-pylint"
"python-robotframework-lint"

;; Browsers.
"icecat"
"ungoogled-chromium")))

and the channels.scm file:

Toggle snippet (6 lines)
(list (channel
(inherit %default-guix-channel)
(commit
"ceeb2bfcaeb4380e01d26c8425e28b94ac13558a"))) ;2022-06-07

and was surprised to be greeted with the following error:


Toggle snippet (5 lines)
(repl-version 0 1 1)
(exception %exception (non-self-quoting 140737300283024 "#<&message message: \"unsupported manifest format\">"))
/var/log/guix/drvs/j8/0wjfx7s7nxhcn0wjxfysnnv2knx0c1-guix-package-cache.drv (END)

What does it mean? Which manifest is it referring to?

Thanks,

Maxim
L
L
Ludovic Courtès wrote on 17 Jul 2022 21:31
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 56545@debbugs.gnu.org)
87h73f4jue.fsf@gnu.org
Hi!

Maxim Cournoyer <maxim.cournoyer@gmail.com> scribes:

Toggle quote (16 lines)
> and the channels.scm file:
>
> (list (channel
> (inherit %default-guix-channel)
> (commit
> "ceeb2bfcaeb4380e01d26c8425e28b94ac13558a"))) ;2022-06-07
>
>
> and was surprised to be greeted with the following error:
>
> (repl-version 0 1 1)
> (exception %exception (non-self-quoting 140737300283024 "#<&message message: \"unsupported manifest format\">"))
> /var/log/guix/drvs/j8/0wjfx7s7nxhcn0wjxfysnnv2knx0c1-guix-package-cache.drv (END)
>
> What does it mean? Which manifest is it referring to?

Commit 4ff12d1de7cd617b791996ee7ca1240660b4c20e introduced that bug,
which was fixed in c9fbd40785a99e13a59d8e530830ce85220a9871:


‘guix describe’ should show that you’re using a commit in that range.

The solution is to run ‘time-machine’ from a commit outside that range,
for instance with:

guix time-machine -- time-machine -C channels.scm -- whatever

:-)

Ludo’.
M
M
Maxim Cournoyer wrote on 18 Jul 2022 13:04
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 56545-done@debbugs.gnu.org)
87k08asmva.fsf@gmail.com
Hi Ludovic,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (34 lines)
> Hi!
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> scribes:
>
>> and the channels.scm file:
>>
>> (list (channel
>> (inherit %default-guix-channel)
>> (commit
>> "ceeb2bfcaeb4380e01d26c8425e28b94ac13558a"))) ;2022-06-07
>>
>>
>> and was surprised to be greeted with the following error:
>>
>> (repl-version 0 1 1)
>> (exception %exception (non-self-quoting 140737300283024 "#<&message message: \"unsupported manifest format\">"))
>> /var/log/guix/drvs/j8/0wjfx7s7nxhcn0wjxfysnnv2knx0c1-guix-package-cache.drv (END)
>>
>> What does it mean? Which manifest is it referring to?
>
> Commit 4ff12d1de7cd617b791996ee7ca1240660b4c20e introduced that bug,
> which was fixed in c9fbd40785a99e13a59d8e530830ce85220a9871:
>
> https://issues.guix.gnu.org/56441
>
> ‘guix describe’ should show that you’re using a commit in that range.
>
> The solution is to run ‘time-machine’ from a commit outside that range,
> for instance with:
>
> guix time-machine -- time-machine -C channels.scm -- whatever
>
> :-)

That's a happy resolution. Thank you!

Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56545@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56545
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch