(name . bug-guix)(address . bug-guix@gnu.org)
Hi Guix,
I recently tried re-entering an older environment via:
$ guix describe
Generation 128 Jul 06 2022 14:50:39 (current)
guix 17892c5
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: 17892c5f9c5c5c93325884834a58cc2a4fafa51f
sfl-packages 6385881
repository URL: https://gitlab.com/Apteryks/sfl-guix-channel
branch: master
commit: 6385881124429016f750b0f562b70e07f592275e
$ guix time-machine -C channels.scm -- shell
with in the current directory the project manifest file:
Toggle snippet (60 lines)
(packages->manifest
(map specification->package
(list
;; General utilities.
"bash"
"coreutils"
"cpio"
"cqfd"
"findutils"
"gawk"
"git"
"grep"
"gzip"
"info-reader" ;to generate the info dir entry
"less" ;for a better git experience
"make"
"man-db" ;to generate the manpages database
"pandoc"
"pict"
"sed"
"openssh" ;for the SSH client used by git
"tar"
"tree"
"wget"
;; Python and libraries.
"python-matplotlib"
"python-paramiko"
"python-robotframework"
"python-robotframework-datadriver"
"python-robotframework-sshlibrary"
"python-robotframework-stacktrace"
"python-scp"
"python-selenium"
"python-tenacity"
"python-wrapper"
;; Drivers
"python-labjack"
;; Development tools.
"python-flake8"
"python-flake8-isort"
"python-ipython"
"python-ipython-documentation"
;; To use ipdb with Python's breakpoint():
;; 'export PYTHONBREAKPOINT=ipdb.sset_trace'
;; then set 'breakpoint()' in Python sources or
;; 'Evaluate breakpoint()' in RobotFramework sources.
"python-ipdb"
"python-isort"
"python-pdbpp" ;for the 'sticky' mode
"python-pylint"
"python-robotframework-lint"
;; Browsers.
"icecat"
"ungoogled-chromium")))
and the channels.scm file:
Toggle snippet (6 lines)
(list (channel
(inherit %default-guix-channel)
(commit
"ceeb2bfcaeb4380e01d26c8425e28b94ac13558a"))) ;2022-06-07
and was surprised to be greeted with the following error:
Toggle snippet (5 lines)
(repl-version 0 1 1)
(exception %exception (non-self-quoting 140737300283024 "#<&message message: \"unsupported manifest format\">"))
/var/log/guix/drvs/j8/0wjfx7s7nxhcn0wjxfysnnv2knx0c1-guix-package-cache.drv (END)
What does it mean? Which manifest is it referring to?
Thanks,
Maxim