sushi: build failure, bad URI

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Howard
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Christopher Howard
Severity
normal

Debbugs page

Christopher Howard wrote 3 years ago
(name . Bug Guix)(address . bug-guix@gnu.org)
Ys663qtMx/EOtzHZ@nightshade
Hello, I am trying to do a system reconfigure to update my system, but eventually gnome dependency "sushi" tries to build and fails. I believe the problem is that Guix is trying to download https://download.gnome.org/sources/sushi/42.0/sushi-42.0.tar.xzbut the path is actually https://download.gnome.org/sources/sushi/42/sushi-42.0.tar.xz.

Here is information on my system:

```
christopher@nightshade ~$ guix describe
Generation 13 Jul 12 2022 19:55:42 (current)
guix c8f3240
branch: master
commit: c8f32406e8778c803eddeefe0f510733a9018e67

christopher@nightshade
----------------------
OS: Guix System 0 x86_64
Host: GA-880GM-UD2H
Kernel: 5.15.5-gnu
Uptime: 3 days, 19 hours, 6 mins
Packages: 63 (guix-system), 141 (guix-user)
Shell: bash 5.0.16
Resolution: 1920x1200
DE: GNOME 3.34.5
Theme: Adwaita [GTK2/3]
Icons: Adwaita [GTK2/3]
Terminal: .gnome-terminal
CPU: AMD Athlon II X3 455 (3) @ 3.300GHz
GPU: NVIDIA Quadro 2000
Memory: 1289MiB / 7957MiB
```

Here is the build failure:

```
Starting download of /gnu/store/1pdl4ibgskpqbqca7kxhf8xqw9150dq3-sushi-42.0.tar.xz

Starting download of /gnu/store/1pdl4ibgskpqbqca7kxhf8xqw9150dq3-sushi-42.0.tar.xz

Starting download of /gnu/store/1pdl4ibgskpqbqca7kxhf8xqw9150dq3-sushi-42.0.tar.xz

Starting download of /gnu/store/1pdl4ibgskpqbqca7kxhf8xqw9150dq3-sushi-42.0.tar.xz

Starting download of /gnu/store/1pdl4ibgskpqbqca7kxhf8xqw9150dq3-sushi-42.0.tar.xz

Starting download of /gnu/store/1pdl4ibgskpqbqca7kxhf8xqw9150dq3-sushi-42.0.tar.xz

Starting download of /gnu/store/1pdl4ibgskpqbqca7kxhf8xqw9150dq3-sushi-42.0.tar.xz
Trying to use Disarchive to assemble /gnu/store/1pdl4ibgskpqbqca7kxhf8xqw9150dq3-sushi-42.0.tar.xz...
could not find its Disarchive specification
failed to download "/gnu/store/1pdl4ibgskpqbqca7kxhf8xqw9150dq3-sushi-42.0.tar.xz" from "mirror://gnome/sources/sushi/42.0/sushi-42.0.tar.xz"
```

--
馃摏 Christopher Howard
馃殌 gemini://gem.librehacker.com

讘专讗砖讬转 讘专讗 讗诇讛讬诐 讗转 讛砖诪讬诐 讜讗转 讛讗专抓
Maxim Cournoyer wrote 3 years ago
(name . Christopher Howard)(address . christopher@librehacker.com)(address . 56537-done@debbugs.gnu.org)
87a69d2nb0.fsf@gmail.com
Hi Christopher,

Christopher Howard <christopher@librehacker.com> writes:

Toggle quote (2 lines)
> Hello, I am trying to do a system reconfigure to update my system, but eventually gnome dependency "sushi" tries to build and fails. I believe the problem is that Guix is trying to download https://download.gnome.org/sources/sushi/42.0/sushi-42.0.tar.xzbut the path is actually https://download.gnome.org/sources/sushi/42/sushi-42.0.tar.xz.

Indeed. Fixed with this:

Toggle snippet (12 lines)
modified gnu/packages/gnome.scm
@@ -1588,7 +1588,7 @@ (define-public sushi
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
+ (version-major version) "/"
name "-" version ".tar.xz"))
(sha256
(base32

Pushed to master as 6d5b3df7afefa6b038c8430ae3e1650af986ad1e.

Sorry for the breakage, and thank you for reporting it!

Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56537@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56537
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help