[PATCH 0/2] Fix protobuf-2.

  • Done
  • quality assurance status badge
Details
One participant
  • Greg Hogan
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 8 Jul 2022 22:47
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
cover.1657312543.git.code@greghogan.com
This patchset fixes the broken protobuf-2 and updates the dependent
pokerth in order to fix that build.

Greg Hogan (2):
gnu: protobuf-2: Fix broken build.
gnu: pokerth: Update to 1.1.2-8e6088e4.

gnu/packages/games.scm | 129 ++++++++++++++++++--------------------
gnu/packages/protobuf.scm | 6 +-
2 files changed, 65 insertions(+), 70 deletions(-)

--
2.36.1
G
G
Greg Hogan wrote on 8 Jul 2022 22:49
[PATCH 1/2] gnu: protobuf-2: Fix broken build.
(address . 56456@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
479518687c1c164ba3f159223985154acdedaa88.1657313089.git.code@greghogan.com
* gnu/packages/protobuf.scm (protobuf-2): Fix broken build.
[arguments]<#:phases>: Delete 'disable-broken-tests.
---
gnu/packages/protobuf.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index f66e3469b8..59f2f361e3 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -180,7 +180,11 @@ (define-public protobuf-2
version ".tar.bz2"))
(sha256
(base32
- "040rcs9fpv4bslhiy43v7dcrzakz4vwwpyqg4jp8bn24sl95ci7f"))))))
+ "040rcs9fpv4bslhiy43v7dcrzakz4vwwpyqg4jp8bn24sl95ci7f"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'disable-broken-tests))))))
(define-public protobuf-c
(package
--
2.36.1
G
G
Greg Hogan wrote on 8 Jul 2022 22:49
[PATCH 2/2] gnu: pokerth: Update to 1.1.2-8e6088e4.
(address . 56456@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
22b980b0564079b825af5a9dad5af81e68e20fe7.1657313089.git.code@greghogan.com
* gnu/packages/games.scm (pokerth): Update to 1.1.2-8e6088e4.
[source]: Switch to git-fetch.
[arguments]<#:phases>: Remove substitution for libircclient in
'fix-paths and delete 'fix-build.
---
gnu/packages/games.scm | 129 +++++++++++++++++++----------------------
1 file changed, 60 insertions(+), 69 deletions(-)

Toggle diff (143 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c6ed6eed00..6f72465c5c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12231,76 +12231,67 @@ (define-public neverball
(license license:gpl2+))))
(define-public pokerth
- (package
- (name "pokerth")
- (version "1.1.2")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/pokerth/pokerth/"
- version "/pokerth-" version ".tar.gz"))
- (sha256
- (base32 "0yi9bj3k8yc1gkwmaf14zbbvvn13n54n1dli8k6j1pkph3p3vjq2"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Remove bundled websocketpp.
- (delete-file-recursively "src/third_party/websocketpp")
- (substitute* "pokerth_lib.pro"
- (("src/third_party/websocketpp")
- ""))
- #t))))
- (build-system qt-build-system)
- (inputs
- `(("boost" ,boost)
- ("curl" ,curl)
- ("gsasl" ,gsasl)
- ("libgcrypt" ,libgcrypt)
- ("libircclient" ,libircclient)
- ("protobuf" ,protobuf-2) ; remove package when no longer needed
- ("qtbase" ,qtbase-5)
- ("sdl" ,(sdl-union (list sdl sdl-mixer)))
- ("sqlite" ,sqlite)
- ("tinyxml" ,tinyxml)
- ("websocketpp" ,websocketpp)
- ("zlib" ,zlib)))
- (arguments
- `(#:tests? #f ; No test suite
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* (find-files "." "\\.pro$")
- (("/opt/gsasl")
- (assoc-ref inputs "gsasl"))
- (("\\$\\$\\{PREFIX\\}/include/libircclient")
- (search-input-directory inputs "/include/libircclient"))
- (("LIB_DIRS =")
- (string-append "LIB_DIRS = "
- (assoc-ref inputs "boost") "/lib")))
- #t))
- (add-after 'unpack 'fix-build
- (lambda _
- ;; Fixes for Boost versions >= 1.66.
- (substitute* '("src/net/common/clientthread.cpp"
- "src/net/serveraccepthelper.h")
- (("boost::asio::socket_base::non_blocking_io command\\(true\\);")
- "")
- (("newSock->io_control\\(command\\);")
- "newSock->non_blocking(true);")
- (("acceptedSocket->io_control\\(command\\);")
- "acceptedSocket->non_blocking(true);"))
- #t))
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "qmake" "pokerth.pro" "CONFIG+=client"
- (string-append "PREFIX=" (assoc-ref outputs "out"))))))))
- (home-page "https://www.pokerth.net")
- (synopsis "Texas holdem poker game")
- (description
- "With PokerTH you can play the Texas holdem poker game, either against
+ (let ((commit "8e6088e425ace3bb31c1dfc3231bff74891e3e94")
+ (revision "0"))
+ (package
+ (name "pokerth")
+ (version "1.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/pokerth/pokerth")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1i7z0zc3sbws1bpgn1rd9nxfin121kl81d0as6f10wlrzndsn3sf"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove bundled websocketpp.
+ (delete-file-recursively "src/third_party/websocketpp")
+ (substitute* "pokerth_lib.pro"
+ (("src/third_party/websocketpp")
+ ""))
+ #t))))
+ (build-system qt-build-system)
+ (inputs
+ `(("boost" ,boost)
+ ("curl" ,curl)
+ ("gsasl" ,gsasl)
+ ("libgcrypt" ,libgcrypt)
+ ("libircclient" ,libircclient)
+ ("protobuf" ,protobuf-2) ; remove package when no longer needed
+ ("qtbase" ,qtbase-5)
+ ("sdl" ,(sdl-union (list sdl sdl-mixer)))
+ ("sqlite" ,sqlite)
+ ("tinyxml" ,tinyxml)
+ ("websocketpp" ,websocketpp)
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:tests? #f ; No test suite
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* (find-files "." "\\.pro$")
+ (("/opt/gsasl")
+ (assoc-ref inputs "gsasl"))
+ (("LIB_DIRS =")
+ (string-append "LIB_DIRS = "
+ (assoc-ref inputs "boost") "/lib")))
+ #t))
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "qmake" "pokerth.pro" "CONFIG+=client"
+ (string-append "PREFIX=" (assoc-ref outputs "out"))))))))
+ (home-page "https://www.pokerth.net")
+ (synopsis "Texas holdem poker game")
+ (description
+ "With PokerTH you can play the Texas holdem poker game, either against
computer opponents or against real players online.")
- (license license:agpl3+)))
+ (license license:agpl3+))))
(define-public xblackjack
(package
--
2.36.1
G
G
Greg Hogan wrote on 12 Jul 2022 22:54
Re: [PATCH 0/2] Fix protobuf-2.
CA+3U0Z=Vdxmq3aDpTCB+-20vbVosS_P8E0Gy5FnA1N9Bwy3GZw@mail.gmail.com
On Fri, Jul 8, 2022 at 4:48 PM Greg Hogan <code@greghogan.com> wrote:
Toggle quote (15 lines)
>
> This patchset fixes the broken protobuf-2 and updates the dependent
> pokerth in order to fix that build.
>
> Greg Hogan (2):
> gnu: protobuf-2: Fix broken build.
> gnu: pokerth: Update to 1.1.2-8e6088e4.
>
> gnu/packages/games.scm | 129 ++++++++++++++++++--------------------
> gnu/packages/protobuf.scm | 6 +-
> 2 files changed, 65 insertions(+), 70 deletions(-)
>
> --
> 2.36.1

Closing since fixed in a later patchset.
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56456@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56456
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch