Sharlatan Hellseher wrote 3 years ago
(address . guix-patches@gnu.org)
Hi Guix team!
I'm on the way to pack SunPy - astronomical python package for Sun astrophysics.
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 3b9c20528103da6b15da12f8cb0d828b7aaae79e Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 2 Jul 2022 21:03:54 +0100
Subject: [PATCH] gnu: Add cdflib
* gnu/packages/astronomy.scm (python-cdflib): New variable.
---
gnu/packages/astronomy.scm | 46 ++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)
Toggle diff (59 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 82a67ce5ef..0324edcb40 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -918,6 +918,52 @@ (define-public python-astroquery
to access online Astronomical data. Each web service has its own sub-package.")
(license license:bsd-3)))
+(define-public python-cdflib
+ (package
+ (name "python-cdflib")
+ (version "0.4.4")
+ (source
+ (origin
+ (method git-fetch) ; no tests in pypi archive
+ (uri (git-reference
+ (url "https://github.com/MAVENSDC/cdflib")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1h7750xvr6qbhnl2w3bhccs3pwp3hci3624pvvxym0yjinmskjlz"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "HOME" (getcwd))
+ (invoke "pytest" "-vv" "tests")))))))
+ (propagated-inputs
+ (list python-attrs python-numpy))
+ (native-inputs
+ (list python-astropy
+ python-hypothesis
+ python-pytest
+ python-pytest-cov
+ python-pytest-remotedata
+ python-xarray))
+ (home-page "https://github.com/MAVENSDC/cdflib")
+ (synopsis "Python library to deal with NASA's CDF astronmical data format")
+ (description "This package provides a Python CDF reader toolkit
+It provides functionality:
+@itemize
+@item Ability to read variables and attributes from CDF files (see CDF Reader
+Class)
+@item Writes CDF version 3 files (see CDF Writer Class)
+@item Can convert between CDF time types (EPOCH/EPOCH16/TT2000) to other common
+time formats (see CDF Time Conversions)
+@item Can convert CDF files into XArray Dataset objects and vice versa,
+attempting to maintain ISTP compliance (see Working with XArray)
+@end itemize\n")
+ (license license:expat)))
+
(define-public python-photutils
(package
(name "python-photutils")
--
2.36.1