[PATCH] gnu: Add cdflib

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 3 years ago
(address . guix-patches@gnu.org)
CAO+9K5p=xpLd9jHBR+EOeN1iH61OL7-dVy6BNC9Cc_XgzdkWoA@mail.gmail.com
Hi Guix team!
I'm on the way to pack SunPy - astronomical python package for Sun astrophysics.
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From 3b9c20528103da6b15da12f8cb0d828b7aaae79e Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sat, 2 Jul 2022 21:03:54 +0100
Subject: [PATCH] gnu: Add cdflib

* gnu/packages/astronomy.scm (python-cdflib): New variable.
---
gnu/packages/astronomy.scm | 46 ++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 82a67ce5ef..0324edcb40 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -918,6 +918,52 @@ (define-public python-astroquery
to access online Astronomical data. Each web service has its own sub-package.")
(license license:bsd-3)))
+(define-public python-cdflib
+ (package
+ (name "python-cdflib")
+ (version "0.4.4")
+ (source
+ (origin
+ (method git-fetch) ; no tests in pypi archive
+ (uri (git-reference
+ (url "https://github.com/MAVENSDC/cdflib")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1h7750xvr6qbhnl2w3bhccs3pwp3hci3624pvvxym0yjinmskjlz"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "HOME" (getcwd))
+ (invoke "pytest" "-vv" "tests")))))))
+ (propagated-inputs
+ (list python-attrs python-numpy))
+ (native-inputs
+ (list python-astropy
+ python-hypothesis
+ python-pytest
+ python-pytest-cov
+ python-pytest-remotedata
+ python-xarray))
+ (home-page "https://github.com/MAVENSDC/cdflib")
+ (synopsis "Python library to deal with NASA's CDF astronmical data format")
+ (description "This package provides a Python CDF reader toolkit
+It provides functionality:
+@itemize
+@item Ability to read variables and attributes from CDF files (see CDF Reader
+Class)
+@item Writes CDF version 3 files (see CDF Writer Class)
+@item Can convert between CDF time types (EPOCH/EPOCH16/TT2000) to other common
+time formats (see CDF Time Conversions)
+@item Can convert CDF files into XArray Dataset objects and vice versa,
+attempting to maintain ISTP compliance (see Working with XArray)
+@end itemize\n")
+ (license license:expat)))
+
(define-public python-photutils
(package
(name "python-photutils")
--
2.36.1
Ludovic Courtès wrote 3 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 56363-done@debbugs.gnu.org)
87a69js28p.fsf@gnu.org
Hello Sharlatan,

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (7 lines)
> From 3b9c20528103da6b15da12f8cb0d828b7aaae79e Mon Sep 17 00:00:00 2001
> From: Sharlatan Hellseher <sharlatanus@gmail.com>
> Date: Sat, 2 Jul 2022 21:03:54 +0100
> Subject: [PATCH] gnu: Add cdflib
>
> * gnu/packages/astronomy.scm (python-cdflib): New variable.

Applied with the cosmetic changes below, thanks!

Ludo’.
Toggle diff (24 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 0324edcb40..498252aaf4 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -952,15 +952,14 @@ (define-public python-cdflib
(home-page "https://github.com/MAVENSDC/cdflib")
(synopsis "Python library to deal with NASA's CDF astronmical data format")
(description "This package provides a Python CDF reader toolkit
-It provides functionality:
+It provides the following functionality:
@itemize
-@item Ability to read variables and attributes from CDF files (see CDF Reader
-Class)
-@item Writes CDF version 3 files (see CDF Writer Class)
+@item Ability to read variables and attributes from CDF files
+@item Writes CDF version 3 files
@item Can convert between CDF time types (EPOCH/EPOCH16/TT2000) to other common
-time formats (see CDF Time Conversions)
+time formats
@item Can convert CDF files into XArray Dataset objects and vice versa,
-attempting to maintain ISTP compliance (see Working with XArray)
+attempting to maintain ISTP compliance
@end itemize\n")
(license license:expat)))
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56363@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56363
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help