[PATCH] gnu: Add kaidan.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Raghav Gururajan
Owner
unassigned
Submitted by
Raghav Gururajan
Severity
normal
R
R
Raghav Gururajan wrote on 2 Jul 2022 10:49
(address . bug-guix@gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20220702084900.18089-1-rg@raghavgururajan.name
* gnu/packages/messaging.scm (kaidan): New variable.
---
gnu/packages/messaging.scm | 63 +++++++++++++++++++++++++++++++++++++-
1 file changed, 62 insertions(+), 1 deletion(-)

Toggle diff (88 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 9b1d06e21a..67841efc8a 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -25,7 +25,7 @@
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2020 Mason Hock <chaosmonk@riseup.net>
;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
-;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
+;;; Copyright © 2020, 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2020, 2021 Robert Karszniewicz <avoidr@posteo.de>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
@@ -89,6 +89,7 @@ (define-module (gnu packages messaging)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
#:use-module (gnu packages kde)
+ #:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages kerberos)
#:use-module (gnu packages less)
#:use-module (gnu packages libcanberra)
@@ -3359,4 +3360,64 @@ (define-public python-harmony
(home-page "https://github.com/taylordotfish/harmony")
(license license:gpl3+)))
+(define-public kaidan
+ (package
+ (name "kaidan")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://kde/unstable/kaidan/"
+ version "/kaidan-" version ".tar.xz"))
+ (modules '((guix build utils)))
+ (snippet
+ `(begin
+ (delete-file-recursively "3rdparty")))
+ (sha256
+ (base32 "195iddv35gc3k83r226y17avsab2b9bszgd7z7ynbddsgbf75rx7"))))
+ (build-system qt-build-system)
+ (arguments
+ `(#:configure-flags
+ (list
+ "-DBUILD_TESTS=TRUE")))
+ (native-inputs
+ (list
+ extra-cmake-modules
+ perl
+ pkg-config
+ python-wrapper))
+ (inputs
+ (list
+ kirigami
+ knotifications
+ qtbase-5
+ qtdeclarative
+ qtlocation
+ qtquickcontrols2
+ qtsvg
+ qtmultimedia
+ qtxmlpatterns
+ qqc2-desktop-style
+ qxmpp
+ zxing-cpp))
+ (home-page "https://www.kaidan.im/")
+ (synopsis "Qt-based XMPP/Jabber Client")
+ (description "Kaidan is a chat client. It uses the open communication
+protocol XMPP (Jabber). The user interface makes use of Kirigami and QtQuick,
+while the back-end of Kaidan is entirely written in C++ using Qt and the
+Qt-based XMPP library QXmpp.")
+ (license
+ (list
+ ;; Graphics
+ license:cc-by-sa4.0
+ ;; Files:
+ ;; src/{StatusBar.cpp|StatusBar.h|singleapp/*|hsluv-c/*}
+ ;; utils/generate-license.py
+ license:expat
+ ;; QrCodeVideoFrame
+ license:asl2.0
+ ;; Others
+ license:gpl3+))))
+
;;; messaging.scm ends here
--
2.36.1
R
R
Raghav Gururajan wrote on 2 Jul 2022 11:06
[PATCH v2] gnu: Add kaidan.
(address . 56349@debbugs.gnu.org)(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
20220702090627.19040-1-rg@raghavgururajan.name
* gnu/packages/messaging.scm (kaidan): New variable.
---
gnu/packages/messaging.scm | 64 +++++++++++++++++++++++++++++++++++++-
1 file changed, 63 insertions(+), 1 deletion(-)

Toggle diff (89 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 9b1d06e21a..4798119871 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -25,7 +25,7 @@
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2020 Mason Hock <chaosmonk@riseup.net>
;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
-;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
+;;; Copyright © 2020, 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2020, 2021 Robert Karszniewicz <avoidr@posteo.de>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
@@ -89,6 +89,7 @@ (define-module (gnu packages messaging)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
#:use-module (gnu packages kde)
+ #:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages kerberos)
#:use-module (gnu packages less)
#:use-module (gnu packages libcanberra)
@@ -3359,4 +3360,65 @@ (define-public python-harmony
(home-page "https://github.com/taylordotfish/harmony")
(license license:gpl3+)))
+(define-public kaidan
+ (package
+ (name "kaidan")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://kde/unstable/kaidan/"
+ version "/kaidan-" version ".tar.xz"))
+ (modules '((guix build utils)))
+ (snippet
+ `(begin
+ (delete-file-recursively "3rdparty")))
+ (sha256
+ (base32 "195iddv35gc3k83r226y17avsab2b9bszgd7z7ynbddsgbf75rx7"))))
+ (build-system qt-build-system)
+ (arguments
+ `(#:configure-flags
+ (list
+ "-DBUILD_TESTS=TRUE")))
+ (native-inputs
+ (list
+ extra-cmake-modules
+ perl
+ pkg-config
+ python-wrapper))
+ (inputs
+ (list
+ kirigami
+ knotifications
+ qtbase-5
+ qtdeclarative
+ qtgraphicaleffects
+ qtlocation
+ qtquickcontrols2
+ qtsvg
+ qtmultimedia
+ qtxmlpatterns
+ qqc2-desktop-style
+ qxmpp
+ zxing-cpp))
+ (home-page "https://www.kaidan.im/")
+ (synopsis "Qt-based XMPP/Jabber Client")
+ (description "Kaidan is a chat client. It uses the open communication
+protocol XMPP (Jabber). The user interface makes use of Kirigami and QtQuick,
+while the back-end of Kaidan is entirely written in C++ using Qt and the
+Qt-based XMPP library QXmpp.")
+ (license
+ (list
+ ;; Graphics
+ license:cc-by-sa4.0
+ ;; Files:
+ ;; src/{StatusBar.cpp|StatusBar.h|singleapp/*|hsluv-c/*}
+ ;; utils/generate-license.py
+ license:expat
+ ;; QrCodeVideoFrame
+ license:asl2.0
+ ;; Others
+ license:gpl3+))))
+
;;; messaging.scm ends here
--
2.36.1
L
L
Liliana Marie Prikler wrote on 2 Jul 2022 13:39
ae5d62df64bf91856e5fa4ee4250b15e08b06cc6.camel@gmail.com
Hi Raghav,

Am Samstag, dem 02.07.2022 um 05:06 -0400 schrieb Raghav Gururajan:
Toggle quote (1 lines)
> * gnu/packages/messaging.scm (kaidan): New variable.
I cleaned up your patch and pushed it.

Cheers
Closed
?