(address . guix-patches@gnu.org)
* gnu/packages/base.scm (tzdata)[replacement]: New field.
(tzdata-leap-seconds-list): New private variable.
---
gnu/packages/base.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)
Toggle diff (34 lines)
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 4bdc3e7792..b265b429d5 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1305,6 +1305,7 @@ (define-public tzdata
;; This package should be kept in sync with python-pytz in (gnu packages
;; time).
(version "2022a")
+ (replacement tzdata-leap-seconds-list)
(source (origin
(method url-fetch)
(uri (string-append
@@ -1390,6 +1391,19 @@ (define-public tzdata
and daylight-saving rules.")
(license public-domain)))
+(define tzdata-leap-seconds-list
+ (package
+ (inherit tzdata)
+ (arguments
+ (substitute-keyword-arguments (package-arguments tzdata)
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'install 'copy-leap-seconds-list
+ (lambda _
+ (copy-file "leap-seconds.list"
+ (string-append
+ #$output "/share/zoneinfo/leap-seconds.list"))))))))))
+
;;; A "fixed" version of tzdata, which is used in the test suites of glib and R
;;; and a few other places. We can update this whenever we are able to rebuild
;;; thousands of packages (for example, in a core-updates rebuild). This package
--
2.36.1