[PATCH] gnu: home: services: shells: Export Fish environment variables.

  • Done
  • quality assurance status badge
Details
One participant
  • (
Owner
unassigned
Submitted by
(
Severity
normal

Debbugs page

( wrote 3 years ago
(address . guix-patches@gnu.org)(name . ()(address . paren@disroot.org)
20220629065333.11191-1-paren@disroot.org
Variables set in the Fish configuration weren't previously being
exported. This commit changes `set` to `set -x` to do that.

* gnu/home/services/shells.scm (serialize-fish-env-vars): Output the
`set -x` command instead of `set`, so that variables get exported.

Based-on: d7449142f56cb0b34860f4ac90fc322aee32d177
---
gnu/home/services/shells.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/home/services/shells.scm b/gnu/home/services/shells.scm
index fd5a66090d..dda80736b1 100644
--- a/gnu/home/services/shells.scm
+++ b/gnu/home/services/shells.scm
@@ -555,9 +555,9 @@ (define (serialize-fish-env-vars field-name val)
((key . #f)
"")
((key . #t)
- #~(string-append "set " #$key "\n"))
+ #~(string-append "set -x " #$key "\n"))
((key . value)
- #~(string-append "set " #$key " " #$value "\n")))
+ #~(string-append "set -x " #$key " " #$value "\n")))
val)))
(define-configuration home-fish-configuration
--
2.36.1
( wrote 3 years ago
(address . control@debbugs.gnu.org)
CL2UD1AYDZRB.1J8XEJML6RI6U@guix-aspire
close 56294
thanks

-- (
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56294@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56294
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help