( wrote 3 years ago
(address . guix-patches@gnu.org)(name . ()(address . paren@disroot.org)
Variables set in the Fish configuration weren't previously being
exported. This commit changes `set` to `set -x` to do that.
* gnu/home/services/shells.scm (serialize-fish-env-vars): Output the
`set -x` command instead of `set`, so that variables get exported.
Based-on: d7449142f56cb0b34860f4ac90fc322aee32d177
---
gnu/home/services/shells.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (18 lines)
diff --git a/gnu/home/services/shells.scm b/gnu/home/services/shells.scm
index fd5a66090d..dda80736b1 100644
--- a/gnu/home/services/shells.scm
+++ b/gnu/home/services/shells.scm
@@ -555,9 +555,9 @@ (define (serialize-fish-env-vars field-name val)
((key . #f)
"")
((key . #t)
- #~(string-append "set " #$key "\n"))
+ #~(string-append "set -x " #$key "\n"))
((key . value)
- #~(string-append "set " #$key " " #$value "\n")))
+ #~(string-append "set -x " #$key " " #$value "\n")))
val)))
(define-configuration home-fish-configuration
--
2.36.1