"guix shell -f guix2.scm" fails always

  • Open
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Maxime Devos
Owner
unassigned
Submitted by
Maxime Devos
Severity
normal
M
M
Maxime Devos wrote on 28 Jun 2022 22:47
(address . bug-guix@gnu.org)
f4cf2cbe3d6648bfd192d449475332f4d413d67b.camel@telenet.be
Put the folllowing in "oops-guix.scm":

(use-modules (gnu packages))
(specifications->packages '("hello"))

then do: "guix shell -f oops-guix.scm" to make an environment
with "hello". I get:

Toggle quote (1 lines)
> guix shell: warning: no packages specified; creating an empty environment
$ which hello
Toggle quote (2 lines)
> /home/regulator/.guix-profile/bin/hello # <-- not from the new environment!

Or even simpler: do "guix shell -f non-existing-file.scm":
Toggle quote (2 lines)
> guix shell: warning: no packages specified; creating an empty environment

Looks like "-f" is ignored entirely?

Version information:
$ guix --version
guix (GNU Guix) 0

(Didn't there use to be a commit? Is confirmed on #guix as
reproducible ...)

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYrto4RccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7vPQAQCt+X11kjsi1+l3E0l9KKA0kByc
2lgkTinhktYTA67phQD+PrdR1NA26wfsdvibSuL4vtdBklvC2z3PwScfKAU05Ag=
=bsAt
-----END PGP SIGNATURE-----


L
L
Liliana Marie Prikler wrote on 29 Jun 2022 08:19
2df655ef071dd057655ebf6a87335148c6cd64e7.camel@ist.tugraz.at
Am Dienstag, dem 28.06.2022 um 22:47 +0200 schrieb Maxime Devos:
Toggle quote (19 lines)
> Put the folllowing in "oops-guix.scm":
>
> (use-modules (gnu packages))
> (specifications->packages '("hello"))
>
> then do: "guix shell -f oops-guix.scm" to make an environment
> with "hello".  I get:
>
> > guix shell: warning: no packages specified; creating an empty
> > environment
> $ which hello
> > /home/regulator/.guix-profile/bin/hello # <-- not from the new
> > environment!
>
> Or even simpler: do "guix shell -f non-existing-file.scm":
> > guix shell: warning: no packages specified; creating an empty
> > environment
>
> Looks like "-f" is ignored entirely?
Have you tried specifying a file that actually contains a package (not
a manifest)? That being said, the error reporting could be better :)
M
M
Maxime Devos wrote on 29 Jun 2022 11:10
cfdd155d4c1cfffcfb6344aa7d27b2a15aba84e4.camel@telenet.be
Liliana Marie Prikler schreef op wo 29-06-2022 om 08:19 [+0200]:
Toggle quote (5 lines)
> > Looks like "-f" is ignored entirely?
> Have you tried specifying a file that actually contains a package
> (not
> a manifest)?

None of the examples contain a manifest, oops-guix.scm actually
contains a list of packages as mentioned previously (*).  And the exact
same thing happens if a package is used instead of a list of packages.

(*):

Toggle quote (5 lines)
> > Put the folllowing in "oops-guix.scm":
> >
> > (use-modules (gnu packages))
> > (specifications->packages '("hello"))

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYrwXCBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7uXVAQDqtDtcgRRBpV7Hxirk9Nqdhmnx
XBNBeJY97UTb/o0L2gD/WIODLIyBkEPB+zrnn0o1iDZHtlDjTIHQq6CyHUg/+QU=
=z9oK
-----END PGP SIGNATURE-----


L
L
Liliana Marie Prikler wrote on 29 Jun 2022 11:22
823572af8921c9b7b1468ace6d248eb5f4bbee68.camel@ist.tugraz.at
Am Mittwoch, dem 29.06.2022 um 11:10 +0200 schrieb Maxime Devos:
Toggle quote (7 lines)
> Liliana Marie Prikler schreef op wo 29-06-2022 om 08:19 [+0200]:
> > > Looks like "-f" is ignored entirely?
> > Have you tried specifying a file that actually contains a package
> > (not a manifest)?
>
> None of the examples contain a manifest, oops-guix.scm actually
> contains a list of packages as mentioned previously (*).
My bad, I read that as specifications->manifest. Note that for
specifications->package, you could simply specify hello on the command
line.

Having tested your file now, I can say that guix shell builds hello as
expected, whereas with specifications->manifest, it produces a lovely
backtrace (which is more or less what one ought to expect).

Toggle quote (2 lines)
> And the exact same thing happens if a package is used instead of a
> list of packages.
One thing to check here is whether a cache might be interfering. I
think it is an already known bug, that the file itself is not key in
the cache, which you can work around by specifying --rebuild-cache.

Cheers
M
M
Maxime Devos wrote on 29 Jun 2022 11:40
0087a26483dcbfef0d922b04e75530cde057edc8.camel@telenet.be
Liliana Marie Prikler schreef op wo 29-06-2022 om 11:22 [+0200]:
Toggle quote (6 lines)
> > And the exact same thing happens if a package is used instead of a
> > list of packages.
> One thing to check here is whether a cache might be interfering.  I
> think it is an already known bug, that the file itself is not key in
> the cache, which you can work around by specifying --rebuild-cache.

Whatever non-existent file name I use, I don't get an error message but
the warning ‘guix shell: warning: no packages specified; creating an
empty environment’, so this doesn't look like a cache issue to me.

However, if I do:

$ LANGUAGE=en_US guix shell --rebuild-cache -f nn-fefefefexistent.scm
guix shell: error: failed to load 'nn-fefefefexistent.scm': No such file or directory

$ LANGUAGE=en_US guix shell --rebuild-cache -f nn-fefefefexistent.scm
guix shell: error: failed to load 'nn-fefefefexistent.scm': No such file or directory

$ LANGUAGE=en_US guix shell --rebuild-cache -f mm-fefefefexistent.scm
guix shell: error: failed to load 'mm-fefefefexistent.scm': No such file or directory

$ LANGUAGE=en_US guix shell -f mm-fefefefexistent.scm
guix shell: error: failed to load 'mm-fefefefexistent.scm': No such file or directory

so looks like there's a cache issue!

Greetings,
Maxime.


*
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYrweChccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7h65AQD+vw7G3TZgFkEye6Scid8gsZZP
pyvSJBVOCijyiTJH/wD/ewnoHvc5SMWZfP0xriumxYuUw6+69W6UZsC6Ph5d6gI=
=y/mv
-----END PGP SIGNATURE-----


L
L
Liliana Marie Prikler wrote on 29 Jun 2022 11:49
19b8d259a397c514fce0be7a850138c9a64a2cef.camel@ist.tugraz.at
Am Mittwoch, dem 29.06.2022 um 11:40 +0200 schrieb Maxime Devos:
Toggle quote (11 lines)
> Liliana Marie Prikler schreef op wo 29-06-2022 om 11:22 [+0200]:
> > > And the exact same thing happens if a package is used instead of
> > > a list of packages.
> > One thing to check here is whether a cache might be interfering.  I
> > think it is an already known bug, that the file itself is not key
> > in the cache, which you can work around by specifying --rebuild-
> > cache.
>
> Whatever non-existent file name I use, I don't get an error message
> but the warning ‘guix shell: warning: no packages specified; creating
> an empty environment’, so this doesn't look like a cache issue to me.
That is exactly the cache issue, though. Once ‘guix shell -f’
“succeeds” (even with an empty environment), subsequent invocations
lacking ‘--rebuild-cache’ ignore the file completely and serve from
cache.


Cheers
?