gnu: add raul, add ingen

  • Open
  • quality assurance status badge
Details
One participant
  • Schmidt, Florian Paul
Owner
unassigned
Submitted by
Schmidt, Florian Paul
Severity
normal
S
S
Schmidt, Florian Paul wrote on 28 Jun 2022 16:30
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
52554c2fa03a49fa9b4ffcf332084cff@uni-bielefeld.de
Hi,


looking forward to your review. Thanks and

kind regards,
FPS
Attachment: file
Toggle diff (80 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 8ec78f665c..85a994bbea 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2679,6 +2679,75 @@ (define-public audio-to-midi
frequencies. This data is then formatted to MIDI and written to disk.")
(license license:expat)))
+(define-public raul
+ (package
+ (name "raul")
+ (version "c56e7259")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/drobilla/raul")
+ (commit "c56e72595ac6478639f6a0b074d24946d652dc4b")
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1s87ma7pn5g1054rhizmjcjzk5fyil47nk6d8ql4grr85hghrk39"))))
+ (build-system waf-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (delete 'check))))
+ (native-inputs
+ (list python pkg-config))
+ (home-page "http://drobilla.net/software/raul.html")
+ (synopsis "A realtime audio utility library for C++")
+ (description
+ "Raul (Realtime Audio Utility Library) is a C++ utility library
+primarily aimed at audio/musical applications.
+It is used by Ingen, Patchage, and Machina.")
+ (license license:gpl3+)))
+
+(define-public ingen
+ (package
+ (name "ingen")
+ (version "41dcb999")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/drobilla/ingen")
+ (commit "41dcb999034254a6aa1161610c38978b0b819b15")
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0bibwpgjijsz3jj9v43fvgna65w31j65r1r69hp33q6n797jq23s"))))
+ (build-system waf-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (delete 'check))
+ #:configure-flags
+ (list
+ (string-append "LDFLAGS=-Wl,-rpath=" (assoc-ref %outputs "out") "/lib"))))
+ (native-inputs
+ (list
+ python pkg-config boost lilv suil lv2
+ raul jack-1 portaudio libsigc++-2 alsa-lib
+ glibmm-2.64 gtkmm-2 ganv))
+ (home-page "http://drobilla.net/software/ingen.html")
+ (synopsis "Realtime modular audio system based on LV2")
+ (description
+ "Ingen is built around LV2 technology and a strict separation
+of engine from user interface. The engine is controlled
+exclusively through a protocol, and can execute as a
+headless process, with an in-process GUI, or as an LV2
+plugin. The GUI can run as a program which communicates
+over a Unix or TCP/IP socket, or as an embeddable LV2
+GUI which communicates via LV2 ports.")
+ (license license:agpl3+)))
+
+
(define-public lilv
(package
(name "lilv")
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 56278@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56278
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch