[PATCH 0/2] gnu: Add gdk-pixbuf-xlib.

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Liliana Marie Prikler
  • Tomasz Jeneralczyk
Owner
unassigned
Submitted by
Tomasz Jeneralczyk
Severity
normal
T
T
Tomasz Jeneralczyk wrote on 28 Jun 2022 15:09
(address . guix-patches@gnu.org)(name . Tomasz Jeneralczyk)(address . tj@schwi.pl)
cover.1656419649.git.tj@schwi.pl
In gdk-pixbuf version 2.42.0 the gdk-pixbuf-xlib was split into
its own separate library:

Although it's described as deprecated, there's at least one package
that has missing functionality without gdk-pixbuf-xlib but still
builds just fine: xscreensaver.
There might be more packages like this.

I'm not sure if I packaged this library correctly seeing as many other
gtk packages have a lot custom phases and whatnot. But if it is added
as a native-input to xscreensaver it restores its ability to build
the `xscreensaver-demo` binary.


Tomasz Jeneralczyk (2):
gnu: gdk-pixbuf: Remove unnecessary dependency.
gnu: Add gdk-pixbuf-xlib.

gnu/packages/gtk.scm | 30 ++++++++++++++++++++++++++++--
1 file changed, 28 insertions(+), 2 deletions(-)


base-commit: 8d810c209f18ffb635a1db2488a939543c6f060f
--
2.36.1
T
T
Tomasz Jeneralczyk wrote on 28 Jun 2022 15:21
[PATCH 1/2] gnu: gdk-pixbuf: Remove unnecessary dependency.
(address . 56276@debbugs.gnu.org)(name . Tomasz Jeneralczyk)(address . tj@schwi.pl)
c9b357baf19c33c14b3abbeee533104da360044c.1656419649.git.tj@schwi.pl
* gnu/packages/gtk.scm (gtk-pixbuf): Remove libx11 from native-inputs

gdk-pixbuf-xlib was split into its own library in gdk-pixbuf version 2.42.0:
---
gnu/packages/gtk.scm | 2 --
1 file changed, 2 deletions(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 4d6a690fbb..835c0be3a2 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -682,8 +682,6 @@ (define-public gdk-pixbuf
(propagated-inputs
(list ;; Required by gdk-pixbuf-2.0.pc
glib
- ;; Required by gdk-pixbuf-xlib-2.0.pc
- libx11
;; Used for testing and required at runtime.
shared-mime-info))
(inputs
--
2.36.1
T
T
Tomasz Jeneralczyk wrote on 28 Jun 2022 15:21
[PATCH 2/2] gnu: Add gdk-pixbuf-xlib.
(address . 56276@debbugs.gnu.org)(name . Tomasz Jeneralczyk)(address . tj@schwi.pl)
d3590068657e6608a6654a65bf24ac16e3c39494.1656419649.git.tj@schwi.pl
* gnu/packages/gtk.scm (gtk-pixbuf-xlib): Add variable.

This was part of gtk-pixbuf before but was split into its own library
---
gnu/packages/gtk.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 835c0be3a2..31e100e91d 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -715,6 +715,34 @@ (define-public gdk-pixbuf
(home-page "https://wiki.gnome.org/Projects/GdkPixbuf")
(license license:lgpl2.1+)))
+(define-public gdk-pixbuf-xlib
+ (package
+ (name "gdk-pixbuf-xlib")
+ (version "2.40.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://gitlab.gnome.org/Archive/gdk-pixbuf-xlib.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vwnvqxap3r9zw932jwasazy9sxw49j78x2g650xkn70iili90bg"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:configure-flags '("-Dgtk_doc=true")))
+ (native-inputs (list pkg-config gtk-doc/stable))
+ (inputs (list gdk-pixbuf libx11))
+ (synopsis "Deprecated Xlib integration for GdkPixbuf")
+ (description
+ "GdkPixbuf-Xlib contains the deprecated API for integrating GdkPixbuf with
+Xlib data types. This library was originally shipped by gdk-pixbuf, and has
+since been moved out of the original repository. No newly written code should
+ever use this library.")
+ (home-page "https://gitlab.gnome.org/Archive/gdk-pixbuf-xlib")
+ (license license:lgpl2.1+)))
+
;;; A minimal variant used to prevent a cycle with Inkscape.
(define-public at-spi2-core-minimal
(hidden-package
--
2.36.1
L
L
Liliana Marie Prikler wrote on 28 Jun 2022 14:38
Re: [PATCH 1/2] gnu: gdk-pixbuf: Remove unnecessary dependency.
e74bc39ef5c3f4866898589d2afa6f1dae566f67.camel@ist.tugraz.at
Am Dienstag, dem 28.06.2022 um 13:21 +0000 schrieb Tomasz Jeneralczyk:
Toggle quote (5 lines)
> * gnu/packages/gtk.scm (gtk-pixbuf): Remove libx11 from native-inputs
>
> gdk-pixbuf-xlib was split into its own library in gdk-pixbuf version
> 2.42.0:
> https://gitlab.gnome.org/GNOME/gdk-pixbuf/-/tags/2.42.0
Details go before, not after the ChangeLog.
Toggle quote (17 lines)
> ---
>  gnu/packages/gtk.scm | 2 --
>  1 file changed, 2 deletions(-)
>
> diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> index 4d6a690fbb..835c0be3a2 100644
> --- a/gnu/packages/gtk.scm
> +++ b/gnu/packages/gtk.scm
> @@ -682,8 +682,6 @@ (define-public gdk-pixbuf
>      (propagated-inputs
>       (list ;; Required by gdk-pixbuf-2.0.pc
>             glib
> -           ;; Required by gdk-pixbuf-xlib-2.0.pc
> -           libx11
>             ;; Used for testing and required at runtime.
>             shared-mime-info))
>      (inputs
This patch should go to core-updates, while 2/2 can go to master.
T
T
Tomasz Jeneralczyk wrote on 28 Jun 2022 15:45
(name . Liliana Marie Prikler)(address . liliana.prikler@ist.tugraz.at)(address . 56276@debbugs.gnu.org)
a3cffdc1e4b05621de14a6afd337da65@schwi.pl
On 2022-06-28 12:38, Liliana Marie Prikler wrote:
Toggle quote (2 lines)
> This patch should go to core-updates, while 2/2 can go to master.

Should I send the patched here as [PATCH v2 1/2 core-updates] and [PATCH
v2 2/2], or split it into two new patches?
Sorry, it's just not clear to me.

I also noticed I gave the 1/2 an incorrect changelog - it should be
`propagated-inputs` instead of `native-inputs`. I'll fix that too.
L
L
Liliana Marie Prikler wrote on 28 Jun 2022 15:49
(name . Tomasz Jeneralczyk)(address . tj@schwi.pl)(address . 56276@debbugs.gnu.org)
3ac3419ef08742e5a1b377ff0f489ef42c73522b.camel@ist.tugraz.at
Am Dienstag, dem 28.06.2022 um 13:45 +0000 schrieb Tomasz Jeneralczyk:
Toggle quote (6 lines)
> On 2022-06-28 12:38, Liliana Marie Prikler wrote:
> > This patch should go to core-updates, while 2/2 can go to master.
>
> Should I send the patched here as [PATCH v2 1/2 core-updates] and
> [PATCH v2 2/2], or split it into two new patches?
> Sorry, it's just not clear to me.
The way you propose is *probably* fine. It's rather rare that patches
"need" to be split in this manner. FWIW I'd propose swapping the
patches around, so that [1/2] can go to master and [2/2] to core-
updates.

Toggle quote (2 lines)
> I also noticed I gave the 1/2 an incorrect changelog - it should be
> `propagated-inputs` instead of `native-inputs`. I'll fix that too.
Please do.

Cheers
T
T
Tomasz Jeneralczyk wrote on 28 Jun 2022 18:15
[PATCH v2 1/2] gnu: Add gdk-pixbuf-xlib.
(address . 56276@debbugs.gnu.org)(name . Tomasz Jeneralczyk)(address . tj@schwi.pl)
953b0e4bae239733fab4c462c7bc813171ffed01.1656431910.git.tj@schwi.pl
This was part of gtk-pixbuf before but was split into its own library

* gnu/packages/gtk.scm (gtk-pixbuf-xlib): Add variable.
---
gnu/packages/gtk.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 4d6a690fbb..358eb365ef 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -717,6 +717,34 @@ (define-public gdk-pixbuf
(home-page "https://wiki.gnome.org/Projects/GdkPixbuf")
(license license:lgpl2.1+)))
+(define-public gdk-pixbuf-xlib
+ (package
+ (name "gdk-pixbuf-xlib")
+ (version "2.40.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://gitlab.gnome.org/Archive/gdk-pixbuf-xlib.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vwnvqxap3r9zw932jwasazy9sxw49j78x2g650xkn70iili90bg"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:configure-flags '("-Dgtk_doc=true")))
+ (native-inputs (list pkg-config gtk-doc/stable))
+ (inputs (list gdk-pixbuf libx11))
+ (synopsis "Deprecated Xlib integration for GdkPixbuf")
+ (description
+ "GdkPixbuf-Xlib contains the deprecated API for integrating GdkPixbuf with
+Xlib data types. This library was originally shipped by gdk-pixbuf, and has
+since been moved out of the original repository. No newly written code should
+ever use this library.")
+ (home-page "https://gitlab.gnome.org/Archive/gdk-pixbuf-xlib")
+ (license license:lgpl2.1+)))
+
;;; A minimal variant used to prevent a cycle with Inkscape.
(define-public at-spi2-core-minimal
(hidden-package

base-commit: 8d810c209f18ffb635a1db2488a939543c6f060f
--
2.36.1
T
T
Tomasz Jeneralczyk wrote on 28 Jun 2022 18:15
[PATCH core-updates v2 2/2] gnu: gdk-pixbuf: Remove unnecessary dependency.
(address . 56276@debbugs.gnu.org)(name . Tomasz Jeneralczyk)(address . tj@schwi.pl)
e6a1f1974b11a186044716829e2e4cdde8c52e22.1656431910.git.tj@schwi.pl
gdk-pixbuf-xlib was split into its own library in gdk-pixbuf version 2.42.0:

* gnu/packages/gtk.scm (gtk-pixbuf): Remove libx11 from propagated-inputs
---
gnu/packages/gtk.scm | 2 --
1 file changed, 2 deletions(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 358eb365ef..31e100e91d 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -682,8 +682,6 @@ (define-public gdk-pixbuf
(propagated-inputs
(list ;; Required by gdk-pixbuf-2.0.pc
glib
- ;; Required by gdk-pixbuf-xlib-2.0.pc
- libx11
;; Used for testing and required at runtime.
shared-mime-info))
(inputs
--
2.36.1
L
L
Liliana Marie Prikler wrote on 2 Jul 2022 13:54
Re: [PATCH v2 1/2] gnu: Add gdk-pixbuf-xlib.
7b1bae28eb28579d8d5d133e3a9b43f5476f149b.camel@gmail.com
Am Dienstag, dem 28.06.2022 um 16:15 +0000 schrieb Tomasz Jeneralczyk:
Toggle quote (5 lines)
> This was part of gtk-pixbuf before but was split into its own library
> in version 2.42.0:
> https://gitlab.gnome.org/GNOME/gdk-pixbuf/-/tags/2.42.0
>
> * gnu/packages/gtk.scm (gtk-pixbuf-xlib): Add variable.
Pushed with a slight rewording, though I missed the typo in gtk-pixbuf-
xlib. Also added a follow-up commit to hint core-updates folk that the
libx11 input ought to be removed from gdk-pixbuf.

I'll thus mark this as “done”, even if a task remains :)
Closed
?