[PATCH] gnu: Add r-bandits.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220627223403.21840-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-bandits): New variable.
---
gnu/packages/bioconductor.scm | 38 +++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..628eaacb6c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2029,6 +2029,44 @@ (define-public r-aneufinder
sequencing data.")
(license license:artistic2.0)))
+(define-public r-bandits
+ (package
+ (name "r-bandits")
+ (version "1.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BANDITS" version))
+ (sha256
+ (base32
+ "1423djb7cij68y0q2dcp8q7lrcn2fxjn6d25v4qy3w00b2w8ppg9"))))
+ (properties `((upstream-name . "BANDITS")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocparallel
+ r-data-table
+ r-doparallel
+ r-dorng
+ r-drimseq
+ r-foreach
+ r-ggplot2
+ r-mass
+ r-r-utils
+ r-rcpp
+ r-rcpparmadillo))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/SimoneTiberi/BANDITS")
+ (synopsis "Bayesian analysis of differential splicing")
+ (description
+ "@code{BANDITS} is a Bayesian hierarchical model for detecting differential
+splicing of genes and transcripts, via @dfn{DTU} (differential transcript usage),
+between two or more conditions. The method uses a Bayesian hierarchical framework,
+which allows for sample specific proportions in a Dirichlet-Multinomial model,
+and samples the allocation of fragments to the transcripts. Parameters are
+inferred via @dfn{MCMC} (Markov chain Monte Carlo) techniques and a DTU test is
+performed via a multivariate Wald test on the posterior densities for the average
+relative abundance of transcripts.")
+ (license license:gpl3+)))
+
(define-public r-biocversion
(package
(name "r-biocversion")

base-commit: 144a750f8b10e606751bc887bcb09e7fb7ae09ff
--
2.36.1
Ricardo Wurmus wrote 2 years ago
(address . 56269-done@debbugs.gnu.org)
87a65hgyab.fsf@elephly.net
Applied with minor changes.
Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56269@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56269
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help