[PATCH] gnu: Add r-badregionfinder.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220627213936.19198-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-badregionfinder): New variable.
---
gnu/packages/bioconductor.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..aa4ba4706d 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2029,6 +2029,34 @@ (define-public r-aneufinder
sequencing data.")
(license license:artistic2.0)))
+(define-public r-badregionfinder
+ (package
+ (name "r-badregionfinder")
+ (version "1.24.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BadRegionFinder" version))
+ (sha256
+ (base32
+ "1a1pqmh5ak9s3k1lxw6flanchk24zyznwm34ixi2b78wdc3hqgm9"))))
+ (properties `((upstream-name . "BadRegionFinder")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biomart
+ r-genomicranges
+ r-rsamtools
+ r-s4vectors
+ r-variantannotation))
+ (home-page "https://bioconductor.org/packages/BadRegionFinder")
+ (synopsis "Identifying regions with bad coverage in sequence alignment data")
+ (description
+ "@code{BadRegionFinder} is a package for identifying regions with a bad,
+acceptable and good coverage in sequence alignment data available as bam files.
+The whole genome may be considered as well as a set of target regions. Various
+visual and textual types of output are available.")
+ (license license:lgpl3)))
+
+
(define-public r-biocversion
(package
(name "r-biocversion")

base-commit: 144a750f8b10e606751bc887bcb09e7fb7ae09ff
--
2.36.1
Ricardo Wurmus wrote 2 years ago
(address . 56267-done@debbugs.gnu.org)
87ilk5gybj.fsf@elephly.net
Applied with minor changes. Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56267@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56267
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help