Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
* gnu/packages/bioconductor.scm (r-badregionfinder): New variable.
---
gnu/packages/bioconductor.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
Toggle diff (43 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..aa4ba4706d 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2029,6 +2029,34 @@ (define-public r-aneufinder
sequencing data.")
(license license:artistic2.0)))
+(define-public r-badregionfinder
+ (package
+ (name "r-badregionfinder")
+ (version "1.24.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BadRegionFinder" version))
+ (sha256
+ (base32
+ "1a1pqmh5ak9s3k1lxw6flanchk24zyznwm34ixi2b78wdc3hqgm9"))))
+ (properties `((upstream-name . "BadRegionFinder")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biomart
+ r-genomicranges
+ r-rsamtools
+ r-s4vectors
+ r-variantannotation))
+ (home-page "https://bioconductor.org/packages/BadRegionFinder")
+ (synopsis "Identifying regions with bad coverage in sequence alignment data")
+ (description
+ "@code{BadRegionFinder} is a package for identifying regions with a bad,
+acceptable and good coverage in sequence alignment data available as bam files.
+The whole genome may be considered as well as a set of target regions. Various
+visual and textual types of output are available.")
+ (license license:lgpl3)))
+
+
(define-public r-biocversion
(package
(name "r-biocversion")
base-commit: 144a750f8b10e606751bc887bcb09e7fb7ae09ff
--
2.36.1