[PATCH] gnu: Add r-bader.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)
20220627212824.18326-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-bader): New variable.
---
gnu/packages/bioconductor.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1e87b190c2..6d65cc1c1f 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2029,6 +2029,30 @@ (define-public r-aneufinder
sequencing data.")
(license license:artistic2.0)))
+(define-public r-bader
+ (package
+ (name "r-bader")
+ (version "1.34.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BADER" version))
+ (sha256
+ (base32
+ "0i5x1r2ns1hxhqk5jyfqird81hck1hllvvgx5bn0rb5vl99g8spm"))))
+ (properties `((upstream-name . "BADER")))
+ (build-system r-build-system)
+ (home-page "https://bioconductor.org/packages/BADER")
+ (synopsis
+ "Bayesian analysis of differential expression in RNA sequencing data")
+ (description
+ "The @code{BADER} package is intended for the analysis of RNA sequencing
+data. The algorithm fits a Bayesian hierarchical model for RNA sequencing count
+data. @code{BADER} returns the posterior probability of differential expression
+for each gene between two groups A and B. The joint posterior distribution of
+the variables in the model can be returned in the form of posterior samples,
+which can be used for further down-stream analyses such as gene set enrichment.")
+ (license license:gpl2)))
+
(define-public r-biocversion
(package
(name "r-biocversion")

base-commit: 144a750f8b10e606751bc887bcb09e7fb7ae09ff
--
2.36.1
Ricardo Wurmus wrote 2 years ago
(address . 56266-done@debbugs.gnu.org)
87mt9hgz1t.fsf@elephly.net
Applied with minor changes, thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56266@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56266
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help