[PATCH] gnu: polkit-mozjs: Fix native-inputs usage.

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Marius Bakke
  • Jean Pierre De Jesus DIAZ
Owner
unassigned
Submitted by
Jean Pierre De Jesus DIAZ
Severity
normal
J
J
Jean Pierre De Jesus DIAZ wrote on 27 Jun 2022 12:34
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
B_CFQDy5KLheC3sodY7GB7qAP5KbxyAQ9KC1Icp3s5IGK9ILZ72PmklC8NpuD5vcsAvpDCCV3sYJpgnSJXhW1ew2g8ViwpX5pl1zom6itrk=@jeandudey.tech
This patch fixes cross-compilation for `polkit-mozjs' and `polkit-duktape'.

The error can be seen by executing:

guix build polkit-duktape \
--target=aarch64-linux-gnu

Jean-Pierre De Jesus DIAZ
From ef8d6092de9a134cea73893536eb9ad9615454fe Mon Sep 17 00:00:00 2001
Message-Id: <ef8d6092de9a134cea73893536eb9ad9615454fe.1656325553.git.me@jeandudey.tech>
From: Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
Date: Mon, 27 Jun 2022 12:18:05 +0200
Subject: [PATCH] gnu: polkit-mozjs: Fix native-inputs on stage.

* gnu/packages/polkit.scm (polkit-duktape)[arguments]: Change the use of
`inputs' to `native-inputs' when searching for `docbook-xsl' path as
it is a native input.
---
gnu/packages/polkit.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index a75608cd43..8d9b6773c5 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -119,8 +120,8 @@ (define-public polkit-mozjs
(("@INTROSPECTION_TYPELIBDIR@")
(string-append out "/lib/girepository-1.0/"))))))
(add-after 'unpack 'fix-manpage-generation
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((xsldoc (string-append (assoc-ref inputs "docbook-xsl")
+ (lambda* (#:key native-inputs #:allow-other-keys)
+ (let ((xsldoc (string-append (assoc-ref native-inputs "docbook-xsl")
"/xml/xsl/docbook-xsl-"
,(package-version docbook-xsl))))
(substitute* '("docs/man/Makefile.am" "docs/man/Makefile.in")
--
2.36.1
From ef8d6092de9a134cea73893536eb9ad9615454fe Mon Sep 17 00:00:00 2001
Message-Id: <ef8d6092de9a134cea73893536eb9ad9615454fe.1656325553.git.me@jeandudey.tech>
From: Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
Date: Mon, 27 Jun 2022 12:18:05 +0200
Subject: [PATCH] gnu: polkit-mozjs: Fix native-inputs on stage.

* gnu/packages/polkit.scm (polkit-duktape)[arguments]: Change the use of
`inputs' to `native-inputs' when searching for `docbook-xsl' path as
it is a native input.
---
gnu/packages/polkit.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index a75608cd43..8d9b6773c5 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -119,8 +120,8 @@ (define-public polkit-mozjs
(("@INTROSPECTION_TYPELIBDIR@")
(string-append out "/lib/girepository-1.0/"))))))
(add-after 'unpack 'fix-manpage-generation
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((xsldoc (string-append (assoc-ref inputs "docbook-xsl")
+ (lambda* (#:key native-inputs #:allow-other-keys)
+ (let ((xsldoc (string-append (assoc-ref native-inputs "docbook-xsl")
"/xml/xsl/docbook-xsl-"
,(package-version docbook-xsl))))
(substitute* '("docs/man/Makefile.am" "docs/man/Makefile.in")
--
2.36.1
L
L
Liliana Marie Prikler wrote on 27 Jun 2022 14:19
ed42c25112a138ab38b8f5c375b85374124bca19.camel@ist.tugraz.at
Am Montag, dem 27.06.2022 um 10:34 +0000 schrieb Jean Pierre De Jesus
DIAZ:

Toggle quote (6 lines)
> - (lambda* (#:key inputs #:allow-other-keys)
> - (let ((xsldoc (string-append (assoc-ref inputs
> "docbook-xsl")
> + (lambda* (#:key native-inputs #:allow-other-keys)
> + (let ((xsldoc (string-append (assoc-ref native-inputs
> "docbook-xsl")
The correct usage would be (or native-inputs inputs).

Cheers
J
J
Jean Pierre De Jesus DIAZ wrote on 27 Jun 2022 23:32
(name . 56252@debbugs.gnu.org)(address . 56252@debbugs.gnu.org)
Q0Y3IK7kQZOJM4gJF9WX07NzpvpPbjjwEOClNLNNfXjyXyCC9nf64e_FIP6S8DQAbvxZC1o6Dl7k1IV5UJlDcUu_aR71yhU2WW9IXg5OQ1w=@jeandudey.tech
Fixed it and changed commit message.

Thanks!

Jean-Pierre De Jesus DIAZ

------- Original Message -------
On Monday, June 27th, 2022 at 2:19 PM, Liliana Marie Prikler <liliana.prikler@ist.tugraz.at> wrote:


Toggle quote (13 lines)
> Am Montag, dem 27.06.2022 um 10:34 +0000 schrieb Jean Pierre De Jesus
> DIAZ:
>
> > - (lambda* (#:key inputs #:allow-other-keys)
> > - (let ((xsldoc (string-append (assoc-ref inputs
> > "docbook-xsl")
> > + (lambda* (#:key native-inputs #:allow-other-keys)
> > + (let ((xsldoc (string-append (assoc-ref native-inputs
> > "docbook-xsl")
>
> The correct usage would be (or native-inputs inputs).
>
> Cheers
From 7a6b55bb34a61ab393b5a994dc1467f5f25a2992 Mon Sep 17 00:00:00 2001
Message-Id: <7a6b55bb34a61ab393b5a994dc1467f5f25a2992.1656347660.git.me@jeandudey.tech>
From: Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
Date: Mon, 27 Jun 2022 12:18:05 +0200
Subject: [PATCH] gnu: polkit-mozjs: Fix native-inputs on stage.

* gnu/packages/polkit.scm (polkit-duktape)[arguments]: Change the use of
`inputs' to `(or native-inputs inputs)' when searching for `docbook-xsl'
path.
---
gnu/packages/polkit.scm | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index a75608cd43..9a3703b196 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -119,10 +120,11 @@ (define-public polkit-mozjs
(("@INTROSPECTION_TYPELIBDIR@")
(string-append out "/lib/girepository-1.0/"))))))
(add-after 'unpack 'fix-manpage-generation
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((xsldoc (string-append (assoc-ref inputs "docbook-xsl")
- "/xml/xsl/docbook-xsl-"
- ,(package-version docbook-xsl))))
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (let ((xsldoc (string-append
+ (assoc-ref (or native-inputs inputs) "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ ,(package-version docbook-xsl))))
(substitute* '("docs/man/Makefile.am" "docs/man/Makefile.in")
(("http://docbook.sourceforge.net/release/xsl/current")
xsldoc)))))
--
2.36.1
M
M
Marius Bakke wrote on 20 Jul 2022 15:12
874jzcnd1u.fsf@gnu.org
Toggle quote (10 lines)
> From 7a6b55bb34a61ab393b5a994dc1467f5f25a2992 Mon Sep 17 00:00:00 2001
> Message-Id: <7a6b55bb34a61ab393b5a994dc1467f5f25a2992.1656347660.git.me@jeandudey.tech>
> From: Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
> Date: Mon, 27 Jun 2022 12:18:05 +0200
> Subject: [PATCH] gnu: polkit-mozjs: Fix native-inputs on stage.
>
> * gnu/packages/polkit.scm (polkit-duktape)[arguments]: Change the use of
> `inputs' to `(or native-inputs inputs)' when searching for `docbook-xsl'
> path.

Pushed to 'staging' in 7767d30f55, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56252@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56252
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch