(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
This patch fixes cross-compilation for `polkit-mozjs' and `polkit-duktape'.
The error can be seen by executing:
guix build polkit-duktape \
--target=aarch64-linux-gnu
—
Jean-Pierre De Jesus DIAZ
From ef8d6092de9a134cea73893536eb9ad9615454fe Mon Sep 17 00:00:00 2001
Message-Id: <ef8d6092de9a134cea73893536eb9ad9615454fe.1656325553.git.me@jeandudey.tech>
From: Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
Date: Mon, 27 Jun 2022 12:18:05 +0200
Subject: [PATCH] gnu: polkit-mozjs: Fix native-inputs on stage.
* gnu/packages/polkit.scm (polkit-duktape)[arguments]: Change the use of
`inputs' to `native-inputs' when searching for `docbook-xsl' path as
it is a native input.
---
gnu/packages/polkit.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
Toggle diff (25 lines)
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index a75608cd43..8d9b6773c5 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -119,8 +120,8 @@ (define-public polkit-mozjs
(("@INTROSPECTION_TYPELIBDIR@")
(string-append out "/lib/girepository-1.0/"))))))
(add-after 'unpack 'fix-manpage-generation
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((xsldoc (string-append (assoc-ref inputs "docbook-xsl")
+ (lambda* (#:key native-inputs #:allow-other-keys)
+ (let ((xsldoc (string-append (assoc-ref native-inputs "docbook-xsl")
"/xml/xsl/docbook-xsl-"
,(package-version docbook-xsl))))
(substitute* '("docs/man/Makefile.am" "docs/man/Makefile.in")
--
2.36.1
From ef8d6092de9a134cea73893536eb9ad9615454fe Mon Sep 17 00:00:00 2001
Message-Id: <ef8d6092de9a134cea73893536eb9ad9615454fe.1656325553.git.me@jeandudey.tech>
From: Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
Date: Mon, 27 Jun 2022 12:18:05 +0200
Subject: [PATCH] gnu: polkit-mozjs: Fix native-inputs on stage.
* gnu/packages/polkit.scm (polkit-duktape)[arguments]: Change the use of
`inputs' to `native-inputs' when searching for `docbook-xsl' path as
it is a native input.
---
gnu/packages/polkit.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
Toggle diff (25 lines)
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index a75608cd43..8d9b6773c5 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -119,8 +120,8 @@ (define-public polkit-mozjs
(("@INTROSPECTION_TYPELIBDIR@")
(string-append out "/lib/girepository-1.0/"))))))
(add-after 'unpack 'fix-manpage-generation
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((xsldoc (string-append (assoc-ref inputs "docbook-xsl")
+ (lambda* (#:key native-inputs #:allow-other-keys)
+ (let ((xsldoc (string-append (assoc-ref native-inputs "docbook-xsl")
"/xml/xsl/docbook-xsl-"
,(package-version docbook-xsl))))
(substitute* '("docs/man/Makefile.am" "docs/man/Makefile.in")
--
2.36.1