[PATCH 1/1]: gnu: Add giza

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal
S
S
Sharlatan Hellseher wrote on 26 Jun 2022 23:30
(address . guix-patches@gnu.org)
CAO+9K5qfMty+OuF_+=3REN9tbw2HN_1pX2yD=X7ZmfEw7CcBLA@mail.gmail.com
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
From bd63d185da1aaaa8d084956bbc91da1a77fd7290 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 26 Jun 2022 22:28:33 +0100
Subject: [PATCH] gnu: Add giza

* gnu/packages/maths.scm (giza): New variable.
---
gnu/packages/maths.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 5e8fd7ae2d..65f07d3ac1 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Pierre-Antoine Bouttier <pierre-antoine.bouttier@univ-grenoble-alpes.fr>
+;;; Copyright © 2022 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1091,6 +1092,31 @@ (define-public feedgnuplot
in the terminal or with an external viewer.")
(license license:gpl1+))) ;any version
+(define-public giza
+ (package
+ (name "giza")
+ (version "1.3.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/danieljprice/giza")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1clklh3nzgwrwg80h3k5x65gdymbvcc84c44nql7m4bv9b8rqfsq"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list perl pkg-config))
+ (inputs
+ (list cairo freetype gfortran))
+ (home-page "https://danieljprice.github.io/giza/")
+ (synopsis "Scientific plotting library for C/Fortran")
+ (description
+ "Giza is a lightweight scientific plotting library built on top of
+@code{cairo} that provides uniform output to multiple devices.")
+ (license license:lgpl2.0)))
+
(define-public gnuplot
(package
(name "gnuplot")
--
2.36.0
L
L
Ludovic Courtès wrote on 4 Jul 2022 12:25
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 56242-done@debbugs.gnu.org)
87bku5fa3u.fsf@gnu.org
Hi,

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (7 lines)
> From bd63d185da1aaaa8d084956bbc91da1a77fd7290 Mon Sep 17 00:00:00 2001
> From: Sharlatan Hellseher <sharlatanus@gmail.com>
> Date: Sun, 26 Jun 2022 22:28:33 +0100
> Subject: [PATCH] gnu: Add giza
>
> * gnu/packages/maths.scm (giza): New variable.

[...]

Toggle quote (7 lines)
> + (synopsis "Scientific plotting library for C/Fortran")
> + (description
> + "Giza is a lightweight scientific plotting library built on top of
> +@code{cairo} that provides uniform output to multiple devices.")
> + (license license:lgpl2.0)))

Changed the license to ‘gpl2+’ because that’s what the source file
headers say (rather, they do not restrict to any particular version).

Applied, thanks!

Ludo’.
Closed
?