[PATCH 1/1]: gnu: Add giza

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 3 years ago
(address . guix-patches@gnu.org)
CAO+9K5qfMty+OuF_+=3REN9tbw2HN_1pX2yD=X7ZmfEw7CcBLA@mail.gmail.com
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
From bd63d185da1aaaa8d084956bbc91da1a77fd7290 Mon Sep 17 00:00:00 2001
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Sun, 26 Jun 2022 22:28:33 +0100
Subject: [PATCH] gnu: Add giza

* gnu/packages/maths.scm (giza): New variable.
---
gnu/packages/maths.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 5e8fd7ae2d..65f07d3ac1 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Pierre-Antoine Bouttier <pierre-antoine.bouttier@univ-grenoble-alpes.fr>
+;;; Copyright © 2022 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1091,6 +1092,31 @@ (define-public feedgnuplot
in the terminal or with an external viewer.")
(license license:gpl1+))) ;any version
+(define-public giza
+ (package
+ (name "giza")
+ (version "1.3.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/danieljprice/giza")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1clklh3nzgwrwg80h3k5x65gdymbvcc84c44nql7m4bv9b8rqfsq"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list perl pkg-config))
+ (inputs
+ (list cairo freetype gfortran))
+ (home-page "https://danieljprice.github.io/giza/")
+ (synopsis "Scientific plotting library for C/Fortran")
+ (description
+ "Giza is a lightweight scientific plotting library built on top of
+@code{cairo} that provides uniform output to multiple devices.")
+ (license license:lgpl2.0)))
+
(define-public gnuplot
(package
(name "gnuplot")
--
2.36.0
Ludovic Courtès wrote 3 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 56242-done@debbugs.gnu.org)
87bku5fa3u.fsf@gnu.org
Hi,

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

Toggle quote (7 lines)
> From bd63d185da1aaaa8d084956bbc91da1a77fd7290 Mon Sep 17 00:00:00 2001
> From: Sharlatan Hellseher <sharlatanus@gmail.com>
> Date: Sun, 26 Jun 2022 22:28:33 +0100
> Subject: [PATCH] gnu: Add giza
>
> * gnu/packages/maths.scm (giza): New variable.

[...]

Toggle quote (7 lines)
> + (synopsis "Scientific plotting library for C/Fortran")
> + (description
> + "Giza is a lightweight scientific plotting library built on top of
> +@code{cairo} that provides uniform output to multiple devices.")
> + (license license:lgpl2.0)))

Changed the license to ‘gpl2+’ because that’s what the source file
headers say (rather, they do not restrict to any particular version).

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56242@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56242
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help