[PATCH] Update GDAL to 3.5.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Roman Scherer
Owner
unassigned
Submitted by
Roman Scherer
Severity
normal
R
R
Roman Scherer wrote on 25 Jun 2022 14:25
(address . guix-patches@gnu.org)
87a6a1vsh6.fsf@burningswell.com
Hello Guix,

I would like to update the GDAL library to v3.5.0.

Could you please review it?

Thanks, Roman.
From caccab6114293a9b4e3b2304de22de997a076a34 Mon Sep 17 00:00:00 2001
From: r0man <roman@burningswell.com>
Date: Sat, 25 Jun 2022 13:47:19 +0200
Subject: [PATCH] Update GDAL to 3.5.0

This patch updates GDAL to v3.5.0. I added 2 more dependencies to the package:

- curl (To be able to read rasters using vsicurl) [1]

- openssl (To enable Postgresql raster support, pkg-config was not detecting
libpq without openssl)

I also had to add the --without-jpeg12 option, because GDAL did not build with
it's internal libjpeg and libjpeg12 removed. I don't think we supported
libjpeg12 in the previous version, since the bundled code was removed and I
believe libjpeg-turbo does not provide this functionality.

---
gnu/packages/geo.scm | 42 ++++++++++++++++++++----------------------
1 file changed, 20 insertions(+), 22 deletions(-)

Toggle diff (84 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 7b29c55088..38df5ff537 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -113,6 +113,7 @@ (define-module (gnu packages geo)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages textutils)
#:use-module (gnu packages time)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages web)
#:use-module (gnu packages webkit)
#:use-module (gnu packages wxwidgets)
@@ -914,7 +915,7 @@ (define-public spatialite-gui
(define-public gdal
(package
(name "gdal")
- (version "3.3.3")
+ (version "3.5.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -922,7 +923,7 @@ (define-public gdal
version ".tar.gz"))
(sha256
(base32
- "0nk09lws1hk873yn5f4wzqfvr82gm4hw3gq8w9g1h0kvf6j5x4i8"))
+ "0h7dgjx8nk3dd17wwqm2yjnaqciyrd2mz9gcjswpcnmap09wbzrs"))
(modules '((guix build utils)))
(snippet
`(begin
@@ -946,27 +947,23 @@ (define-public gdal
(string-append option "="
(assoc-ref %build-inputs input))))))
(list
- ;; TODO: --with-pcidsk, --with-pcraster
- (with "--with-freexl" "freexl")
- (with "--with-libjson-c" "json-c")
- (with "--with-png" "libpng")
- (with "--with-webp" "libwebp")
- (with "--with-gif" "giflib")
- (with "--with-jpeg" "libjpeg-turbo")
- (with "--with-libtiff" "libtiff")
- (with "--with-geotiff" "libgeotiff")
- (with "--with-libz" "zlib")
- (with "--with-expat" "expat")
- (with "--with-sqlite3" "sqlite")
- "--with-pcre"))
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'fix-path
- (lambda _
- (substitute* "frmts/mrf/mrf_band.cpp"
- (("\"../zlib/zlib.h\"") "<zlib.h>")))))))
+ ;; TODO: --with-pcidsk, --with-pcraster
+ (with "--with-expat" "expat")
+ (with "--with-freexl" "freexl")
+ (with "--with-geotiff" "libgeotiff")
+ (with "--with-gif" "giflib")
+ (with "--with-jpeg" "libjpeg-turbo")
+ (with "--with-libjson-c" "json-c")
+ (with "--with-libtiff" "libtiff")
+ (with "--with-libz" "zlib")
+ (with "--with-png" "libpng")
+ (with "--with-sqlite3" "sqlite")
+ (with "--with-webp" "libwebp")
+ "--without-jpeg12"
+ "--with-pcre"))))
(inputs
- (list expat
+ (list curl
+ expat
freexl
geos
giflib
@@ -977,6 +974,7 @@ (define-public gdal
libtiff
libwebp
netcdf
+ openssl
pcre
postgresql ; libpq
proj
--
2.36.1
-----BEGIN PGP SIGNATURE-----

iQFTBAEBCAA9FiEE0iajOdjfRIFd3gygPdpSUn0qwZkFAmK2/xUfHHJvbWFuLnNj
aGVyZXJAYnVybmluZ3N3ZWxsLmNvbQAKCRA92lJSfSrBmQL0B/9DvJMGHu294y+S
fQ6/d4w1/IVAZ8nU+g14JAKM01WsHD0qFt6RJmMXiL76CtWJ0zG+asBhhD4IxQvA
TDUxqXVOn4ZArcLEj2MfhTrRi1pW9TnKrV8TJPfToTlzxI/BC7X6E1iVb9t2kU/i
+vqy1Ee+W6quIA/VgnwIocdQz22ymyUaLHowKbWDkEuab+LLhld7yGfIQAVP1dmD
J5QLIWoWaoBAFoqTx3SmhyonSuaKswbYTs1QCzElkz+azipZfzVJe2Rn8/ePU3IN
P0Ab3u7Nf9ZoA/fj8owaDFrwt95RafdeHRDrdAnkl58jGl4JukWWDTxXbdzt3WAu
lxFei8Y4
=bAjp
-----END PGP SIGNATURE-----

G
G
Guillaume Le Vaillant wrote on 25 Jun 2022 21:17
(name . Roman Scherer)(address . roman.scherer@burningswell.com)(address . 56214-done@debbugs.gnu.org)
87fsjsr1oa.fsf@kitej
I modified the commit message to use our standard format (see [1]), and
pushed the patch as d4c8e8b62fb9ef59e203e97cbb9bfa9e83389199.
Thanks.

-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYrdfxQ8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9esgD/cA4ssnuZinR4RJ4N0PQ2/hsCKEyRlegJQ2ST
y6wwHcIA/26DHy2AuTcgpSZtvkBh8VCi9NitVlgDIHcvV1QyxLEb
=oU1V
-----END PGP SIGNATURE-----

Closed
R
R
Roman Scherer wrote on 25 Jun 2022 22:06
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 56214-done@debbugs.gnu.org)
87mte0zew9.fsf@burningswell.com
Thanks Guillaume!

Guillaume Le Vaillant <glv@posteo.net> writes:

Toggle quote (8 lines)
> [[PGP Signed Part:Undecided]]
> I modified the commit message to use our standard format (see [1]), and
> pushed the patch as d4c8e8b62fb9ef59e203e97cbb9bfa9e83389199.
> Thanks.
>
> [1] https://guix.gnu.org/manual/devel/en/guix.html#Submitting-Patches
>
> [[End of PGP Signed Part]]
-----BEGIN PGP SIGNATURE-----

iQFTBAEBCAA9FiEE0iajOdjfRIFd3gygPdpSUn0qwZkFAmK3atYfHHJvbWFuLnNj
aGVyZXJAYnVybmluZ3N3ZWxsLmNvbQAKCRA92lJSfSrBmabkB/99NaMnCwklyQ3A
wP8GrY5bOIhaU6XnimSBIiHDgQsUIQMCW+0Fj8mqiwCYeoYhq7B9C4X37vhle5Ap
peyx7YE2unTSW5hEJiQ7lrRlBY3dtcUACsysd2jyTJPVt9fLBpkcrnfAJbQnJPOS
5wiEqSc4S43z+qv/Hnnnsm5is3gadhg8F6Z9uvkGUvDnxLilwf8f8Ujyw+v1+xIu
FPDvCPW0CSAuzTzpfGTZsR5xgNvpa4PYNQB+gFv1TNrahe1Tbk00gB0xAZP24Nx8
fyiiJnmLiC/bNJcGsC3b465v/DMjdcu3MaaG5lNS4GGjslxuIev3UlyAsXbBMtz0
vUgCGB9+
=oV3+
-----END PGP SIGNATURE-----

Closed
?