[PATCH] gnu: Add nsync.

  • Done
  • quality assurance status badge
Details
3 participants
  • Antero Mejr
  • Andy Tai
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Antero Mejr
Severity
normal
A
A
Antero Mejr wrote on 24 Jun 2022 20:39
(address . guix-patches@gnu.org)
20220624183946.23595-1-antero@mailbox.org
* gnu/packages/c.scm (nsync): New variable.
---
gnu/packages/c.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 3e49539473..9f7e6891b9 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2021 David Dashyan <mail@davie.li>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 (unmatched parenthesis <paren@disroot.org>
+;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1134,3 +1135,31 @@ (define-public utf8-h
C and C++. The functions it provides are like those from the C header
string.h, but with a utf8* prefix instead of the str* prefix.")
(license license:unlicense))))
+
+(define-public nsync
+ (package
+ (name "nsync")
+ (version "1.24.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/nsync")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0737jcjw5nxv34zs7ppp6hqimb79k51kjiavgg0ygsfi22a6s0ld"))))
+ (build-system cmake-build-system)
+ (home-page "https://github.com/google/nsync")
+ (synopsis "C library for synchronization primitives")
+ (description
+ "nsync is a C library that exports various synchronization primitives:
+@enumerate
+@item locks
+@item condition variables
+@item run-once initialization
+@item waitable counter (useful for barriers)
+@item waitable bit (useful for cancellation, or other conditions)
+@end enumerate
+")
+ (license license:asl2.0)))
--
2.36.1
A
A
Antero Mejr wrote on 15 Nov 2022 23:26
[PATCH v2] gnu: Add nsync.
(address . 56202@debbugs.gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
20221115222601.15094-1-antero@mailbox.org
* gnu/packages/c.scm (nsync): New variable.
---
Update to 1.25.0 and build shared libs.

gnu/packages/c.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index fb876eeb71..e1d8105585 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -1376,3 +1376,33 @@ (define-public utest-h
(description
"This package provides a header-only unit testing library for C/C++.")
(license license:unlicense))))
+
+(define-public nsync
+ (package
+ (name "nsync")
+ (version "1.25.0")
+ (home-page "https://github.com/google/nsync")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1nnavsm5m0yl65r9nyxzzg0y1z1dr0r9933b5329k7n1r6ndinbd"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-DBUILD_SHARED_LIBS=ON")))
+ (synopsis "C library for synchronization primitives")
+ (description
+ "@code{nsync} is a C library that exports various synchronization
+primitives:
+@enumerate
+@item locks
+@item condition variables
+@item run-once initialization
+@item waitable counter (useful for barriers)
+@item waitable bit (useful for cancellation, or other conditions)
+@end enumerate\n")
+ (license license:asl2.0)))
--
2.38.1
A
A
Antero Mejr wrote on 6 Apr 2023 22:16
[PATCH v3] gnu: Add nsync.
(address . 56202@debbugs.gnu.org)
20230406201649.8364-1-antero@mailbox.org
* gnu/packages/c.scm (nsync): New variable.
---
gnu/packages/c.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index b2f16613dd..c7d3fb258c 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -1375,3 +1375,32 @@ (define-public utest-h
(description
"This package provides a header-only unit testing library for C/C++.")
(license license:unlicense))))
+
+(define-public nsync
+ (package
+ (name "nsync")
+ (version "1.25.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/nsync")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1nnavsm5m0yl65r9nyxzzg0y1z1dr0r9933b5329k7n1r6ndinbd"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-DBUILD_SHARED_LIBS=ON")))
+ (home-page "https://github.com/google/nsync")
+ (synopsis "C library for synchronization primitives")
+ (description
+ "nsync is a C library that exports various synchronization primitives:
+@itemize
+@item locks
+@item condition variables
+@item run-once initialization
+@item waitable counter (useful for barriers)
+@item waitable bit (useful for cancellation, or other conditions)
+@end itemize")
+ (license license:asl2.0)))
--
2.38.1
A
A
Andy Tai wrote on 16 Jun 2023 07:35
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
CAJsg1E8_GAZ9VfJ5QR90P6eSW93B5CSSQ4hj2uJ=GxtNv11uHA@mail.gmail.com
block 63897 by 56202
A
A
Andy Tai wrote on 16 Jun 2023 08:01
(address . 56202@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
f695914d0d26e9da855aac0c6fb69d03326daa2b.1686895184.git.atai@atai.org
* gnu/packages/c.scm (nsync): New variable.
---
gnu/packages/c.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index e8bde0133d..0b8cf20c6e 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2022 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2023 zamfofex <zamfofex@twdb.moe>
+;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1453,6 +1454,35 @@ (define-public utest-h
"This package provides a header-only unit testing library for C/C++.")
(license license:unlicense))))
+
+(define-public nsync
+ (package
+ (name "nsync")
+ (version "1.26.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/nsync")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qg58kkcbm4zqkql8j5yvrb7fpx09qsf7j93dwqb9s1y69l70kx4"))))
+ (build-system cmake-build-system)
+ (home-page "https://github.com/google/nsync")
+ (synopsis "C library for synchronization primitives")
+ (description
+ "nsync is a C library that exports various synchronization primitives:
+@enumerate
+@item locks
+@item condition variables
+@item run-once initialization
+@item waitable counter (useful for barriers)
+@item waitable bit (useful for cancellation, or other conditions)
+@end enumerate
+")
+ (license license:asl2.0)))
+
(define-public ispc
(package
(name "ispc")

base-commit: 31336e9f5d68512a9c1c6826bce9f17c892a2125
--
2.40.1
A
A
Andy Tai wrote on 28 Jul 2023 06:54
[PATCH v5] gnu: Add nsync
(address . 56202@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
ff2a1864eff1733af6f72bca069f0a52f45e06f2.1690520012.git.atai@atai.org
* gnu/packages/c.scm (nsync): New variable.
---
gnu/packages/c.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 9e5b511b98..722e2844cb 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2023 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
+;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1495,6 +1496,34 @@ (define-public utest-h
"This package provides a header-only unit testing library for C/C++.")
(license license:unlicense))))
+(define-public nsync
+ (package
+ (name "nsync")
+ (version "1.26.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/nsync")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qg58kkcbm4zqkql8j5yvrb7fpx09qsf7j93dwqb9s1y69l70kx4"))))
+ (build-system cmake-build-system)
+ (home-page "https://github.com/google/nsync")
+ (synopsis "C library for synchronization primitives")
+ (description
+ "nsync is a C library that exports various synchronization primitives:
+@enumerate
+@item locks
+@item condition variables
+@item run-once initialization
+@item waitable counter (useful for barriers)
+@item waitable bit (useful for cancellation, or other conditions)
+@end enumerate
+")
+ (license license:asl2.0)))
+
(define-public ispc
(package
(name "ispc")

base-commit: 35c8d631d2bd63c64e863b5509f29fdcb7f856e6
--
2.41.0
R
R
Ricardo Wurmus wrote on 8 Sep 2023 10:48
[PATCH] gnu: Add nsync.
(address . 56202-done@debbugs.gnu.org)
87edj96oea.fsf@elephly.net
Applied with very minor changes. Thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 56202@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 56202
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch