[PATCH] gnu: packages: qbe: Update to 1.0.

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Liliana Marie Prikler
  • (
Owner
unassigned
Submitted by
(
Severity
normal
(
(address . guix-patches@gnu.org)(name . ()(address . paren@disroot.org)
20220624060410.3257-1-paren@disroot.org
* gnu/packages/c.scm (qbe): Update to 1.0.
---
gnu/packages/c.scm | 72 ++++++++++++++++++++++------------------------
1 file changed, 35 insertions(+), 37 deletions(-)

Toggle diff (86 lines)
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 3e49539473..2dc8adb895 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -147,44 +147,42 @@ (define-public pcc
(license (list license:bsd-2 license:bsd-3))))
(define-public qbe
- (let ((commit "2caa26e388b1c904d2f12fb09f84df7e761d8331")
- (revision "1"))
- (package
- (name "qbe")
- (version (git-version "0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://c9x.me/qbe")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1gv03ym0gqrl4wkbhysa82025xwrkr1fg44z814b6vnggwlqgljc"))))
- (build-system gnu-build-system)
- (arguments
- (list #:make-flags
- #~(list (string-append "CC=" #$(cc-for-target))
- (string-append "PREFIX=" #$output))
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'allow-cross-compilation
- (lambda _
- (substitute* "Makefile"
- (("`uname -m`") #$(or (%current-target-system)
- (%current-system))))))
- (add-after 'allow-cross-compilation 'use-$CC-for-tests
- (lambda _
- (substitute* "tools/test.sh"
- (("cc=\"cc -no-pie\"") "cc=\"${CC} -no-pie\""))))
- (delete 'configure))))
- (supported-systems (list "x86_64-linux" "aarch64-linux" "riscv64-linux"))
- (synopsis "Simple compiler backend")
- (description
- "QBE is a small compiler backend using an SSA-based intermediate
+ (package
+ (name "qbe")
+ (version "1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://c9x.me/qbe")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qx4a3fjjrp2m4dsn19rpbjf89k9w7w7l09s96jx8vv15vzsdgis"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'allow-cross-compilation
+ (lambda _
+ (substitute* "Makefile"
+ (("`uname -m`") #$(or (%current-target-system)
+ (%current-system))))))
+ (add-after 'allow-cross-compilation 'use-$CC-for-tests
+ (lambda _
+ (substitute* "tools/test.sh"
+ (("cc=\"cc -no-pie\"") "cc=\"${CC} -no-pie\""))))
+ (delete 'configure))))
+ (supported-systems (list "x86_64-linux" "aarch64-linux" "riscv64-linux"))
+ (synopsis "Simple compiler backend")
+ (description
+ "QBE is a small compiler backend using an SSA-based intermediate
language as input.")
- (home-page "https://c9x.me/compile/")
- (license license:expat))))
+ (home-page "https://c9x.me/compile/")
+ (license license:expat)))
(define-public python-pcpp
(package
--
2.36.1
L
L
Liliana Marie Prikler wrote on 24 Jun 2022 08:17
ced024062eda52b6bb17323254b4010df25cb8f4.camel@ist.tugraz.at
Am Freitag, dem 24.06.2022 um 07:04 +0100 schrieb (:
Toggle quote (82 lines)
> * gnu/packages/c.scm (qbe): Update to 1.0.
> ---
>  gnu/packages/c.scm | 72 ++++++++++++++++++++++------------------------
>  1 file changed, 35 insertions(+), 37 deletions(-)
>
> diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
> index 3e49539473..2dc8adb895 100644
> --- a/gnu/packages/c.scm
> +++ b/gnu/packages/c.scm
> @@ -147,44 +147,42 @@ (define-public pcc
>      (license (list license:bsd-2 license:bsd-3))))
>  
>  (define-public qbe
> -  (let ((commit "2caa26e388b1c904d2f12fb09f84df7e761d8331")
> -        (revision "1"))
> -    (package
> -      (name "qbe")
> -      (version (git-version "0.0" revision commit))
> -      (source (origin
> -                (method git-fetch)
> -                (uri (git-reference
> -                      (url "git://c9x.me/qbe")
> -                      (commit commit)))
> -                (file-name (git-file-name name version))
> -                (sha256
> -                 (base32
> -                 
> "1gv03ym0gqrl4wkbhysa82025xwrkr1fg44z814b6vnggwlqgljc"))))
> -      (build-system gnu-build-system)
> -      (arguments
> -       (list #:make-flags
> -             #~(list (string-append "CC=" #$(cc-for-target))
> -                     (string-append "PREFIX=" #$output))
> -             #:phases
> -             #~(modify-phases %standard-phases
> -                 (add-after 'unpack 'allow-cross-compilation
> -                   (lambda _
> -                     (substitute* "Makefile"
> -                       (("`uname -m`") #$(or (%current-target-system)
> -                                             (%current-system))))))
> -                 (add-after 'allow-cross-compilation 'use-$CC-for-
> tests
> -                   (lambda _
> -                     (substitute* "tools/test.sh"
> -                       (("cc=\"cc -no-pie\"") "cc=\"${CC} -no-
> pie\""))))
> -                 (delete 'configure))))
> -      (supported-systems (list "x86_64-linux" "aarch64-linux"
> "riscv64-linux"))
> -      (synopsis "Simple compiler backend")
> -      (description
> -       "QBE is a small compiler backend using an SSA-based
> intermediate
> +  (package
> +   (name "qbe")
> +   (version "1.0")
> +   (source (origin
> +            (method git-fetch)
> +            (uri (git-reference
> +                  (url "git://c9x.me/qbe")
> +                  (commit (string-append "v" version))))
> +            (file-name (git-file-name name version))
> +            (sha256
> +             (base32
> +             
> "0qx4a3fjjrp2m4dsn19rpbjf89k9w7w7l09s96jx8vv15vzsdgis"))))
> +   (build-system gnu-build-system)
> +   (arguments
> +    (list #:make-flags
> +          #~(list (string-append "CC=" #$(cc-for-target))
> +                  (string-append "PREFIX=" #$output))
> +          #:phases
> +          #~(modify-phases %standard-phases
> +              (add-after 'unpack 'allow-cross-compilation
> +                (lambda _
> +                  (substitute* "Makefile"
> +                    (("`uname -m`") #$(or (%current-target-system)
> +                                          (%current-system))))))
> +              (add-after 'allow-cross-compilation 'use-$CC-for-tests
> +                (lambda _
> +                  (substitute* "tools/test.sh"
> +                    (("cc=\"cc -no-pie\"") "cc=\"${CC} -no-pie\""))))
I'm pretty sure you can drop this phase as of [1]. Nice to know that
Gentoo folk have our back.
Toggle quote (11 lines)
> +              (delete 'configure))))
> +   (supported-systems (list "x86_64-linux" "aarch64-linux" "riscv64-
> linux"))
> +   (synopsis "Simple compiler backend")
> +   (description
> +    "QBE is a small compiler backend using an SSA-based intermediate
>  language as input.")
> -      (home-page "https://c9x.me/compile/")
> -      (license license:expat))))
> +   (home-page "https://c9x.me/compile/")
> +   (license license:expat)))
(
CKYHFOFD6IUJ.245765AT0LHXN@guix-aspire
On Fri Jun 24, 2022 at 7:17 AM BST, Liliana Marie Prikler wrote:
Toggle quote (3 lines)
> I'm pretty sure you can drop this phase as of [1]. Nice to know that
> Gentoo folk have our back.

Oh, nice catch!

-- (
(
[PATCH v2] gnu: packages: qbe: Update to 1.0.
(address . 56181@debbugs.gnu.org)(name . ()(address . paren@disroot.org)
20220625143328.2477-1-paren@disroot.org
* gnu/packages/c.scm (qbe): Update to 1.0.
---
gnu/packages/c.scm | 68 +++++++++++++++++++++-------------------------
1 file changed, 31 insertions(+), 37 deletions(-)

Toggle diff (82 lines)
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 3e49539473..8cf7122fcc 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -147,44 +147,38 @@ (define-public pcc
(license (list license:bsd-2 license:bsd-3))))
(define-public qbe
- (let ((commit "2caa26e388b1c904d2f12fb09f84df7e761d8331")
- (revision "1"))
- (package
- (name "qbe")
- (version (git-version "0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://c9x.me/qbe")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1gv03ym0gqrl4wkbhysa82025xwrkr1fg44z814b6vnggwlqgljc"))))
- (build-system gnu-build-system)
- (arguments
- (list #:make-flags
- #~(list (string-append "CC=" #$(cc-for-target))
- (string-append "PREFIX=" #$output))
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'allow-cross-compilation
- (lambda _
- (substitute* "Makefile"
- (("`uname -m`") #$(or (%current-target-system)
- (%current-system))))))
- (add-after 'allow-cross-compilation 'use-$CC-for-tests
- (lambda _
- (substitute* "tools/test.sh"
- (("cc=\"cc -no-pie\"") "cc=\"${CC} -no-pie\""))))
- (delete 'configure))))
- (supported-systems (list "x86_64-linux" "aarch64-linux" "riscv64-linux"))
- (synopsis "Simple compiler backend")
- (description
- "QBE is a small compiler backend using an SSA-based intermediate
+ (package
+ (name "qbe")
+ (version "1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://c9x.me/qbe")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qx4a3fjjrp2m4dsn19rpbjf89k9w7w7l09s96jx8vv15vzsdgis"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'allow-cross-compilation
+ (lambda _
+ (substitute* "Makefile"
+ (("`uname -m`") #$(or (%current-target-system)
+ (%current-system))))))
+ (delete 'configure))))
+ (supported-systems (list "x86_64-linux" "aarch64-linux" "riscv64-linux"))
+ (synopsis "Simple compiler backend")
+ (description
+ "QBE is a small compiler backend using an SSA-based intermediate
language as input.")
- (home-page "https://c9x.me/compile/")
- (license license:expat))))
+ (home-page "https://c9x.me/compile/")
+ (license license:expat)))
(define-public python-pcpp
(package
--
2.36.1
L
L
Liliana Marie Prikler wrote on 25 Jun 2022 20:20
c3d1c21ebfe8be3e1efdfb63d86b3df9cc807520.camel@gmail.com
Am Samstag, dem 25.06.2022 um 15:33 +0100 schrieb (:
Toggle quote (2 lines)
> * gnu/packages/c.scm (qbe): Update to 1.0.
> ---
Fixed up indentation and pushed.

Thanks
Closed
?